Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot question
  • From: Stratos Zolotas <strzol@xxxxxxxxx>
  • Date: Thu, 9 Feb 2017 16:19:23 +0200
  • Message-id: <CAOvAxR=L1AejT3M59qxWUCwbM2k39e2KWDtjxG4LY8tEei8t+Q@mail.gmail.com>
Didn't know that. Thanks!

On Thu, Feb 9, 2017 at 4:18 PM, Richard Brown <RBrownCCB@xxxxxxxxxxxx> wrote:
On 9 February 2017 at 15:12, Stratos Zolotas <strzol@xxxxxxxxx> wrote:
On Thu, Feb 9, 2017 at 3:21 PM, Patrick Shanahan <paka@xxxxxxxxxxxx> wrote:

if "other repositories" means not the base openSUSE Tumbleweed repos, you
need "dup" and "--no-allow-verndor-change" as "up" causes problems, no
matter who does the configuring.

I don't know if I haven't understood something obvious but zypper dup
--no-allow-vendor-change doesn't work for me. It asks to change the
repo for some packman packages

sudo zypper dup --no-allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
8 Problems:
Problem: problem with installed package amarok-2.8.0-36.9.x86_64
Problem: problem with installed package libchromaprint1-1.3.1-30.7.x86_64
Problem: problem with installed package libguess1-1.2-11.10.x86_64
Problem: problem with installed package libkcddb16-16.07.0-5.7.x86_64
Problem: problem with installed package
libluajit-5_1-2-2.1.0~beta2-16.2.x86_64
Problem: problem with installed package libnfs-1.10.0-1.7.x86_64
Problem: problem with installed package libopencv3_1-3.1.0-88.30.x86_64
Problem: problem with installed package libsoxr0-0.1.2-12.7.x86_64

Problem: problem with installed package amarok-2.8.0-36.9.x86_64
Solution 1: install amarok-2.8.0-26.1.x86_64 (with vendor change)
http://packman.links2linux.de --> openSUSE

Choose the above solution using '1' or skip, retry or cancel [1/s/r/c] (c):

Choosing "skip" on all packages just recycles the procedure. Am I
missing something?

No, the correct option is 1

Amarok is no longer built for Tumbleweed by Packman

You should be getting it from openSUSE, just like zypper dup
--no-allow-vendor-change is telling you.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >