Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
[opensuse-factory] -debuginfo package naming change proposal


currently we have an inconsistency with naming debuginfo packages
for multilib packages (-32bit, -64bit).

Packages that build multilibs themselves like gcc produce for example
libgcc_s1-32bit to which then rpm appends -debuginfo to form
libgcc_s1-32bit-debuginfo. This is upstream rpm behavior.

Now we have another way of producing multilib packages, namely via
the baselibs.conf machinery which has a default rule to produce

This is inconsistent and results in gdb making invalid suggestions
about debuginfo packages to install (it suggests glibc-32bit-debuginfo
instead of glibc-debuginfo-32bit).

The proposal is to fix the SUSE specific baselibs.conf script to
instead produce X-32bit-debuginfo from X-debuginfo.

If there are no objections to this plan we'll go forward with this.


Richard Biener <rguenther@xxxxxxx>
SUSE LINUX GmbH, GF: Felix Imendoerffer, Jane Smithard, Graham Norton, HRB
21284 (AG Nuernberg)
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages