Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
Re: [opensuse-factory] s2disk = hibernate issues
  • From: nicholas <ndcunliffe@xxxxxxxxx>
  • Date: Thu, 26 Jan 2017 22:46:13 +0100
  • Message-id: <2116612.XF2e95Tq42@asus>
On Thursday, 26 January 2017 22:35:34 CET Peter Mc Donough wrote:
Am 26.01.2017 um 19:25 schrieb nicholas:
On Thursday, 26 January 2017 18:56:48 CET Peter Mc Donough wrote:
Am 26.01.2017 um 15:04 schrieb nicholas:
On Thursday, 26 January 2017 14:12:40 CET Peter Mc Donough wrote:
[...]

Jan 26 18:07:43 lux systemd-hibernate-resume[343]: Could not resume from
'/dev/sda1' (8:1).

[..]

you appear to have swap on sda2, whilst trying to resume from resume=/dev/
sda1? this should be simple to fix, could you first
CHECK your /etc/fstab entry for swap entry first, if given as uuid instead
of sda you can cross ref using something like blkid

You are right!
I recently repartitioned and moved swap from sda1 to sda2.

My Yast still doesn't like changing boot-parameters.
I thought I could fix it by going to /etc/default/grub and change
resume=/dev/sda1 to resume=dev/sda2

but after booting, it is still unchanged
cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.9.4-1-default
root=UUID=5e01abdd-40ef-48d5-b80e-0badb32669fe resume=/dev/sda1
splash=verbose quiet showopts

I can pick the UUID of swap from /etc/fstab, but how can I insert it
into the boot parameter if changing in /etc/default/grub doesn't work.
Or what am I missing ?

cu
Peter
you changed /etc/defualt/grub to read resume=/dev/sda2, then run grub2-mkconfig
-o /boot/grub2/grub.cfg ?? there is no reason it wouldnt work.

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups