Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
Re: [opensuse-factory] new package: xfce4-volumed-pulse
On Thu, 26 Jan 2017 09:35:55 +0100,
Stefan Seyfried wrote:

Hi all,

even though Takashi has fixed xfce4-mixer and xfce4-volumed to build with
gstreamer-1.0 (thanks!), I'd still like to
introduce the new upstream package xfce4-volumed-pulse, which is using
pulseaudio to get / set volume settings and
notify the user about changes (it presents a popup if e.g. with hotkeys the
volume is changed).

Devel project is X11:xfce, where all the other XFCE related packages

Thanks, it's good to have more PA coverage.

And this makes me wonder whether we should move more forward: namely,
add Recommends pulseaudio and related packages to XFCE patterns, and
drop the old xfce4-mixer and xfce4-volumed from patterns as well.

I guess removing recommends would be harmless for the already
installed systems, but adding recommends would drag the newer package
after zypper up?

Installing pulseaudio will switch the sound backend, per default, thus
it may bring inconsistencies when the system was already set up
without PA. Although you can run "setup-pulseaudio --disable" to get
back to non-PA system easily, it still needs a manual invocation.

Thoughts?


Takashi
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References