Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
Re: [opensuse-factory] TW Dist-upgrade: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) = 11.3
On Mon, 2017-01-23 at 08:50 +0100, Francesco Montesano wrote:
Hi,

I am trying to dist-upgrade TW from 20170110 -> 20170120 and I am
getting problems with python-kde4 and python-sip.

Problems:

Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
[...]

Problem: python-kde4-4.14.3-5.9.x86_64 requires python-sip(api) =
11.3, but this requirement cannot be provided
  deleted providers: python-sip-4.18.1-1.3.x86_64
 Solution 1: deinstallation of python-kdebase4-4.11.22-6.8.x86_64
 Solution 2: keep obsolete python-sip-4.18.1-1.3.x86_64
 Solution 3: break python-kde4-4.14.3-5.9.x86_64 by ignoring some of
its dependencies

python-kde4 is quite old - and surprising you still have this on your
machine - but the next snapshot should already bring the fix for this.

Cheers,
Dominique
< Previous Next >
Follow Ups
References