Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
Re: [opensuse-factory] 4.9+ kernel failure on toshiba satellite
* emanuel <emanuel.castelo@xxxxxxxxx> [01-20-17 08:46]:
On Thursday, January 19, 2017 2:01:35 PM PST Patrick Shanahan wrote:
I have a dual boot toshiba laptop which will not run > 4.8 kernels. It
began life as win 8 upgraded to 10 and shrunk to minimum. Then openSUSE
Tumbleweed. System is uefi and boots correctly (afaics) with 4.8 kernels
but all 4.9+ kernels immediately reboot after displaying "loading initial
ramdisk".

Adding "nomodeset" on boot line does not help. Nor does "dis_ucode_ldr".

tks,

see here for fix, https://bugzilla.suse.com/show_bug.cgi?id=1017783

tks, but bad news. Install failed for me, boot msg (from memory):
Loading initial ramdisk ...
error: you need to load the kernel first.

and from lack of attention and old force of habit, I installed the 4.9.2
kernel with rpm -Uvh and it removed my other kernels.

I have no idea about the error "you need to load the kernel first". I
thought zypper/rpm handled all of that.

luckily, one of my btrfs snapshots recovered my system to 4.8.14, albeit
several packages to upgrade.

tks
--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
Photos: http://wahoo.no-ip.org/gallery2 Registered Linux User #207535

Photos: http://wahoo.no-ip.org/piwigo @ http://linuxcounter.net
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups