Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot 20170112 - hanging Plasma, broken extended display
On Tue, Jan 17, 2017 at 5:49 AM, Tyler <Tyler_Kdog@xxxxxxxxx> wrote:
On 16/01/17 02:55 PM, Felix Miata wrote:

Preferred FOSS Xorg drivers have been transitioning[1] from discrete
gfxchip-specific to the generic modesetting driver that was moved from a
separate package directly into Xorg back in server 1.17. You might try
uninstalling the AMD/ATI/Radeon driver (xf86-video-ati)

[1] https://lists.opensuse.org/opensuse-factory/2017-01/msg00163.html


While the modesetting driver should work (and most certainly does for me),
do note the recently expressed opinion on what the "preferred" DDX for AMD
GPUs is: https://lwn.net/Articles/704883/

see if automatic use of the third display is restored



It won't be. Stratos is mistaken -- it is still the case that, with 2 GPUs,
you manually (or some configuration utility) must bridge the two together
via
"xrandr --setprovideroutputsource displays renders"


With the previous X version there was no need of this or a
configuration utility, as you say, was doing that automatically. Even
if sometimes kscreen was meshing the configuration layout (known KDE
issue), all 3 monitors (2 on primary GPU and one on the secondary)
were activated. After upgrading to X 1.19 the secondary GPU needs to
be activates with xrandr, so something changed.



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >