Mailinglist Archive: opensuse-factory (446 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161209 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161209

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager-openconnect (1.2.2 -> 1.2.4)
bash
clutter-gst (3.0.20 -> 3.0.22)
colord (1.3.3 -> 1.3.4)
corosync (2.4.1 -> 2.4.2)
filesystem
grep (2.26 -> 2.27)
gstreamer (1.8.3 -> 1.10.2)
gstreamer-plugins-bad (1.8.3 -> 1.10.2)
gstreamer-plugins-base (1.8.3 -> 1.10.2)
gstreamer-plugins-good (1.8.3 -> 1.10.2)
gstreamer-plugins-ugly (1.8.3 -> 1.10.2)
harfbuzz (1.3.3 -> 1.3.4)
hwinfo (21.37 -> 21.38)
libyui-ncurses-pkg (2.48.3 -> 2.48.4)
ncurses
rubygem-cfa (0.4.1 -> 0.4.2)
rubygem-cfa_grub2 (0.5.2 -> 0.5.3)
shim-leap
vala (0.34.3 -> 0.34.4)
yast2-bootloader (3.2.11 -> 3.2.12)
yast2-installation (3.2.10 -> 3.2.11)
yast2-network (3.2.15 -> 3.2.16)

=== Details ===

==== NetworkManager-openconnect ====
Version update (1.2.2 -> 1.2.4)
Subpackages: NetworkManager-openconnect-gnome

- Update to version 1.2.4:
+ Split libnm-vpn-plugin-openconnect.so into a GTK-free core
plugin usable by nmcli and a UI plugin for nm-applet and GNOME
components.
+ Support NM_VPN_LOG_LEVEL environment variable to control debug
logging from NetworkManager.
+ Support Juniper Network Connect / Junos Pulse Secure VPN.
+ Add Yubikey OATH support.
+ Added support for automatic login when all needed data is
known.
+ Fixed support for IPv6-only VPNs.
+ Updated translations.

==== bash ====
Subpackages: bash-doc libreadline7 readline-devel readline-doc

- Add upstream patch popd-offset-overflow.patch to fix boo#1010845
CVE-2016-9401: bash: popd controlled free (Segmentation fault)
Remark: this is a simple Segmentation fault, no security risk

==== clutter-gst ====
Version update (3.0.20 -> 3.0.22)
Subpackages: gstreamer-plugin-gstclutter-3_0 libclutter-gst-3_0-0
typelib-1_0-ClutterGst-3_0

- Update to version 3.0.22:
+ A couple of video sink fixes (crashes & not up-to-date data).
+ A bunch of content fixes.

==== colord ====
Version update (1.3.3 -> 1.3.4)
Subpackages: colord-lang libcolord2 libcolorhug2

- Update to version 1.3.4:
+ New Features:
- colord:
. Add cd_color_rgb_from_wavelength().
. Add cd_spectrum_resample_to_size().
- colorhug:
. Add commands for getting the device calibration spectra.
. Increase the size of the EP0 transfer.
. Support enabling the illuminants on the ColorHug+.
+ Bugfixes:
- Fix a possible NULL dereference when talking to Spark
devices.
- Fix compile with -Wformat-signedness.
- Fix possible division by zero if parsing /proc/cpuinfo fails.
- Install the libcolordcompat.so in the main -libs package.

==== corosync ====
Version update (2.4.1 -> 2.4.2)

- Corosync 2.4.1 still produces libvotequorum.so.7.0.0, just like Corosync
2.3.6.(bsc#1013842)
added: disable-build-html-docs.patch
upgrade to corosync-2.4.2:
Man: Fix corosync-qdevice-net-certutil link
man: mention qdevice incompatibilites in votequorum.5
Qnetd LMS: Fix two partition use case
cfg: Prevents use of uninitialized buffer

==== filesystem ====

- change /etc/cups to mode 0755 by cherry-picking SLE change

==== grep ====
Version update (2.26 -> 2.27)

- Update to grep 2.27
* grep no longer reports a false match in a multibyte, non-UTF8 locale
like zh_CN.gb18030, with a regular expression like ".*7" that just
happens to match the 4-byte representation of gb18030's \uC9, the
final byte of which is the digit "7".
* grep by default now reads all of standard input if it is a pipe,
even if this cannot affect grep's output or exit status.
* grep no longer mishandles ranges in nontrivial unibyte locales.
* grep -P no longer attempts multiline matches.
* grep -m0 -L PAT FILE now outputs "FILE".
* To output ':' and tab-align the following character C, grep -T no
longer outputs tab-backspace-':'-C, an approach that has problems if
run inside an Emacs shell window.
* grep -T now uses worst-case widths of line numbers and byte offsets
instead of guessing widths that might not work with larger files.
* grep no longer reads the input in a few more cases when it is easy to
see that matching cannot succeed, e.g., 'grep -f /dev/null'.

==== gstreamer ====
Version update (1.8.3 -> 1.10.2)
Subpackages: gstreamer-devel gstreamer-utils libgstreamer-1_0-0
libgstreamer-1_0-0-32bit typelib-1_0-Gst-1_0

- Update to version 1.10.2:
+ Minor bugfixes.
+ Updated translations.
- Update to version 1.10.1:
+ Security-relevant bugfix in the vmnc decoder (no CVE).
+ Various bugfixes to playbin3/decodebin3.
+ Fix error at the end of playing any WAV file.
+ Fix usability of androidmedia plugin if the camera or sensor
API is not available, but codecs are.
+ Handle redirections on PLAY, and missing control attribute in
the RTSP source.
+ Various OpenGL related bugfixes and many, many more.
+ Bugs fixed: bgo#765662, bgo#773813, bgo#774044, bgo#774108.
- Update to version 1.10.0:
+ Several convenience APIs have been added to make developers'
lives easier.
+ A new GstStream API provides applications a more meaningful
view of the structure of streams, simplifying the process of
dealing with media in complex container formats.
+ Experimental decodebin3 and playbin3 elements which bring a
number of improvements which were hard to implement within
decodebin and playbin.
+ A new parsebin element to automatically unpack and parse a
stream, stopping just short of decoding.
+ Experimental new meson-based build system, bringing faster
build and much better Windows support (including for building
with Visual Studio).
+ A new gst-docs module has been created, and we are in the
process of moving our documentation to a markdown-based format
for easier maintenance and updates.
+ A new gst-examples module has been create, which contains
example GStreamer applications and is expected to grow with
many more examples in the future.
+ Various OpenGL and OpenGL|ES-related fixes and improvements for
greater efficiency on desktop and mobile platforms, and Vulkan
support on Wayland was also added.
+ Extensive improvements to the VAAPI plugins for improved
robustness and efficiency.
+ Lots of fixes and improvements across the board, spanning
RTP/RTSP, V4L2, Bluetooth, audio conversion, echo cancellation,
and more!
+ Bugs fixed: bgo#770627, bgo#772431, bgo#772571, bgo#772741,
bgo#772851, bgo#773114, bgo#773319.
+ Updated translations.
- Add pkgconfig(libunwind) BuildRequires: New dependency.
- Add explicit pkgconfig BuildRequires for completeness.

==== gstreamer-plugins-bad ====
Version update (1.8.3 -> 1.10.2)
Subpackages: libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0 libgstbadbase-1_0-0
libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstgl-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0

- Update to version 1.10.2:
+ Bugs fixed: bgo#774624, bgo#774702, bgo#774851, bgo#774896,
bgo#775048, bgo#775120, bgo#775127, bgo#775130.
- Update to version 1.10.1:
+ Bugs fixed: bgo#773681, bgo#773313, bgo#774287, bgo#774328,
bgo#774462.
- Update to version 1.10.0:
+ Bugs fixed: bgo#758717, bgo#762717, bgo#769382, bgo#770528,
bgo#770587, bgo#772330, bgo#772499, bgo#772503, bgo#772698,
bgo#772699, bgo#772704, bgo#772706, bgo#772742, bgo#773026,
bgo#773423, bgo#773540, bgo#773635, bgo#773720, bgo#772608.
+ Updated translations.
- Rebase gstreamer-plugins-bad-patch-source.sh.
- Package new plugins: musepack and timecode.
- Replace disabled pkgconfig(slv2) BuildRequires with
pkgconfig(lilv-0), and enabled it following upstream changes.
Drop bcond_with lv2 and move built plugin to main package, all
dependencies are now available in openSUSE.
- Add disabled pkgconfig(graphene-1.0) BuildRequires, new optional
dependency, not yet available in openSUSE.
- Add pkgconfig(webrtc-audio-processing) BuildRequires: Build
webrtcdsp plugin.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Add pkgconfig(gstreamer-allocators-1.0), pkgconfig(libdrm) and
pkgconfig(libkms) BuildRequires: Build new kmssink plugin, mainly
targeted for embedded systems.

==== gstreamer-plugins-base ====
Version update (1.8.3 -> 1.10.2)
Subpackages: libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0
libgstaudio-1_0-0-32bit libgstfft-1_0-0 libgstpbutils-1_0-0 libgstriff-1_0-0
libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0
libgsttag-1_0-0-32bit libgstvideo-1_0-0 libgstvideo-1_0-0-32bit
typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0
typelib-1_0-GstVideo-1_0

- Update to version 1.10.2:
+ Bugs fixed: bgo#774911, bgo#774585, bgo#774902, bgo#775224.
- Update to version 1.10.1:
+ Bugs fixed: bgo#773131, bgo#774322, bgo#774343, bgo#727802.
- Update to version 1.10.0:
+ Bugs fixed: bgo#768763, bgo#772500, bgo#772501, bgo#772676,
bgo#772855, bgo#773103, bgo#773105, bgo#773107, bgo#773181,
bgo#773441.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Disable aarch64-no-neon.patch: It needs a rebase, or may possibly
be dropped as fixed upstream.

==== gstreamer-plugins-good ====
Version update (1.8.3 -> 1.10.2)
Subpackages: gstreamer-plugins-good-extra

- Update to version 1.10.2:
+ Bugs fixed: bgo#757292, bgo#774428, bgo#774834, bgo#774859,
bgo#774897, bgo#775219.
- Update to version 1.10.1:
+ Bugs fixed: bgo#769765, bgo#770568, bgo#772610, bgo#773269,
bgo#773512, bgo#773515, bgo#773516, bgo#773784, bgo#773861,
bgo#774507, bgo#774556.
- Update to version 1.10.0:
+ Bugs fixed: bgo#762207, bgo#772496, bgo#772497, bgo#772644,
bgo#772656, bgo#773509, bgo#773580, bgo#773582, bgo#773643.
+ Updated translations.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Drop gstreamer-plugins-good-wavparse.patch: Fixed upstream.
- Stop passing --enabel-gtk to configure, no longer needed nor
recognized.
- Move monoscape plugin to extra subpackage as it is an
experimental plugin.

==== gstreamer-plugins-ugly ====
Version update (1.8.3 -> 1.10.2)

- Update to version 1.10.2:
+ Bugs fixed: bgo#774846, bgo#775070.
- Update to version 1.10.1:
+ Meson update.
+ Updated translations.
- Update to version 1.10.0:
+ Bugs fixed: bgo#773114, bgo#772159, bgo#770158, bgo#769610,
bgo#769418, bgo#765807, bgo#769116, bgo#763082.
+ Updated translations.

==== harfbuzz ====
Version update (1.3.3 -> 1.3.4)
Subpackages: harfbuzz-devel libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- Update to version 1.3.4:
+ Fix vertical glyph origin in hb-ot-font.
+ Implement CBDT/CBLC color font glyph extents in hb-ot-font.

==== hwinfo ====
Version update (21.37 -> 21.38)
Subpackages: hwinfo-devel

- increase version
- simplify code in smbios_get_info()
- look for smbios entry point also in efi settings (bsc#1010276)
- 21.38

==== libyui-ncurses-pkg ====
Version update (2.48.3 -> 2.48.4)

- Sort pkg list case-insensitively (bsc#1012294)
- Prevent double sorting (widget sorts by itself)
- 2.48.4

==== ncurses ====
Subpackages: libncurses5 libncurses6 libncurses6-32bit ncurses-devel
ncurses-utils tack terminfo terminfo-base

- Add ncurses patch 20161126
+ modify linux-16color to not mask dim, standout or reverse with the
ncv capability -TD
+ add 0.1sec mandatory delay to flash capabilities using the VT100
reverse-video control -TD
+ omit selection of ISO-8859-1 for G0 in enacs capability from linux2.6
entry, to avoid conflict with the user-defined mapping. The reset
feature will use ISO-8859-1 in any case (Mikulas Patocka).
+ improve check in tic for delays by also warning about beep/flash
when a delay is not embedded, or if those use the VT100 reverse
video escape without using a delay.
+ minor fix for syntax-check of delays from 20161119 changes.
+ modify trace() to avoid overwriting existing file (report by Maor
Shwartz).
- Add ncurses patch 20161112
+ improve -W option in tic/infocmp:
+ correct order of size-adjustments in wrapped lines
+ if -f option splits line, do not further split it with -W
+ begin a new line when adding "use=" after a wrapped line
- Add ncurses patch 20161119
+ add check in tic for some syntax errors of delays, as well as use of
proportional delays for non-line capabilities.
+ document history of the clear program and the E3 extension, prompted
by various discussions including

http://unix.stackexchange.com/questions/87469/clearing-the-old-scrollback-buffer

==== rubygem-cfa ====
Version update (0.4.1 -> 0.4.2)

- Improve deletion of elements in the augeas parser (needed to
fix ntp-client, bsc#983486)
- 0.4.2

==== rubygem-cfa_grub2 ====
Version update (0.5.2 -> 0.5.3)

- Use correct configuration file for xen kernel parameters
(bsc#1012503)
- 0.5.3

==== shim-leap ====

- New signature from Microsoft
- shim-install : fix regression of password prompt (bsc#993764)
- Add shim-bsc991885-fix-sig-length.patch to fix the signature
length passed to Authenticode (bsc#991885)
- Update shim-bsc973496-mokmanager-no-append-write.patch to try
append write first
- Add shim-update-openssl-1.0.2h.patch to update openssl to 1.0.2h
- Bump the requirement of gnu-efi due to the HTTPBoot support
- Add shim-httpboot-support.patch to support HTTPBoot
- Add shim-update-openssl-1.0.2g.patch to update openssl to 1.0.2g
and Cryptlib to 5e2318dd37a51948aaf845c7d920b11f47cdcfe6
- Drop patches since they are merged into
shim-update-openssl-1.0.2g.patch
+ shim-update-openssl-1.0.2d.patch
+ shim-gcc5.patch
+ shim-bsc950569-fix-cryptlib-va-functions.patch
+ shim-fix-aarch64.patch
- Refresh shim-change-debug-file-path.patch
- Add shim-bsc973496-mokmanager-no-append-write.patch to work
around the firmware that doesn't support APPEND_WRITE (bsc973496)
- shim-install : remove '\n' from the help message (bsc#991188)
- shim-install : print a message if there is no valid EFI partition
(bsc#991187)
- shim-install : support simple MD RAID1 target devices (FATE#314829)
- Add shim-fix-aarch64.patch to fix compilation on AArch64 (bsc#978438)
- shim-install : fix typing ESC can escape to parent config which is
in command mode and cannot return back (bsc#966701)
- shim-install : fix no which command for JeOS (bsc#968264)

==== vala ====
Version update (0.34.3 -> 0.34.4)
Subpackages: libvala-0_34-0

- Update to version 0.34.4:
+ Bug fixes.

==== yast2-bootloader ====
Version update (3.2.11 -> 3.2.12)

- stop failing with new cfa ( caused by deleting nil, change
in cfa needed for bsc#983486 )
- 3.2.12

==== yast2-installation ====
Version update (3.2.10 -> 3.2.11)

- Do not crash when the proposal screen is configured through
an AutoYaST profile and tabs are not being used (bsc#1013976)
- 3.2.11

==== yast2-network ====
Version update (3.2.15 -> 3.2.16)

- bnc#1013684
- do not crash with internal error when setting static setup for
newly added device
- 3.2.16

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages