Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] openSUSE Leap 42.2 request to include perl-Perl-Critic
Hi,

would it be possible to submit perl-Perl-Critic into Leap 42.2?

For Leap 42.1 it exists in the repo devel:languages:perl [1]

I tried to install it from there and only a few requirements are
missing from the official distribution:
# rpm -Uhv perl-Perl-Critic-1.126-40.2.noarch.rpm
perl(PPIx::Regexp) >= 0.027 is needed by
perl-Perl-Critic-1.126-40.2.noarch

perl(PPIx::Utilities::Node) >= 1.001
is needed by perl-Perl-Critic-1.126-40.2.noarch

perl(PPIx::Utilities::Statement) >= 1.001 is needed by
perl-Perl-Critic-1.126-40.2.noarch

perl(Pod::Spell) >= 1 is needed by
perl-Perl-Critic-1.126-40.2.noarch

perl(Readonly) >= 2 is needed by
perl-Perl-Critic-1.126-40.2.noarch

These requirements are provided by
perl-PPIx-Regexp-0.050-52.1.noarch.rpm
perl-Pod-Spell-1.20-41.1.noarch.rpm
perl-PPIx-Utilities-1.001000-22.1.noarch.rpm
perl-Readonly-2.04-65.1.noarch.rpm
which are also available in devel:languages:perl. They can be installed
without creating additional dependencies to packages not yet in the
official distribution.

perl-Perl-Critic is available in Tumbleweed, it and the missing packages
are noarch and can therefore probably "just" be included.

I also checked the update repos 12.1 to 13.2 - these openSUSE
versions included perl-Perl-Critic - and there were never updates
for it, so probably it would also not create future maintenance effort
once included.

Thanks and regards,
Dieter

[1]
http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.1/noarch/perl-Perl-Critic-1.126-40.2.noarch.rpm

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups