Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160524 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160524

Packages changed:
ImageMagick (6.9.3.10 -> 6.9.4.1)
Mesa
MozillaFirefox
PackageKit
appstream-glib (0.5.14 -> 0.5.15)
atril (1.14.0 -> 1.14.1)
augeas (1.4.0 -> 1.5.0)
autoyast2 (3.1.126 -> 3.1.128)
bash-completion
calligra
digikam
evince
exiv2
freerdp (1.0.2 -> 2.0.0~git.1463131968.4e66df7)
gdm
git (2.8.2 -> 2.8.3)
glyr (1.0.8 -> 1.0.9)
gnome-contacts (3.19.91 -> 3.20.0)
gnome-documents
gnome-sudoku (3.20.1 -> 3.20.2)
gnome-terminal
grub2
installation-images-openSUSE (14.243 -> 14.245)
lensfun (0.3.1 -> 0.3.2)
libXScrnSaver
libbluray (0.9.2 -> 0.9.3)
libseccomp (2.3.0 -> 2.3.1)
libvirt
libxcb (1.11.1 -> 1.12)
llvm
mate-desktop (1.14.0 -> 1.14.1)
mercurial (3.8.1 -> 3.8.2)
mutt
netcontrol (0.3.0 -> 0.3.1)
obs-service-tar_scm (0.5.3.1434983686.0b4ce51 -> 0.6.0~pre.1461681073.57c0bab)
parted
patterns-openSUSE
pciutils (3.4.1 -> 3.5.0)
plasma-nm5
postgresql94 (9.4.6 -> 9.4.8)
postgresql94-libs (9.4.6 -> 9.4.8)
python-cffi (1.4.2 -> 1.5.2)
python-pyOpenSSL (0.15.1 -> 16.0.0)
python-pyserial (2.7 -> 3.0.1)
python-sip (4.17 -> 4.18)
python3-sip (4.17 -> 4.18)
qscintilla (2.9.1 -> 2.9.2)
rtkit
solid
speech-dispatcher (0.8.3 -> 0.8.4)
sqlite3 (3.12.2 -> 3.13.0)
sysconfig (0.83.8 -> 0.83.9)
system-config-printer
update-alternatives
viewvc
virtualbox
vlc
wicked (0.6.33 -> 0.6.34)
xcb-proto (7.6_1.11 -> 7.6_1.12)
xf86-input-synaptics
xf86-input-wacom
yast2-bootloader (3.1.183 -> 3.1.187)
yast2-network (3.1.149 -> 3.1.151)

=== Details ===

==== ImageMagick ====
Version update (6.9.3.10 -> 6.9.4.1)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-6_Q16-6
libMagickCore-6_Q16-2 libMagickWand-6_Q16-2 perl-PerlMagick

- updated to 6.9.4-1:
* Remove https delegate.
* Check for buffer overflow in magick/draw.c/DrawStrokePolygon().
* Replace show delegate title with image filename rather than label.
* Fix GetNextToken() off by one error.
* Remove support for internal ephemeral coder.
- refreshed ImageMagick-6.8.8-1-disable-insecure-coders.patch
- believe or not, correct license string is ImageMagick:
http://spdx.org/licenses/ImageMagick.html
- rework ImageMagick-6.8.8-1-disable-insecure-coders.patch
* add new policy (TEXT, SHOW, WIN and PLT)
- rebase patches (p0)
* ImageMagick-6.6.8.9-doc.patch
* ImageMagick-6.6.8.9-examples.patch
* ImageMagick-6.7.6.1-no-dist-lzip.patch
* ImageMagick-6.8.4.0-dont-build-in-install.patch
* ImageMagick-6.8.4.0-rpath.patch
* ImageMagick-6.8.5.7-no-XPMCompliance.patch
* ImageMagick-6.8.8-1-disable-insecure-coders.patch

==== Mesa ====
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
Mesa-libva libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1
libgbm1-32bit libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- u_glxcmds-glXGetFBConfigs-fix-screen-bounds.patch:
Fix crash due to oud of founds screen (boo#980382).

==== MozillaFirefox ====
Subpackages: MozillaFirefox-translations-common

- enable build with PIE and full relro on x86_64 (boo#980384)

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module libpackagekit-glib2-18 typelib-1_0-PackageKitGlib-1_0

- Drop docbook-utils BuildRequires: No longer needed for man pages
building.

==== appstream-glib ====
Version update (0.5.14 -> 0.5.15)
Subpackages: libappstream-builder8 libappstream-glib8

- Update to version 0.5.15:
+ trivial: post release version bump.
+ Add AS_APP_QUIRK_HAS_SHORTCUT.
+ trivial: Try to shut up libasn.
+ Ignore files with invalid suffixes when building installed
stores.
+ Add AS_APP_QUIRK_NOT_LAUNCHABLE.
+ trivial: Add three more apps to the ID fallback table.
+ trivial: Fix a critical warning when an AppData file has
invalid input.
+ Fall back to the icon name for LOCAL icon types.
+ yaml: Make icon parser spec compliant.
+ trivial: Add a work-around for the new libreoffice in the
builder.
+ trivial: Set missing icon prefix for cached YAML.
+ Sort archive contents by name for repeatable results.
+ Omit timestamp from gzip compressed files.
+ README.md: add note for glob usage.
+ README.md: wrap at 80 chars.
+ trivial: Add some more debugging to debug an issue.
+ Rename the xdg-app support to the new name: Flatpak.
+ trivial: Add some support for flatpak self tests.
+ Addons can have duplcate names.
+ Show the app name when complaining about missing description in
the metadata.
+ Revert "trivial: Add some support for flatpak self tests".
+ Always add /var/lib/flatpak/appstream as a possible Flatpak
path.
+ Add all applications for all architectures when loading
Flatpak.
+ Set the architecture of discovered Flatpak apps.
+ Correctly set the architecture on newly discovered
applications.
+ Save the ID prefix in more places.
+ Release version 0.5.15.
- Drop 0001-Omit-timestamp-from-gzip-compressed-files.patch and
0001-Sort-archive-contents-by-name-for-repeatable-results.patch:
fixed upstream.
- Make output of appstream-builder repeatable (boo#977885):
+ 0001-Sort-archive-contents-by-name-for-repeatable-results.patch
+ 0001-Omit-timestamp-from-gzip-compressed-files.patch

==== atril ====
Version update (1.14.0 -> 1.14.1)
Subpackages: atril-backends atril-lang libatrildocument3 libatrilview3

- Update to version 1.14.1:
* Fix several random webview related crashes.
* Update translations.

==== augeas ====
Version update (1.4.0 -> 1.5.0)
Subpackages: augeas-lenses libaugeas0

- Update to version 1.5.0:
- General changes/additions
* augtool: new --timing option that prints after each operation how long
it took
* augtool: print brief help message when incorrect options are given rather
than dumping all help text
* Path expressions: optimize performance of evaluating certain
expressions
* lots of safety improvements in libfa to avoid using uninitialized
values and the like (Daniel Trebbien)
* tolerate building against OSX' libedit (Issue #256)
- API changes
* aug_match: fix a bug where expressions like /foo/*[2] would match a
hidden node and pretend there was no match at all. We now make sure
we never match a hidden node. Thanks to Xavier Mol for reporting the
problem.
* aug_get: make sure we set *value to NULL, even if the provided path is
invalid (Issue #372)
* aug_rm: fix segfault when deleting a tree and one of its ancestors
(Issue #319)
* aug_save: fix segfault when trying to save an invalid subtree. A
routine that was generating details for the error message overflowed
a buffer it had created (Issue #349)
- Lens changes/additions
* AptConf: support hash comments
* AptSources: support options (Issue #295),
support brackets with spaces in URI (GH #296)
rename test file to test_aptsources.aug
* Chrony: allow signed numbers and indentation, fix stray EOL entry,
disallow comment on EOL, add many missing directives and
options (Miroslav Lichvar, RHBZ#1213281)
add new directives and options that were added in
chrony-2.2 and chrony-2.3 and improve parsing of
access configuration (Miroslav Lichvar, Issue #348)
add new options for chrony-2.4 (Miroslav Lichvar)
* Dhclient: avoid put ambiguity for node without value (Issue #294)
* Group: support NIS map, support an overridden and disabled password,
i.e. `+:*::` (Matt Dainty) (Issue #258)
* Host_Conf: support spaces between list items (Cedric Bosdonnat, Issue #358)
* Httpd: add paths to SLES vhosts
(Jan Doleschal) (Issue #268)
parse backslashes in directive arguments (Issue #307)
parse mismatching case of opening/closing tags
parse multiple ending section tags on one line
parse wordlists in braces in SSLRequire directives
parse directive args starting with double quote (Issue #330)
parse directive args containing quotes
support perl directives (Issue #327)
parse line breaks/continuations in section arguments
parse escaped spaces in directive/section arguments
parse backslashes at the start of directive args (Issue #324)
* Inputrc: support $else (Cedric Bosdonnat, Issue #359)
* Interfaces: add support for source-directory (Issue #306)
* Json: add comments support, refactor,
allow escaped quotes and blackslashes
* Keepalived: fix space/tag alignments and hanging spaces,
add vrrp_mcast_group4 and vrrp_mcast_group6,
add more vrrp_instance flags,
add mcast/unicast_src_ip and unicast_peer,
add missing garp options,
add vrrp_script options,
expand vrrp_sync_group block,
allow notify option
(Joe Topjian) (Issue #266)
* Known_Hosts: refactoring and description fixed
* Logrotate: support dateyesterday option (Chris Reeves) (GH #367, #368)
* MasterPasswd: new lens to parse /etc/master.passwd
(Matt Dainty) (Issue #258)
* Multipath: add various missing keywoards (Olivier Mangold) (Issue #289)
* MySQL: include /etc/my.cnf.d/*.cnf (Issue #353)
* Nginx: improve typechecking of lens,
allow masks in IP keys and IPv6 (Issue #260)
add @server simple nodes (Issue #335)
* Ntp: add support for basic interface syntax
* OpenShift_Quickstarts: Use Json.lns
* OpenVPN: add all options available in OpenVPN 2.3o
(Justin Akers) (Issue #278)
* Puppetfile: name separator is not mandatory
add support for moduledir (Christoph Maser)
* Rabbitmq: remove space in option name,
add support for cluster_partitioning_handling,
add missing simple options (Joe Topjian) (Issue #264)
* Reprepro_Uploaders: add support for distribution field
(Mathieu Alorent) (Issue #277),
add support for groups (Issue #283)
* Rhsm: new lens to parse subscription-manager's /etc/rhsm/rhsm.conf
* Rsyslog: improve property filter parsing,
treat whitespace after commas as optional.
recognize '~' as a valid syslog action (discard)
(Gregory Smith) (Issue #282),
add support for redirecting output to named pipes
(Gerlof Fokkema) (Issue #366)
* Shellvars: allow partial quoting, mixing multiple styles
(Kaarle Ritvanen) (Issue #183);
allow wrapping builtin argument to multiple lines
(Kaarle Ritvanen) (Issue #184);
support ;; on same line with multiple commands
(Kaarle Ritvanen) (Issue #185);
allow line wrapping and improve quoting support
(Kaarle Ritvanen) (Issue #187);
accept [] and [[]] builtins (Issue #188);
allow && and || constructs after condition
(Kaarle Ritvanen) (Issue #265);
add pattern nodes in case entries
(BREAKING CHANGE: case entry values are now in a
@pattern subnode) (Kaarle Ritvanen) (Issue #265)
add eval builtin support;
add alias builtin support;
allow (almost) any command;
allow && and || after commands (Issue #215);
allow wrapping command sequences
(Kaarle Ritvanen) (Issue #333);
allow command-specific environment variable
(Kaarle Ritvanen) (Issue #332);
support subshells (Issue #339)
newlines in start of functions
allow newlines after actions
support comments after function name (Issue #339)
exclude SuSEfirewall2 (Cedric Bosdonnat, Issue #357)
* Simplelines: parse OpenBSD's hostname.if(5)
files (Jasper Lievisse Adriaanse) (Issue #252)
* Smbusers: add support for ; comments
* Spacevars: support flags (Issue #279)
* Ssh: add support for HostKeyAlgorithms, KexAlgorithms
and PubkeyAcceptedKeyTypes (Oliver Mangold) (Issue #290),
add support for GlobalKnownHostsFile (Issue #316)
* Star: New lens to parse /etc/default/star
* Sudoers: support for negated command alias
(Geoff Williams) (Issue #262)
* Syslog: recognize '~' as a valid syslog action (discard)
(Gregory Smith) (Issue #282)
* Tmpfiles: new lens to parse systemd's tempfiles.d configuration
files (Julien Pivotto) (Issue #269)
* Trapperkeeper: new lens for Puppet server configuration files
* Util: add comment_c_style_or_hash lens
add empty_any lens
* Vsftpd: add isolate and isolate_network options
(Florian Chazal) (Issue #334)
* Xml: allow empty document (Issue #255)
* YAML: new lens (subset) (Dimitar Dimitrov) (Issue #338)
- Drop upstreamed patches:
27d8457-inputrc-lens-support-mapping-like.patch
2d12670-inputrc-lens-support-else.patch
49bcfbe-Exclude-network-if-up.d-SuSEfirewall2-in-shellvars-l.patch
7558c12-host_conf-lens-spaces-between-list-items-support.patch

==== autoyast2 ====
Version update (3.1.126 -> 3.1.128)
Subpackages: autoyast2-installation

- Unsupported sections will be now reported in first installation
stage. Reducing log level to warning.
(Additional patch for bnc#955878)
- 3.1.128
- Resetting package selection of previous runs. This is needed
because it could be that additional repositories are available
meanwhile. (bnc#979691)
- 3.1.127

==== bash-completion ====

- Split off sub packages devel and doc to avoid dependency cycles
- Remove completions conflicting with util-linux (boo#977259#c3).
- Add patch sh-script-completion-boo977336.patch to make _filedir
work with COMP_FILEDIR_FALLBACK even if local directries exists
this is for bug boo##977336
- Add documentation for this packages below to get the reference
of the e.g. the variable COMP_FILEDIR_FALLBACK (boo#977336)

==== calligra ====
Subpackages: calligra-extras-dolphin calligra-extras-okular calligra-stage
calligra-words-common

- Move words.appdata.xml from -words-common to -words, where also
the respective .desktop file is packaged.

==== digikam ====
Subpackages: digikam-lang digikam-libs digikam-plugin-color
digikam-plugin-decorate digikam-plugin-enhance digikam-plugin-fxfilters
digikam-plugin-transform kipi-plugins kipi-plugins-acquireimage
kipi-plugins-geolocation kipi-plugins-lang

- Add patch digikam-4.14.0-lensfun-0.3.2.patch to make digikam
build with the latest lensfun version

==== evince ====
Subpackages: evince-browser-plugin evince-plugin-comicsdocument
evince-plugin-djvudocument evince-plugin-dvidocument evince-plugin-pdfdocument
evince-plugin-psdocument evince-plugin-tiffdocument evince-plugin-xpsdocument
libevdocument3-4 libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0

- Add evince-fix-deprecated-warning.patch: Fix deprecation warning
(boo#980576, bgo#980576).
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.

==== exiv2 ====
Subpackages: libexiv2-14 libexiv2-devel

- add exiv2_r3889_r3890_fix_boo964344.diff (taken from revisions linked
in http://dev.exiv2.org/issues/1106) to fix crash in darktable (boo#964344)

==== freerdp ====
Version update (1.0.2 -> 2.0.0~git.1463131968.4e66df7)

- Kill off __DATE__ from built sources.
- Add obs git integration.
- Update to version 2.0.0git.1463131968.4e66df7:
+ Fixed memory leaks.
+ wfreerdp: fix name build without client interface
+ libfreerdp-codec: fix xcrush decompression, revert remote control fix
+ KB3153731: May 2016 DST update for Azerbaijan, Chile, Haiti and Morocco
+ libfreerdp-codec: make proper xcrush context reset fix
- Update to version 2.0.0, git master branch id a7ca42e (FATE#319661),
no upstream changelog available.
* Warning: This is a git snapshot regarded as technical preview
by upstream.
* Warning: For xfreerdp, new /long-option commandline interfaces
have replaced the old --long-option interfaces. Existing user
scripts need to migrate to the new interfaces to avoid breakages.
For more details, see:
https://github.com/FreeRDP/FreeRDP/wiki/CommandLineInterface
* Add Network Level Ahthentication support.
* Add Windows Portable Runtime. For more details, see:
http://www.freerdp.com/2012/05/24/winpr-windows-portable-runtime
* Obsolete libfreerdp-1_0-plugins.
- Drop FindALSA.cmake: deprecated
- Drop freerdp_branch-1.0.x_fix-kpdivide-issue831.patch:
fixed upstream, implemention now in include/freerdp/scancode.h.
- Drop freerdp-CVE-2014-0250.patch (bnc#880317):
fixed upstream 532c420.
- Drop freerdp-CVE-2014-0791.patch (bnc#857491):
fixed upstream f1d6afc.
- Drop freerdp-fix-FindPCSC-macro.patch:
fixed upstream 9148af3.
- Drop freerdp-handle-null-device-name.patch (bnc#785437):
deprecated, related implementation dropped.
was: freerdp-fix-pulse-no-device-name.patch

==== gdm ====
Subpackages: gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Drop insserv_cleanup call in %postun and %insserv_prereq macro
in preamble.

==== git ====
Version update (2.8.2 -> 2.8.3)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.8.3:
* "git send-email" now uses a more readable timestamps when
formulating a message ID.
* When "git worktree" feature is in use, "git branch -d" allowed
deletion of a branch that is checked out in another worktree
* When "git worktree" feature is in use, "git branch -m" renamed a
branch that is checked out in another worktree without adjusting
the HEAD symbolic ref for the worktree.
* "git format-patch --help" showed `-s` and `--no-patch` as if these
are valid options to the command. We already hide `--patch` option
from the documentation, because format-patch is about showing the
diff, and the documentation now hides these options as well.
* A change back in version 2.7 to "git branch" broke display of a
symbolic ref in a non-standard place in the refs/ hierarchy (we
expect symbolic refs to appear in refs/remotes/*/HEAD to point at
the primary branch the remote has, and as .git/HEAD to point at the
branch we locally checked out).
* A partial rewrite of "git submodule" in the 2.7 timeframe changed
the way the gitdir: pointer in the submodules point at the real
repository location to use absolute paths by accident. This has
been corrected.
* "git commit" misbehaved in a few minor ways when an empty message
is given via -m '', all of which has been corrected.
* Support for CRAM-MD5 authentication method in "git imap-send" did
not work well.
* The socks5:// proxy support added back in 2.6.4 days was not aware
that socks5h:// proxies behave differently.
* "git config" had a codepath that tried to pass a NULL to
printf("%s"), which nobody seems to have noticed.
* "git replace -e" did not honour "core.editor" configuration.
* "git submodule" reports the paths of submodules the command
recurses into, but this was incorrect when the command was not run
from the root level of the superproject.
* The "user.useConfigOnly" configuration variable makes it an error
if users do not explicitly set user.name and user.email. However,
its check was not done early enough and allowed another error to
trigger, reporting that the default value we guessed from the
system setting was unusable. This was a suboptimal end-user
experience as we want the users to set user.name/user.email without
relying on the auto-detection at all.
* "git mv old new" did not adjust the path for a submodule that lives
as a subdirectory inside old/ directory correctly.
* "git push" from a corrupt repository that attempts to push a large
number of refs deadlocked; the thread to relay rejection notices
for these ref updates blocked on writing them to the main thread,
after the main thread at the receiving end notices that the push
failed and decides not to read these notices and return a failure.
* A question by "git send-email" to ask the identity of the sender
has been updated.
* Recent update to Git LFS broke "git p4" by changing the output from
its "lfs pointer" subcommand.
* Some multi-byte encoding can have a backslash byte as a later part
of one letter, which would confuse "highlight" filter used in
gitweb.

==== glyr ====
Version update (1.0.8 -> 1.0.9)

- Update to 1.0.9.
* Bugfixes:
+ Support reproducible builds.
+ Build problems.
+ Spelling errors.
* Fixed providers:
+ lyrics/lyricswikia.
+ cover/slothradio.
+ cover/discogs.
- Drop glyr-version.patch: fixed upstream.
- Don't package CHANGELOG. It is obsolete and discontinued.

==== gnome-contacts ====
Version update (3.19.91 -> 3.20.0)
Subpackages: gnome-shell-search-provider-contacts

- Update to version 3.20.0:
+ Updated translations.

==== gnome-documents ====
Subpackages: gnome-documents_books-common gnome-shell-search-provider-documents

- Reenble dependency on libreofficekit for aarch64.

==== gnome-sudoku ====
Version update (3.20.1 -> 3.20.2)

- Update to version 3.20.2:
+ Fix window size growing out of control with GTK+ 3.20.

==== gnome-terminal ====
Subpackages: gnome-shell-search-provider-gnome-terminal
nautilus-extension-terminal

- Drop gnome-terminal-transparency-fix-for-broken-themes.patch and
gnome-terminal-transparency.patch: We will not be bringing these
back into the package as they brought various issues, and we do
not want to chase upstreams releases for rebaseing.
- Following the above: Drop libtool BuildRequires and disabled
autreconf call: no longer needed since the patch needing it in
the past is already dropped.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Add patch to free memory on exit in efi environments (bsc#980739)
* grub2-efi-Free-malloc-regions-on-exit.patch

==== installation-images-openSUSE ====
Version update (14.243 -> 14.245)

- remove the Ruby gem cache files to save some space
- Fix byebug (Ruby debugger) symlinks if it is present (fate#318421)
- 14.245
- remove lilo from Recomends.
- add sample wicked output
- adjust hostip_from_wicked script to take real arguments
- sanitize hostname handling (fate#319639)
- 14.244

==== lensfun ====
Version update (0.3.1 -> 0.3.2)
Subpackages: lensfun-data lensfun-devel lensfun-doc

- update to version 0.3.2
Incremented binary version number
Improved vignetting interpolation
Internal code cleanups
Custom install directories can be configured by CMAKE_INSTALL_XXX variables
(CMake GNUInstallDirs)
New LENSFUN_WINDOWS_DATADIR CMake variable for better windows compatibility
Support for parallel installation of different database versions
New interchangeable lenses:
Canon EF-S 10-18mm f/4.5-5.6 IS STM
Canon EF-S 24mm f/2.8 STM
Canon EF 24-70mm f/4L IS USM
Canon FDn 50mm 1:1.8
Canon FDn 24mm 1:2.8
Contax G Planar T* 2/35
Fujifilm XC 16-50mm f/3.5-5.6 OIS II
Fujifilm XC 50-230mm f/4.5-6.7 OIS II
Leica D Vario-Elmar 14-150mm f/3.5-5.6 Asph. OIS
Minolta MD Rokkor 50mm 1:1.4
1 Nikkor 18.5mm f/1.8
1 Nikkor 32mm f/1.2
Nikkor AF-S 20mm f/1.8G ED
Nikon Lens Series E 28mm f/2.8
Nikon Lens Series E 50mm f/1.8
Nikkor AF-S 85mm f/1.4G
Nikon Lens Series E 100mm f/2.8
Nikkor AF 105mm f/2.8D Micro
Nikkor AF-S 300mm f/4E PF ED VR
Olympus M.Zuiko Digital ED 7-14mm f/2.8 Pro
Olympus M.Zuiko Digital ED 8mm f/1.8 Fisheye Pro
Olympus 9mm Body Cap Lens Fisheye
Samyang 12mm f/2.8 Fish-Eye ED AS NCS
Samyang 35mm T1.5 Cine Lens
Sigma 70-300mm F4-5.6 DG Macro
Sony FE 28mm f/2
Sony FE 24-70mm f/4 ZA OSS
Sony FE 55mm f/1.8 ZA
Tamron 18-200mm f/3.5-6.3 Di III VC
Tamron SP AF 70-200mm f/2.8 Di LD (IF) Macro
Vivitar Series 1 70-210mm 1:3.5 SN 22...
Voigtländer Ultron 40mm f/2 SL-II Aspherical
New compact cameras:
AEE MagiCam SD19 (action cam)
Canon IXUS 125 HS
Canon PowerShot G7 X
Canon PowerShot S100
Canon PowerShot S110
Canon PowerShot SX130 IS
Canon PowerShot SX510 HS
GoPro HERO4 Silver
LG G4
Nikon Coolpix P7000
Panasonic DMC-FZ150
Panasonic DMC-LF1
Panasonic DMC-TZ71
Sony RX100 IV
New interchangable lens cameras:
Sony Alpha 7 II
Sony Alpha 77 II
Pentax K-3 II
Pentax K-S1
Pentax K-S2
Samsung NX mini
Additional/updated data for:
Canon EF-S 18-135mm f/3.5-5.6 IS STM
Canon EF 24mm f/2.8
Canon EF 24-70mm f/2.8L USM
Canon EF 50mm f/1.8 II
Nikon AF-S Nikkor 18-135mm f/3.5-5.6G DX IF-ED
Nikon AF-S Nikkor 20mm f/1.8G ED
Nikon AF Nikkor 20mm f/2.8D
Nikon AF-S Nikkor 50mm f/1.4G
Nikon AF-S Nikkor 50mm f/1.8G
Nikon AF-S Nikkor 28-300mm f/3.5-5.6G ED VR
Nikon AF-S Zoom-Nikkor 16-35mm f/4G ED VR
Nikon AF DX Fisheye-Nikkor 10.5mm f/2.8G ED
Samsung NX 45mm f/1.8 2D/3D
Sigma 12-24mm f/4.5-5.6 EX DG
Sony DT 16-50mm f/2.8 SSM
smc Pentax-A 28mm 1:2.8
Sony FE 24-70mm f/4 ZA OSS
Panasonic DMC-LX100
Canon PowerShot G7 X

==== libXScrnSaver ====
Subpackages: libXss1 libXss1-32bit

- tagged baselibs.conf as source in specfile
- renamed -devel package to libXss-devel, so one can find it easier
(provides/obsoletes added accordingly)
- rename devel package to libXss-devel

==== libbluray ====
Version update (0.9.2 -> 0.9.3)

- Fix download url to not fail on network error
- Update to version 0.9.3:
+ Add bd_open_files(). This function deprecates old global file
system hooks.
+ Add flag for on-disc menu support to DISC_INFO.
+ Add configure argument to disable building of JAR file.
+ Add missing player settings enums.
+ Update linux Java search path list and preferred JVM.
+ Enable UDF support by default.
+ Split developer tools from examples.
+ Improve BDJ_EVENT_CHAPTER triggering.
+ Improve main title detection.
+ Improve error resilience.
+ Improve BD-J compability.
+ Improve detecting of working aacs implementation.
+ Improve libmmbd support.
+ Fix BD-J media player stop().
+ Fix restoring playback rate with some BD-J discs.
+ Fix restoring suspended playback time position.
+ Fix current chapter lookup.
+ Fix lost key focus with multi-HScene discs.
+ Fix playback of discs without Top Menu title.
+ Fix caching of some BD-J files from UDF filesystem.
+ Fix stopping playback from HDMV menus.
+ Fix possible errors in win32 .iso image reading.
+ Fix undefined values in DISC_INFO.
+ Fix memory leaks.
- Fixed patch libbluray-jvm_dir.patch.

==== libseccomp ====
Version update (2.3.0 -> 2.3.1)
Subpackages: libseccomp2 libseccomp2-32bit

- Update to new upstream release 2.3.1
* arch: fix the multiplexed ipc() syscalls
* s390: handle multiplexed syscalls correctly
- Remove 0001-arch-fix-a-number-of-32-bit-x86-failures-related-to-.patch,
0001-tests-replace-socket-syscall-references-in-15-basic-.patch
(fixed upstream)

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen

- spec: Remove %defattr usage
Inspired by upstream commit 90f9193c
- libxl: support Xen migration stream V2
fccf2725-libxl-API-4.4.patch,
5325123d-libxl-migv2-save-restore.patch,
f9edcfa4-libxl-migv2-migration.patch
bsc#978361
- Fix default video RAM setting
e4d131b8-mv-virDomainDefPostParseInternal.patch,
3e428670-post-parse-implicit-video.patch,
538012c8-default-vram.patch, 96b21fb0-vram-tests.patch,
400e716d-libxl-noprope-emulator.patch,
b90c4b5f-tests-use-qemu-xen.patch
bsc#979397

==== libxcb ====
Version update (1.11.1 -> 1.12)
Subpackages: libxcb-composite0 libxcb-damage0 libxcb-devel libxcb-dpms0
libxcb-dri2-0 libxcb-dri2-0-32bit libxcb-dri3-0 libxcb-dri3-0-32bit libxcb-glx0
libxcb-glx0-32bit libxcb-present0 libxcb-present0-32bit libxcb-randr0
libxcb-record0 libxcb-render0 libxcb-render0-32bit libxcb-res0
libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1
libxcb-sync1-32bit libxcb-xf86dri0 libxcb-xfixes0 libxcb-xfixes0-32bit
libxcb-xinerama0 libxcb-xkb1 libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 libxcb1
libxcb1-32bit

- Update to version 1.12
* here is a new version of libxcb for you to enjoy. The
highlights are the same as for the new xcb-proto release:
xinput support, RandR 1.5 and an automatic alignment checker.
- removed libxcb-xevie0/libxcb-xprint0 subpackages

==== llvm ====
Subpackages: libLLVM libLLVM-32bit

- Build LLDB separated from LLVM.
- Re-enable python bindings for the LLDB API.
- Disable libcxx/lldb/openmp for SLE fate#319582

==== mate-desktop ====
Version update (1.14.0 -> 1.14.1)
Subpackages: libmate-desktop-2-17 mate-desktop-gschemas

- Update to version 1.14.1:
* Backgrounds: Take EXIF rotation tags into consideration.
* Enable installation of mate.svg.
* Update translations.

==== mercurial ====
Version update (3.8.1 -> 3.8.2)
Subpackages: mercurial-lang

- Mercurial v3.8.2
This is an unscheduled bugfix release. 3.8.1 contained a noisy deprecation
warning that was only intended for Mercurial developers, sorry.
* bookmarks: properly invalidate volatile sets when writing bookmarks
* builddeb: add distroseries to tagged versions
* bundle2: properly request phases during getbundle
* debian: add wish to suggests
* debian: forgot to make debian/rules executable in 6b95a623ec90
* deprecation: gate deprecation warning behind devel configuration
* help: fix the display for hg help internals.revlogs (issue5227)
* help: search section of help topic by translated section name correctly
* hg-ssh: copy doc string to man page
* patch: show lower-ed translated message correctly
* progress: stop excessive clearing (issue4801)

==== mutt ====

- Enable some of the new patches like sidebar (boo#980830)
- Add patch COLS-workaround.dif which should become removed once
the sidebar patch does not modify COLS anymore

==== netcontrol ====
Version update (0.3.0 -> 0.3.1)

- version 0.3.1
- filter devices not supported by libvirt API (fate#320557)
[- 0001-blacklist-ifcfg-files-ending-in-.orig-or-tilde-bnc-8.patch]
- sanitize release line in specfile
- blacklist ifcfg files ending in .orig or tilde (bnc#871600)
[+ 0001-blacklist-ifcfg-files-ending-in-.orig-or-tilde-bnc-8.patch]
- version 0.3.0
- Added libnl version configure option and detection
- Obsoletes 0002-allow-wicked.patch, 0001-use-libnl3.patch
- Applied a minimal 0002-allow-wicked.patch to accept wicked
as the network service (fate#316768).
- Renamed libnl3.patch to 0001-use-libnl3.patch
- Add libnl3.patch to build with libnl3 open openSUSE 13.1+, this
fixes bnc#845540
- version 0.2.8
- Added ChangeLog.git to dist archive and to devel package docs.
- Fixed ncf_close to not close logger as ncf_init did not open any.
This caused SEGV's in libvirt, that redirects the global logger
to itself and is using multiple ncf instances (bnc#811002).
- Fixed pthreads detection and source enablement in configure,
added an explicit configure --enable-pthreads option to spec
file to cause a failure on detection problems (bnc#811002).
- Fixed SEGV at parsing not existing BRIDGE_PATHCOSTS and memory
leaks in in loop check, xml parsing and on backup file creation
failure while routes file rewrite (bnc#810381).
- version 0.2.7
- Fixed a bridge variable initialization in try_bridge
- Use --enable-network-service on openSUSE >= 12.3 (bnc#798348)
- Check the network.service alias link instead of NETWORKMANAGER
variable in /etc/sysconfig/network/config, when requested by
the --enable-network-service configure option.
- version 0.2.6
- Merged spec file changes from openSUSE:Factory
- Fixed libnl-devel build requires to build on 12.1
- Updated FSF address in copyright/license statements
- version 0.2.5
- Fixed several bugs reported in bnc#760500, bnc#763388,
bnc#765040, bnc#754001:
- Fetch ip addresses and routes in system refresh via
netlink, adds libnl-1 dependency to libnetcontrol.
- Do not use -o rc for ifup or it fails when startmode
is set to manual.
- Always call ifstatus in ncf_if_status and not check
interface operstate to better match ifstatus results
- Check type while creating topology tree as well, not
only if the interface specific data exists.
- Do not report error in ncf_if_xml_state when interface
does not exists any more [has been stopped/removed].
- Improved error handling, report several errors once
- Expose a lot of error details to the caller
- Fixed to parse and configure complete interface trees
and fixed a senseless type check that caused SEGV.
- Fetch mac address from system when not in the config
- Fixed arp ip target bonding option handling and expose
errors while trying to add not unique slave interface.
- Refresh config handle earlier in ncf_define, fixed a
double free in regression test it does.
- Automatically start port/slave/base interfeces when
stating a bridge/bond/vlan.
- remove call to suse_update_config (very old work around)
- Lowered bad_reference (bridge config references an unknown
interface) log level to warning (bnc#735187).
- version 0.2.4
- Fixed writing of bonding slaves into ifcfg file
- Fixed a memory leak while netcf xml generation error
- Generate complete interface chanins, do not generate
type attribute in vlan interface reference xml node
(bnc#708398).
- license update: LGPL-2.1+
SPDX syntax. See http://www.spdx.org/licenses
- Fixed to include config.h to have _GNU_SOURCE defined
- version 0.2.3, cleaning up copyright statements in source, header
and other files, adding authorization notes about use of GPL code
from wicked project inside of the LGPL libnetcontrol library and
a short README and COPYING files (bnc#713519).
- add baselibs.conf to sources
- version 0.2.2, with several fixes (fate#306765):
Change to use bus-id for bonding slave udev rules,
fixed / tweaked infiniband and vlan configuration,
fixed deletion to not remove unrequested configs,
set close-on-exec flag for all files we open.
- version 0.2.1, fixing config cleanup of depending interfaces
while configure and delete action, ifup and ifdown actions,
adding several checks and removing patch level from the API
version (fate#306765).
- A first write-enabled version 0.2.0, added hook to redirect log
messages e.g. to the libvirtd log routines (fate#306765).
- Initial package (fate#306765)

==== obs-service-tar_scm ====
Version update (0.5.3.1434983686.0b4ce51 -> 0.6.0~pre.1461681073.57c0bab)

- Update to version 0.6.0~pre.1461678268.e8b5d73:
* fix TESTING.md link in CONTRIBUTING.md
* Use correct level 2 bullet point (*)
* very first obs_scm implementation
* allow extracting of (spec) files
* allow to include local changes when using "obs_scm" service via local osc
commands.
* make obsinfo parameter for tar service optional
* support filtering on creation of cpio archives
* - add debian provides
- add debian provides
- fix dependency on SLE 11 to python-argparse
- Correctly reference patch in previous entry
- Update to version 0.6.0~pre.1460377105.35a4ea4:
* support filtering on creation of cpio archives
- Update to version 0.6.0~pre.1460098798.dda5411:
+ make obsinfo parameter for tar service optional
- Update to version 0.6.0.1460017418.4e4b2d6:
+ Correct error message about lack of git tags
+ GNUmakefile: Use default python in $PATH unless it is a python 3.
+ fix TESTING.md link in CONTRIBUTING.md
+ Use correct level 2 bullet point (*)
+ very first obs_scm implementation
+ allow extracting of (spec) files
+ allow to include local changes when using "obs_scm" service via local osc
commands.
- building this pre-version currently from private branch
as discussed with Adam
- only require git-core to not pull in git-web and gitk
- Fix build on Ubuntu by disabling mercurial tests
* 0001-Debianization-disable-running-mercurial-tests.patch

==== parted ====
Subpackages: libparted0

- implement --wipesignatures option (bsc#943623, fate#319893)
- parted-implement-wipesignatures-option.patch
- libparted: Use read only when probing devices on linux
- libparted-Use-read-only-when-probing-devices-on-linu.patch
(bsc#967375)

==== patterns-openSUSE ====
Subpackages: patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt
patterns-openSUSE-base patterns-openSUSE-books patterns-openSUSE-console
patterns-openSUSE-devel_C_C++ patterns-openSUSE-devel_basis
patterns-openSUSE-devel_gnome patterns-openSUSE-devel_ide
patterns-openSUSE-devel_java patterns-openSUSE-devel_kde
patterns-openSUSE-devel_kde_frameworks patterns-openSUSE-devel_kernel
patterns-openSUSE-devel_perl patterns-openSUSE-devel_python
patterns-openSUSE-devel_qt4 patterns-openSUSE-devel_qt5
patterns-openSUSE-devel_rpm_build patterns-openSUSE-devel_ruby
patterns-openSUSE-devel_web patterns-openSUSE-dhcp_dns_server
patterns-openSUSE-directory_server patterns-openSUSE-enhanced_base
patterns-openSUSE-enhanced_base_opt patterns-openSUSE-file_server
patterns-openSUSE-fonts patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns
-openSUSE-gnome_games patterns-openSUSE-gnome_ide
patterns-openSUSE-gnome_imaging patterns-openSUSE-gnome_imaging_opt
patterns-openSUSE-gnome_internet patterns-openSUSE-gnome_laptop
patterns-openSUSE-gnome_multimedia patterns-openSUSE-gnome_multimedia_opt
patterns-openSUSE-gnome_office patterns-openSUSE-gnome_office_opt
patterns-openSUSE-gnome_utilities patterns-openSUSE-gnome_yast
patterns-openSUSE-imaging patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_laptop
patterns-openSUSE-lxde_office
patterns-openSUSE-mail_server patterns-openSUSE-minimal_base
patterns-openSUSE-minimal_base-conflicts patterns-openSUSE-misc_server
patterns-openSUSE-multimedia patterns-openSUSE-multimedia_opt
patterns-openSUSE-network_admin patterns-openSUSE-non_oss
patterns-openSUSE-non_oss_opt patterns-openSUSE-office
patterns-openSUSE-office_opt patterns-openSUSE-print_server
patterns-openSUSE-remote_desktop patterns-openSUSE-rest_dvd
patterns-openSUSE-sw_management patterns-openSUSE-sw_management_gnome
patterns-openSUSE-sw_management_kde patterns-openSUSE-tabletpc
patterns-openSUSE-technical_writing patterns-openSUSE-x11
patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- Add unbound to the DVD patterns (boo#972499).
- add devel_osc_build pattern

==== pciutils ====
Version update (3.4.1 -> 3.5.0)
Subpackages: libpci3 pciutils-devel

- Update to version 3.5.0:
* New capabilities decoded: Downstream Port Containment,
Precision Time Measurement. Thanks to Keith Busch and
Jonathan Yong.
* Domain numbers extended to 31 bits. This will be used by the
Linux kernel on some machines in near future.
* Enhanced allocation regions are now decoded on Linux.
* The NetBSD back-end supports PCIe extended configuration space.
* Updated pci.ids to the current snapshot of the database.

==== plasma-nm5 ====
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- The mobile-broadband-provider-info package is not required anymore,
but recommended.

==== postgresql94 ====
Version update (9.4.6 -> 9.4.8)
Subpackages: postgresql94-contrib postgresql94-docs postgresql94-server

- Bugfix release to 9.4.8
This update fixes several problems which caused downtime for
users, including:
- Clearing the OpenSSL error queue before OpenSSL calls,
preventing errors in SSL connections, particularly when using
the Python, Ruby or PHP OpenSSL wrappers
- Fixed the "failed to build N-way joins" planner error
- Fixed incorrect handling of equivalence in multilevel nestloop
query plans, which could emit rows which didn't match the WHERE
clause.
- Prevented two memory leaks with using GIN indexes, including a
potential index corruption risk.
The release also includes many other bug fixes for reported
issues, many of which affect all supported versions:
- Fix corner-case parser failures occurring when
operator_precedence_warning is turned on
- Prevent possible misbehavior of TH, th, and Y,YYY format codes
in to_timestamp()
- Correct dumping of VIEWs and RULEs which use ANY (array) in a
subselect
- Disallow newlines in ALTER SYSTEM parameter values
- Avoid possible misbehavior after failing to remove a tablespace
symlink
- Fix crash in logical decoding on alignment-picky platforms
- Avoid repeated requests for feedback from receiver while
shutting down walsender
- Multiple fixes for pg_upgrade
- Support building with Visual Studio 2015
- This update also contains tzdata release 2016d, with updates
for Russia, Venezuela, Kirov, and Tomsk.
http://www.postgresql.org/docs/current/static/release-9-4-8.html
- Bugfix release 9.4.7:
- Fix two bugs in indexed ROW() comparisons
- Avoid data loss due to renaming files
- Prevent an error in rechecking rows in SELECT FOR UPDATE/SHARE
- Fix bugs in multiple json_ and jsonb_ functions
- Log lock waits for INSERT ON CONFLICT correctly
- Ignore recovery_min_apply_delay until reaching a consistent
state
- Fix issue with pg_subtrans XID wraparound
- Fix assorted bugs in Logical Decoding
- Fix planner error with nested security barrier views
- Prevent memory leak in GIN indexes
- Fix two issues with ispell dictionaries
- Avoid a crash on old Windows versions
- Skip creating an erroneous delete script in pg_upgrade
- Correctly translate empty arrays into PL/Perl
- Make PL/Python cope with identifier names
- For the full release notes, see:
http://www.postgresql.org/docs/9.4/static/release-9-4-7.html

==== postgresql94-libs ====
Version update (9.4.6 -> 9.4.8)
Subpackages: libecpg6 libpq5 libpq5-32bit postgresql94-devel

- Bugfix release to 9.4.8
This update fixes several problems which caused downtime for
users, including:
- Clearing the OpenSSL error queue before OpenSSL calls,
preventing errors in SSL connections, particularly when using
the Python, Ruby or PHP OpenSSL wrappers
- Fixed the "failed to build N-way joins" planner error
- Fixed incorrect handling of equivalence in multilevel nestloop
query plans, which could emit rows which didn't match the WHERE
clause.
- Prevented two memory leaks with using GIN indexes, including a
potential index corruption risk.
The release also includes many other bug fixes for reported
issues, many of which affect all supported versions:
- Fix corner-case parser failures occurring when
operator_precedence_warning is turned on
- Prevent possible misbehavior of TH, th, and Y,YYY format codes
in to_timestamp()
- Correct dumping of VIEWs and RULEs which use ANY (array) in a
subselect
- Disallow newlines in ALTER SYSTEM parameter values
- Avoid possible misbehavior after failing to remove a tablespace
symlink
- Fix crash in logical decoding on alignment-picky platforms
- Avoid repeated requests for feedback from receiver while
shutting down walsender
- Multiple fixes for pg_upgrade
- Support building with Visual Studio 2015
- This update also contains tzdata release 2016d, with updates
for Russia, Venezuela, Kirov, and Tomsk.
http://www.postgresql.org/docs/current/static/release-9-4-8.html
- Bugfix release 9.4.7:
- Fix two bugs in indexed ROW() comparisons
- Avoid data loss due to renaming files
- Prevent an error in rechecking rows in SELECT FOR UPDATE/SHARE
- Fix bugs in multiple json_ and jsonb_ functions
- Log lock waits for INSERT ON CONFLICT correctly
- Ignore recovery_min_apply_delay until reaching a consistent
state
- Fix issue with pg_subtrans XID wraparound
- Fix assorted bugs in Logical Decoding
- Fix planner error with nested security barrier views
- Prevent memory leak in GIN indexes
- Fix two issues with ispell dictionaries
- Avoid a crash on old Windows versions
- Skip creating an erroneous delete script in pg_upgrade
- Correctly translate empty arrays into PL/Perl
- Make PL/Python cope with identifier names
- For the full release notes, see:
http://www.postgresql.org/docs/9.4/static/release-9-4-7.html

==== python-cffi ====
Version update (1.4.2 -> 1.5.2)

- update to 1.5.2
* support for cffi-based embedding
* more robustness for shutdown logic

==== python-pyOpenSSL ====
Version update (0.15.1 -> 16.0.0)

- added %check section with testsuite
- skip-networked-test.patch - mark a test as networked so that we can
specify non-network test run
- rsa128-i586.patch - sidestep a crasher bug on 32bit platforms
by generating reasonably-sized RSA keys instead of small 128bit ones
- update to 16.0.0
Backward-incompatible changes:
* Python 3.2 support has been dropped. It never had significant real world
usage and has been dropped by our main dependency cryptography. Affected
users should upgrade to Python 3.3 or later.
Deprecations:
* The support for EGD has been removed. The only affected function
OpenSSL.rand.egd() now uses os.urandom() to seed the internal PRNG instead.
Please see pyca/cryptography#1636 for more background information on this
decision. In accordance with our backward compatibility policy
OpenSSL.rand.egd() will be removed no sooner than a year from the release of
16.0.0.
* Please note that you should use urandom for all your secure random number
needs.
* Python 2.6 support has been deprecated. Our main dependency cryptography
deprecated 2.6 in version 0.9 (2015-05-14) with no time table for actually
dropping it. pyOpenSSL will drop Python 2.6 support once cryptography does.
Changes:
* Fixed OpenSSL.SSL.Context.set_session_id,
OpenSSL.SSL.Connection.renegotiate,
OpenSSL.SSL.Connection.renegotiate_pending, and
OpenSSL.SSL.Context.load_client_ca. They were lacking an implementation
since
0.14. #422
* Fixed segmentation fault when using keys larger than 4096-bit to sign data.
[#428]
* Fixed AttributeError when OpenSSL.SSL.Connection.get_app_data() was called
before setting any app data. #304
* Added OpenSSL.crypto.dump_publickey() to dump OpenSSL.crypto.PKey objects
that represent public keys, and OpenSSL.crypto.load_publickey() to load such
objects from serialized representations. #382
* Added OpenSSL.crypto.dump_crl() to dump a certificate revocation list out to
a string buffer. #368
* Added OpenSSL.SSL.Connection.get_state_string() using the OpenSSL binding
state_string_long. #358
* Added support for the socket.MSG_PEEK flag to OpenSSL.SSL.Connection.recv()
and OpenSSL.SSL.Connection.recv_into(). #294
* Added OpenSSL.SSL.Connection.get_protocol_version() and
OpenSSL.SSL.Connection.get_protocol_version_name(). #244
* Switched to utf8string mask by default. OpenSSL formerly defaulted to a
T61String if there were UTF-8 characters present. This was changed to
default to UTF8String in the config around 2005, but the actual code didn?t
change it until late last year. This will default us to the setting that
actually works. To revert this you can call
OpenSSL.crypto._lib.ASN1_STRING_set_default_mask_asc(b"default"). #234
- fixed paths in bug-lp-1265482.diff
- fixed doc generation
- spec clean up

==== python-pyserial ====
Version update (2.7 -> 3.0.1)

- update to version 3.0.1:
* special case for FDTIBUS in list_ports on win32
* "Serial" keyword arguments, more on backward compatibility, fix
[#55]
* list_ports: return name if product is None, fix for #54
* port_publisher: restore some sorting of ports
- update to version 3.0:
* minor fixes to setup.py (file list), inter_byte_timeout (not
stored when passed to __init__), rfc2217 (behavior of close when
open failed), list_ports (__str__), loop://, renamed ReaderThread
* hwgrep:// added options to pick n'th port, skip busy ports
* miniterm: --ask option added
* Bugfixes (posix):
+ [#26/#30] always call tcsettattr on open
+ [#42] fix disregard read timeout if there is more data
+ [#45] check for write timeout, even if EAGAIN was rised
* Bugfixes (win32):
+ [#27] fix race condition in "read()", fix minimal timeout issue
+ race condition in nonblocking case
+ [#49] change exception type in case SetCommState fails
+ [#50] fixed issue with 0 timeout on windows 10
- changes from version 3.0b1:
* list_ports: add "vid", "pid", "serial_number", "product",
"manufacturer" and "location" attribute for USB devices.
* list_ports: update OSX implementation.
* list_ports: Raspberry Pi: internal port is found.
* serial_for_url: fix import (multiple packages in list)
* threaded: added new module implementing a reader thread
* tweak examples/wx*
* posix: add experimental implementation "VTIMESerial"
* new URL handler "alt://" to select alternative implementations
- changes from version 3.0a0:
* Starting from this release, only Python 2.7 and 3.2 (or newer) are
supported. The source code is compatible to the 2.x and 3.x series
without any changes. The support for earlier Python versions than
2.7 is removed, please refer to the pyserial-legacy (V2.x) series
if older Python versions are a requirement).
* Development moved to github, update links in docs.
* API changes: properties for "rts", "dtr", "cts", "dsr", "cd",
"ri", "in_waiting" (instead of get/set functions)
* remove file "FileLike" class, add "read_until" and "iread_until"
to "SerialBase"
* RS485 support changed ("rts_toggle" removed, added "serial.rs485"
module and "rs485_mode" property)
* "socket://" and "rfc2217://" handlers use the IPv6 compatible
"socket.create_connection"
* New URL handler: "spy:://".
* URL handlers now require the proper format ("?" and "&") for
arguments instead of "/"
(e.g. "rfc2217://localhost:7000?ign_set_control&timeout=5.5")
* Remove obsolete examples.
* Finish update to BSD license.
* Use setuptools if available, fall back to distutils if
unavailable.
* miniterm: changed command line options
* miniterm: support encodings on serial port
* miniterm: new transformations, by default escape/convert all
control characters
* list_ports: improved, added USB location (Linux, Win32)
* refactored code
* [FTR pyserial:37] Support fileno() function in the socket protocol
* Posix: [Patch pyserial:31] Mark/space parity on Linux
* Linux: [Patch pyserial:32] Module list_ports for linux should
include the product information as description.
* Java: fix 2 bugs (stop bits if/else and non-integer timeouts)
(Torsten Roemer)
* Update wxSerialConfigDialog.py to use serial.tools.list_ports.
* [Patch pyserial:34] Improvements to port_publisher.py example
* [Feature pyserial:39] Support BlueTooth serial port discovery on
Linux
* Bugfixes:
+ [Bug pyserial:157] Implement inWaiting in protocol_socket
+ [Bug pyserial:166] RFC2217 connections always fail
+ [Bug pyserial:172] applySettingsDict() throws an error if the
settings dictionary is not complete
+ [Bug pyserial:185] SocketSerial.read() never returns data when
timeout==0
* Bugfixes (posix):
+ [Bug pyserial:156] PosixSerial.open raises OSError rather than
SerialException when port open fails
+ [Bug pyserial:163] serial.tools.list_ports.grep() fails if it
encounters None type
+ fix setXON
+ [Patch pyserial:36 / 38] Make USB information work in python 3.4
and 2.7
+ clear OCRNL/ONLCR flags (CR/LF translation settings)
+ [Feature pyserial:38] RS485 Support
+ [Bug pyserial:170] list_ports_posix not working properly for
Cygwin
+ [Bug pyserial:187] improve support for FreeBSD
(list_ports_posix)
* Bugfixes (win32):
+ [Bug pyserial:169] missing "import time" in serialwin32.py
* Bugfixes (cli):
+ [Bug pyserial:159] write() in serialcli.py not working with
IronPython 2.7.4
- specfile:
* update copyright year
* updated url (moved to github)
* use setuptools
* CHANGES.txt -> CHANGES.rst
* README.txt -> README.rst
* Implement update-alternatives

==== python-sip ====
Version update (4.17 -> 4.18)
Subpackages: python-sip-devel

- Update to 4.18 This implements the automatic generation of PEP 484 type
hint files. The sip extension module is available as a wheel from PyPi.
* Added the /TypeHint/ argument, class, mapped type, function, typedef
and variable annotations.
* Added the /TypeHintIn/ and /TypeHintOut/ argument, class, mapped type
and typedef annotations.
* Added the /TypeHintValue/ argument, class and mapped type annotations.
* Added the /NoTypeHint/ class, enum, function and variable annotations.
* Added the %ExportedTypeHintCode and %TypeHintCode directives.
* Added the -f command line option to treat warnings as errors.
* Added the -y command line option to generated PEP 484 compatible type
hint stub files.
* Deprecated the /DocType/ and /DocValue/ annotations.

==== python3-sip ====
Version update (4.17 -> 4.18)

- Update to 4.18 This implements the automatic generation of PEP 484 type
hint files. The sip extension module is available as a wheel from PyPi.
* Added the /TypeHint/ argument, class, mapped type, function, typedef
and variable annotations.
* Added the /TypeHintIn/ and /TypeHintOut/ argument, class, mapped type
and typedef annotations.
* Added the /TypeHintValue/ argument, class and mapped type annotations.
* Added the /NoTypeHint/ class, enum, function and variable annotations.
* Added the %ExportedTypeHintCode and %TypeHintCode directives.
* Added the -f command line option to treat warnings as errors.
* Added the -y command line option to generated PEP 484 compatible type
hint stub files.
* Deprecated the /DocType/ and /DocValue/ annotations.

==== qscintilla ====
Version update (2.9.1 -> 2.9.2)
Subpackages: libqscintilla-devel libqscintilla2-12

- Update to 2.9.2
- This is mainly a packaging release. The Python extension module,
including a statically linked copy of the QScintilla library, can be
installed from PyPI.

==== rtkit ====

- Add proper provides/obsoletes due to small change in versioning

==== solid ====
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- The media-player-info package is not required anymore, but recommended.

==== speech-dispatcher ====
Version update (0.8.3 -> 0.8.4)
Subpackages: libspeechd-devel libspeechd2 python3-speechd
speech-dispatcher-configure speech-dispatcher-module-espeak

- Update to version 0.8.4:
+ Updated documentation for required dependencies and where to
find them.
+ Removed unused code.
+ Fixed compiler and GLib warnings.
+ Cleanup header definitions and inclusions.
+ Enabled silent rules by default
+ Fix language identification references.

==== sqlite3 ====
Version update (3.12.2 -> 3.13.0)
Subpackages: libsqlite3-0 libsqlite3-0-32bit sqlite3-devel sqlite3-doc

- SQLite 3.13.0:
* Postpone I/O associated with TEMP files for as long as possible,
with the hope that the I/O can ultimately be avoided completely.
* Merged the session extension into trunk.
* Added the ".auth ON|OFF" command to the command-line shell.
* Added the "--indent" option to the ".schema" and ".fullschema"
commands of the command-line shell, to turn on pretty-printing.
* Added the ".eqp full" option to the command-line shell, that does
both EXPLAIN and EXPLAIN QUERY PLAN on each statement that is evaluated.
* Improved resistance against goofy query planner decisions caused by
incomplete or incorrect modifications to the sqlite_stat1 table by
the application.
* Added the sqlite3_db_config(db,SQLITE_DBCONFIG_ENABLE_LOAD_EXTENSION)
interface which allows the sqlite3_load_extension() C-API to be enabled
while keeping the load_extension() SQL function disabled for security.
* Change the temporary directory search algorithm on Unix to allow
directories with write and execute permission, but without read permission,
to serve as temporary directories. Apply this same standard to the "."
fallback directory.
* Fix a problem with the multi-row one-pass DELETE optimization that was
causing it to compute incorrect answers with a self-referential subquery
in the WHERE clause. Fix for ticket dc6ebeda9396087
* Fix a possible segfault with DELETE when table is a rowid table with an
INTEGER PRIMARY KEY and the WHERE clause contains a OR and the table has
one or more indexes that are able to trigger the OR optimization, but none
of the indexes reference any table columns other than the INTEGER PRIMARY
KEY.
Ticket 16c9801ceba49.
* When checking for the WHERE-clause push-down optimization, verify that all
terms of the compound inner SELECT are non-aggregate, not just the last
term.
Fix for ticket f7f8c97e97597.

==== sysconfig ====
Version update (0.83.8 -> 0.83.9)
Subpackages: sysconfig-netconfig

- version 0.83.9
- ppp: install refactored ip-up and related scripts (bsc#865573)
- removed patches shipped inside of the source archive
[- 0001-dhcp-network-variables-for-dhcp4-user-class.909307.patch]
[- 0002-netconfig-use-ntpd.service-on-13.2-boo-930309.patch]

==== system-config-printer ====
Subpackages: python-cupshelpers system-config-printer-applet
system-config-printer-common system-config-printer-dbus-service
udev-configure-printer

- Add fix_connect_dialog_focus.diff: Enable the focus on the text
entry part of the combobox in the Connect Dialog. This way, users
can edit its content and write the ip of the remote cups server
to connect to (gh#twaugh/system-config-printer#38).

==== update-alternatives ====

- Provide alternatives binary and alternatives = %{version} symbol

==== viewvc ====

- Update viewvc.conf for Apache 2.4 syntax.

==== virtualbox ====
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11 virtualbox-host-kmp-default virtualbox-qt

- remove libgsoap-devel from build deps, it conflicts with gsoap-devel
- Fix start failure of vboxadd service routine (boo #977328). With this change,
automounting of shared folders works again.

==== vlc ====
Subpackages: libvlc5 libvlccore8 vlc-noX vlc-noX-lang

- Disable freerdp module support on openSUSE Tumbleweed: VLC has
not been ported to FreeRDP 2.0.

==== wicked ====
Version update (0.6.33 -> 0.6.34)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.34
- utils: fix for ni_string_set to set empty pointers
- team: fix for unclosed file descriptor and string memleak
- ppp: initial implementation of PPPoE support
(fate#317976,bsc#865573,boo#913861)

==== xcb-proto ====
Version update (7.6_1.11 -> 7.6_1.12)
Subpackages: python-xcb-proto-devel xcb-proto-devel

- Update to version 1.12
* here is a new version of xcb-proto for you to enjoy. Highlights
are lots of improvements especially to the xinput extension,
support for RandR 1.5 and an automatic alignment checker.

==== xf86-input-synaptics ====

- replaced n_conf-rename-to-70-synaptics.conf.patch with upstreamed
patch U_conf-rename-to-70-synaptics.conf.patch (boo #979554)
- n_conf-rename-to-70-synaptics.conf.patch
* bump up synaptics driver to 70, so it get's preferred over
libinput, which was dropped down to 060 (boo #979554)
- adjusted n_xf86-input-synaptics-default-tap.diff,
n_xf86-input-synaptics-xorg.conf.d_snippet.diff
- removed Supplements: xorg-x11-server, so the driver no longer
gets installed by default

==== xf86-input-wacom ====

- Ensure all unit template instances are gone on uninstall
[boo#981004]
- U_conf-rename-to-70-wacom.conf.patch
* bump up wacom driver to 070, so it get's preferred over
libinput, which was dropped down to 060 (boo #979554)

==== yast2-bootloader ====
Version update (3.1.183 -> 3.1.187)

- do not skip grub2 install during installation on s390
(bnc#980250)
- 3.1.187
- Fix storing default boot section (bnc#978366)
- Fix showing default boot section name with spaces inside
(found during testing fix for bnc#978366)
- 3.1.186
- do not install grub2 with --no-nvram on non-EFI systems
(bnc#980108)
- 3.1.185
- Reintroduce Trusted Boot (FATE#316553).
- 3.1.184

==== yast2-network ====
Version update (3.1.149 -> 3.1.151)

- bnc#971175
- /etc/hosts is correctly updated with static address, hostname
when static net configuration is done via linuxrc and hostname
is provided by AY profile
- 3.1.151
- fate#315995
- Added physical port id to device overview and bond slaves item
description if supported.
- Warn the user when two or more bonded interfaces share the
same physical port.
- Available interfaces for bonding in bond slaves tab are now
sorted and moving them up or down maintain the interface
selected.
- 3.1.150

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >