Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] Trouble with NM connectivity check on wired connection?
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi again ;-)

My network icon is plagued by the connectivity check question mark, but
only on wired connections. This is mildly annoying, but the logs show a
deeper issue

Via journalctl I see:

May 25 08:57:09 linux-mt7a NetworkManager[1315]: <info>  connectivity:
check for uri ' http://conncheck.opensuse.org' failed with 'Could not
connect: Socket I/O timed out'
May 25 08:57:09 linux-mt7a
NetworkManager[1315]: <info>  connectivity: check for uri 'http://connc
heck.opensuse.org' failed with 'Could not connect: Socket I/O timed
out'
May 25 08:57:12 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:12
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:12 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:12
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:12 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:12
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:12 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:12
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:12 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:12
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:13 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:14
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:15 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:15
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:16 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'
May 25 08:57:16
linux-mt7a NetworkManager[1315]: <info>  connectivity: check for uri 'h
ttp://conncheck.opensuse.org' failed with 'Could not connect: Network
is unreachable'
May 25 08:57:17 linux-mt7a NetworkManager[1315]:
<info>  connectivity: check for uri ' http://conncheck.opensuse.org'
failed with 'Could not connect: Network is unreachable'

As you can see, there are two different failures, but for whatever
reason, there are 19 attempts in 8 seconds.

The first issue baffles me, as I _can_ connect fine, and get the
appropriate response (the X-NetworkManager-Status header):

$ curl -i http://conncheck.opensuse.org
HTTP/1.0 204 No Content
Cache-Control: no-cache
X-NetworkManager-Status: online
Connection: close
Content-Type: text/plain

The second issue baffles me, as my
/etc/NetworkManager/NetworkManager.conf is 'stock' and therefore should
default to an interval of 300 seconds == 5 minutes.

BTW, I don't see this when I use a wifi connection, only on 'em1'.


James Mason
Technical Architect, Public Cloud
openSUSE Member
SUSE
jmason@xxxxxxxx

- --
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEcBAEBCAAGBQJXRdBoAAoJEBs5UYhsRJAjUMQIAIKBeM+/9GAPS13xoQdAB8Y7
Fr8A7CdsRFMrDjVrpH9Fps77znMNOhWKpIr0SZpQi+sGTRp2cWR2Hr1CMseBWx9X
NZ2nfwrWLnzNJd8aTipwHdpRuEZAv9rXrBOY/5mXSjMlHvJ9EroEJ6nhVTttlNot
yNFg7anw0KHTLCPcvYlnJFRIWkip9IjayN+YUVyFh+lKrbaPz/BVYV0MoPpTFJIu
6coayRnh0y2HZzhrM6N0EmPWp7N6wStOL4k1fNeNGkT/GVI1j1o2CGQ2dOuzmBmW
eCFFpAgep7xRwaFZVKWcRBoQVVEUOw4dJLSyGncDMWwyZ7G7T7xld65KWHdO2Ks=
=hoPk
-----END PGP SIGNATURE-----
< Previous Next >
This Thread
  • No further messages