Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160519 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160519

Packages changed:
AppStream (0.9.2 -> 0.9.5)
alsa
attica-qt5 (5.21.0 -> 5.22.0)
baloo5 (5.21.0 -> 5.22.0)
bluedevil5 (5.6.3 -> 5.6.4)
bluez-qt (5.21.0 -> 5.22.0)
breeze (5.6.3 -> 5.6.4)
breeze-gtk (5.6.3 -> 5.6.4)
breeze4-style (5.6.3 -> 5.6.4)
breeze5-icons (5.21.0 -> 5.22.0)
bundle-lang-common
bundle-lang-gnome
bundle-lang-kde
dosfstools (3.0.28 -> 4.0)
extra-cmake-modules (5.21.0 -> 5.22.0)
frameworkintegration (5.21.0 -> 5.22.0)
glibc
glibc
help2man (1.47.3 -> 1.47.4)
kactivities5 (5.21.0 -> 5.22.0)
kactivitymanagerd (5.6.3 -> 5.6.4)
karchive (5.21.0 -> 5.22.0)
kauth (5.21.0 -> 5.22.0)
kbookmarks (5.21.0 -> 5.22.0)
kcm_sddm (5.6.3 -> 5.6.4)
kcmutils (5.21.0 -> 5.22.0)
kcodecs (5.21.0 -> 5.22.0)
kcompletion (5.21.0 -> 5.22.0)
kconfig (5.21.0 -> 5.22.0)
kconfigwidgets (5.21.0 -> 5.22.0)
kcoreaddons (5.21.0 -> 5.22.0)
kcrash (5.21.0 -> 5.22.0)
kdbusaddons (5.21.0 -> 5.22.0)
kde-cli-tools5 (5.6.3 -> 5.6.4)
kde-gtk-config5 (5.6.3 -> 5.6.4)
kde-user-manager (5.6.3 -> 5.6.4)
kdeclarative (5.21.0 -> 5.22.0)
kded (5.21.0 -> 5.22.0)
kdelibs4support (5.21.0 -> 5.22.0)
kdesignerplugin (5.21.0 -> 5.22.0)
kdesu (5.21.0 -> 5.22.0)
kdewebkit (5.21.0 -> 5.22.0)
kdnssd-framework (5.21.0 -> 5.22.0)
kdoctools (5.21.0 -> 5.22.0)
kemoticons (5.21.0 -> 5.22.0)
kernel-firmware (20160421 -> 20160503)
kfilemetadata5 (5.21.0 -> 5.22.0)
kglobalaccel (5.21.0 -> 5.22.0)
kguiaddons (5.21.0 -> 5.22.0)
khotkeys5 (5.6.3 -> 5.6.4)
khtml (5.21.0 -> 5.22.0)
ki18n (5.21.0 -> 5.22.0)
kiconthemes (5.21.0 -> 5.22.0)
kidletime (5.21.0 -> 5.22.0)
kimageformats (5.21.0 -> 5.22.0)
kinfocenter5 (5.6.3 -> 5.6.4)
kinit (5.21.0 -> 5.22.0)
kio (5.21.0 -> 5.22.0)
kitemmodels (5.21.0 -> 5.22.0)
kitemviews (5.21.0 -> 5.22.0)
kjobwidgets (5.21.0 -> 5.22.0)
kjs (5.21.0 -> 5.22.0)
kjsembed (5.21.0 -> 5.22.0)
kmediaplayer (5.21.0 -> 5.22.0)
kmenuedit5 (5.6.3 -> 5.6.4)
knewstuff (5.21.0 -> 5.22.0)
knotifications (5.21.0 -> 5.22.0)
knotifyconfig (5.21.0 -> 5.22.0)
kpackage (5.21.0 -> 5.22.0)
kparts (5.21.0 -> 5.22.0)
kpeople5 (5.21.0 -> 5.22.0)
kplotting (5.21.0 -> 5.22.0)
kpty (5.21.0 -> 5.22.0)
kross (5.21.0 -> 5.22.0)
krunner (5.21.0 -> 5.22.0)
kscreen5 (5.6.3 -> 5.6.4)
kscreenlocker (5.6.3 -> 5.6.4)
kservice (5.21.0 -> 5.22.0)
ksshaskpass5 (5.6.3 -> 5.6.4)
ksysguard5 (5.6.3 -> 5.6.4)
ktexteditor (5.21.0 -> 5.22.0)
ktextwidgets (5.21.0 -> 5.22.0)
kunitconversion (5.21.0 -> 5.22.0)
kwallet (5.21.0 -> 5.22.0)
kwayland (5.6.3 -> 5.22.0)
kwidgetsaddons (5.21.0 -> 5.22.0)
kwin5 (5.6.3 -> 5.6.4)
kwindowsystem (5.21.0 -> 5.22.0)
kxmlgui (5.21.0 -> 5.22.0)
kxmlrpcclient5 (5.21.0 -> 5.22.0)
libKF5ModemManagerQt (5.21.0 -> 5.22.0)
libKF5NetworkManagerQt (5.21.0 -> 5.22.0)
libkdecoration2 (5.6.3 -> 5.6.4)
libksba (1.3.3 -> 1.3.4)
libkscreen2 (5.6.3 -> 5.6.4)
libksysguard5 (5.6.3 -> 5.6.4)
liborcus
libverto
libwps (0.4.2 -> 0.4.3)
lsof
milou5 (5.6.3 -> 5.6.4)
oxygen5 (5.6.3 -> 5.6.4)
p7zip
pciutils-ids (20160428 -> 20160511)
plasma-framework (5.21.0 -> 5.22.0)
plasma-nm5 (5.6.3 -> 5.6.4)
plasma5-addons (5.6.3 -> 5.6.4)
plasma5-desktop (5.6.3 -> 5.6.4)
plasma5-openSUSE
plasma5-pa (5.6.3 -> 5.6.4)
plasma5-session (5.6.3 -> 5.6.4)
plasma5-workspace (5.6.3 -> 5.6.4)
polkit-kde-agent-5 (5.6.3 -> 5.6.4)
powerdevil5 (5.6.3 -> 5.6.4)
rubygem-ruby-dbus (0.11.0 -> 0.11.1)
solid (5.21.0 -> 5.22.0)
sonnet (5.21.0 -> 5.22.0)
suse-module-tools
sushi (3.19.90 -> 3.20.0)
systemsettings5 (5.6.3 -> 5.6.4)
threadweaver (5.21.0 -> 5.22.0)
v4l-utils
virt-manager
wine (1.9.9 -> 1.9.10)
xalan-c
yast2 (3.1.186 -> 3.1.189)
yast2-installation (3.1.184 -> 3.1.187)
yast2-packager (3.1.97 -> 3.1.100)
yast2-vm (3.1.26 -> 3.1.28)

=== Details ===

==== AppStream ====
Version update (0.9.2 -> 0.9.5)
Subpackages: libappstream3

- Drop the separate Vala package and include the files into the
devel package
- Drop unnecessary manual library require
- Avoid /bin/sh invocation for simple ldconfig calls
- Generate the Vala API
- Update to version 0.9.5
Features:
* Update README (Matthias Klumpp)
* Provide a bit more hints for translators (Matthias Klumpp)
* Improve error messages when reading broken XML (Matthias Klumpp)
* Load all XML in AsXMLData (Matthias Klumpp)
* Implement reading localized images from metadata (Matthias Klumpp)
* Write localized images in XML/YAML serialize routines (Matthias Klumpp)
* Unify codepaths for checking compatible locales (Matthias Klumpp)
* yaml: Implement read/write support for the Languages field (Matthias Klumpp)
* xml: Serialize and read languages tag properly (Matthias Klumpp)
* validator: Validate files in legacy paths too (Matthias Klumpp)
Specification:
* spec: Allow localized screenshot images (Matthias Klumpp)
Bugfixes:
* Refactor icon-finding code and fix rare double-free corruption
(Matthias Klumpp)
* Properly validate randomly ordered XML tags for duplicates (Matthias Klumpp)
* validator: The translation tag is only valid in metainfo files
(Matthias Klumpp)
* Be slightly less pedantic about size info when reading screenshot
images (Matthias Klumpp)
* xml: Properly write <release/> description tag (Matthias Klumpp)
- From version 0.9.4
Features:
* Handle legacy screenshot tags (Matthias Klumpp)
* Print prettier YAML documents (Matthias Klumpp)
* yaml: Allow loading of distro metadata slices without header
(Matthias Klumpp)
* Do not check for installation candidate on minimal validation
(Matthias Klumpp)
* Don't check if component has an installation candidate before
including it (Matthias Klumpp)
* Quick-check components only when the pool is fully loaded (Matthias Klumpp)
* Support the stub data of GNOME Software (Matthias Klumpp)
* Support reading per-component priorities (Matthias Klumpp)
* Implement the architecture property (Matthias Klumpp)
* Use architecture data to resolve conflicting IDs (Matthias Klumpp)
* Add icon size information to generated XML (Matthias Klumpp)
* xml: Load size hints for icons (Matthias Klumpp)
* l10n: Update
Specification:
* docs: Explicitly define more minimally required tags per component
type (Matthias Klumpp)
* Make /usr/share/metainfo the canonical path for upstream metadata
(Matthias Klumpp)
* spec: Make architecture a property of <components/>, and no tag
(Matthias Klumpp)
* spec: Update the cached icon DEP-11 specification to allow size
information (Matthias Klumpp)
Bugfixes:
* Fix a few minor issues spotted by the YAML validator (Matthias Klumpp)
* Correctly build distro XML descriptions from upstream XML (Matthias Klumpp)
* Be very strict about which elements are allowed in a description
tag (Matthias Klumpp)
* yaml: Prevent bool keys (Matthias Klumpp)
* ascli: Properly print long descriptions and wrap lines (Matthias Klumpp)
* Export less C++ symbols (Matthias Klumpp)
* Show a better error message when failing to parse XML (Matthias Klumpp)
* Allow adding 0x0 icons (Matthias Klumpp)
* yaml: Implement the updated "cached" icon format in a
backwards-compatible way (Matthias Klumpp)
* apt: Drop flat repository entries (Matthias Klumpp)
* Probe less sizes if we already have size information (Matthias Klumpp)
* Don't make stubs delete package information from valid components
(Matthias Klumpp)
* apt: Handle quoted origin entries properly (Matthias Klumpp)
- From version 0.9.3
Features:
* Allow to update an existing component with fresh metadata
* Implement YAML serialization
* writer: Allow to omit writing a header/root node
* cli: Add convenience method to install metainfo files
* cli: Add a new "status" command for various diagnostic information
* yaml: Allow unicode
* Print prettier XML by default
* l10n: Update
Bugfixes:
* Reset umask before building the data cache
* apt: Work around APT using server mtime for its downloaded files

==== alsa ====
Subpackages: alsa-devel libasound2 libasound2-32bit

- Backport various upstream fixes for PCM (bnc#979702):
0001-pcm_plugin-fix-appl-pointer-not-correct-when-mmap_co.patch
0002-pcm-Clean-up-error-paths-in-snd_pcm_plugin_-helpers.patch
0003-pcm-Fallback-open-as-the-first-instance-for-dmix-co.patch
0004-pcm-softvol-fix-conversion-of-TLVs-min_db-and-max_dB.patch
0005-pcm-Fix-suspend-resume-regression-with-dmix-co.patch
0006-pcm-dmix-Fix-doubly-resume-of-slave-PCM.patch

==== attica-qt5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.22.0 (boo#980066)
* Properly check if a URL is a local file
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== baloo5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.22.0 (boo#980066)
* Compilation fixes for Windows
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== bluedevil5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== bluez-qt ====
Version update (5.21.0 -> 5.22.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== breeze ====
Version update (5.6.3 -> 5.6.4)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== breeze-gtk ====
Version update (5.6.3 -> 5.6.4)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== breeze4-style ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== breeze5-icons ====
Version update (5.21.0 -> 5.22.0)

- Update to 5.22.0 (boo#980066)
* Many new action and application icons.
* Specify offered extensions as per change in kiconthemes
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== bundle-lang-common ====
Subpackages: bundle-lang-common-cs bundle-lang-common-da bundle-lang-common-de
bundle-lang-common-el bundle-lang-common-en bundle-lang-common-es
bundle-lang-common-fr bundle-lang-common-hu bundle-lang-common-it
bundle-lang-common-ja bundle-lang-common-pl bundle-lang-common-pt
bundle-lang-common-ru bundle-lang-common-zh

- Improve build-time performance.
- bundle.sh: filter out existing appdata files (metainfo.xml).
- Update package list.

==== bundle-lang-gnome ====
Subpackages: bundle-lang-gnome-cs bundle-lang-gnome-da bundle-lang-gnome-de
bundle-lang-gnome-el bundle-lang-gnome-en bundle-lang-gnome-es
bundle-lang-gnome-fr bundle-lang-gnome-hu bundle-lang-gnome-it
bundle-lang-gnome-ja bundle-lang-gnome-pl bundle-lang-gnome-pt
bundle-lang-gnome-ru bundle-lang-gnome-zh

- Improve build-time performance.
- bundle.sh: filter out existing appdata files (metainfo.xml).
- Update package list.

==== bundle-lang-kde ====
Subpackages: bundle-lang-kde-cs bundle-lang-kde-da bundle-lang-kde-de
bundle-lang-kde-el bundle-lang-kde-en bundle-lang-kde-es bundle-lang-kde-fr
bundle-lang-kde-hu bundle-lang-kde-it bundle-lang-kde-ja bundle-lang-kde-pl
bundle-lang-kde-pt bundle-lang-kde-ru bundle-lang-kde-zh

- Improve build-time performance.
- bundle.sh: filter out existing appdata files (metainfo.xml).
- Update package list.

==== dosfstools ====
Version update (3.0.28 -> 4.0)

- Update to 4.0
* Switch build system to autotools.
* Fixed data corruption errors in fsck.fat Writing to the third
to last cluster on FAT12 with an odd number of clusters would
corrupt the following cluster.
* The automatic alignment of data clusters that was added in
3.0.8 and broken for FAT32 starting with 3.0.20 has been
reinstated.
- Small spec file cleanup
- Drop no longer needed dosfstools-suse-dirs.patch

==== extra-cmake-modules ====
Version update (5.21.0 -> 5.22.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.22.0 (boo#980066)
* Android deployment: support projects without things in share
or lib/qml (kde#362578)
* Enables KDE_INSTALL_USE_QT_SYS_PATHS if CMAKE_INSTALL_PREFIX
Qt5 prefix
* ecm_qt_declare_logging_category: improve error message when
using without including
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== frameworkintegration ====
Version update (5.21.0 -> 5.22.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.22.0 (boo#980066)
* Remove platformtheme plugin as it's in plasma-integration
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== glibc ====
Subpackages: glibc-32bit glibc-locale-32bit

- Import patches from 2.23 branch
0001-Updated-translations-for-2.23.patch
0002-Regenerate-libc.pot-for-2.23.patch
0003-Regenerated-configure-scripts.patch
0004-x86_64-Set-DL_RUNTIME_UNALIGNED_VEC_SIZE-to-8.patch
0005-Add-fts64_-to-sysdeps-arm-nacl-libc.abilist.patch
0006-Don-t-use-long-double-math-functions-if-NO_LONG_DOUB.patch
0007-NEWS-2.23-Fix-typo-in-bug-19048-text.patch
0008-Update-NEWS.patch
0009-sln-use-stat64.patch
0010-Add-sys-auxv.h-wrapper-to-include-sys.patch
0011-mips-terminate-the-FDE-before-the-return-trampoline-.patch
0012-Use-HAS_ARCH_FEATURE-with-Fast_Rep_String.patch
0013-Mention-BZ-19762-in-NEWS.patch
0014-Define-_HAVE_STRING_ARCH_mempcpy-to-1-for-x86.patch
0015-Or-bit_Prefer_MAP_32BIT_EXEC-in-EXTRA_LD_ENVVARS.patch
0016-Fix-resource-leak-in-resolver-bug-19257.patch
0017-math-don-t-clobber-old-libm.so-on-install-BZ-19822.patch
0018-resolv-Always-set-resplen2-out-parameter-in-send_dg-.patch
0019-S390-Save-and-restore-fprs-vrs-while-resolving-symbo.patch
0020-S390-Extend-structs-La_s390_regs-La_s390_retval-with.patch
0021-CVE-2016-3075-Stack-overflow-in-_nss_dns_getnetbynam.patch
0022-configure-fix-test-usage.patch
0023-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
0024-nss_db-Propagate-ERANGE-error-if-parse_line-fails-BZ.patch
0025-getnameinfo-Do-not-preserve-errno.patch
0026-getnameinfo-Refactor-and-fix-memory-leak-BZ-19642.patch
0027-getnameinfo-Reduce-line-length-and-add-missing-comme.patch
0028-getnameinfo-Avoid-calling-strnlen-on-uninitialized-b.patch
0029-getnameinfo-Return-EAI_OVERFLOW-in-more-cases-BZ-197.patch
0030-hesiod-Remove-RCS-keywords.patch
0031-hesiod-Always-use-thread-local-resolver-state-BZ-195.patch
0032-hesiod-Avoid-heap-overflow-in-get_txt_records-BZ-200.patch
0033-malloc-Remove-NO_THREADS.patch
0034-Fix-malloc-threaded-tests-link-on-non-Linux.patch
0035-malloc-Run-fork-handler-as-late-as-possible-BZ-19431.patch
0036-malloc-Remove-malloc-hooks-from-fork-handler.patch
0037-malloc-Add-missing-internal_function-attributes-on-f.patch
0038-nss_dns-Fix-assertion-failure-in-_nss_dns_getcanonna.patch
0039-nss_dns-Validate-RDATA-length-against-packet-length-.patch
0040-resolv-nss_dns-Remove-remaining-syslog-logging-BZ-19.patch
0041-nss_dns-Check-address-length-before-creating-addrinf.patch
0042-nss_dns-Skip-over-non-PTR-records-in-the-netent-code.patch
0043-resolv-Always-set-resplen2-out-parameter-in-send_vc-.patch
0044-tst-audit4-tst-audit10-Compile-AVX-AVX-512-code-sepa.patch
0045-Fix-tst-audit10-build-when-mavx512f-is-not-supported.patch
0046-tst-audit10-Fix-compilation-on-compilers-without-bit.patch
0047-strfmon_l-Use-specified-locale-for-number-formatting.patch
0048-glob-Simplify-the-interface-for-the-GLOB_ALTDIRFUNC-.patch
0049-CVE-2016-1234-glob-Do-not-copy-d_name-field-of-struc.patch
0050-ldconfig-Do-not-remove-stale-symbolic-links-with-X-B.patch
0051-Report-dlsym-dlvsym-lookup-errors-using-dlerror-BZ-1.patch
0052-Fix-tst-dlsym-error-build.patch
0053-Remove-trailing-newline-from-date_fmt-in-Serbian-loc.patch
0054-Revert-Report-dlsym-dlvsym-lookup-errors-using-dlerr.patch
0055-CVE-2016-3706-getaddrinfo-stack-overflow-in-hostent-.patch
0056-Fix-strfmon_l-Use-specified-locale-for-number-format.patch
- CVE-2016-3075 CVE-2016-1234 CVE-2016-3706 bsc#973164 bsc#969727
- resolv-mem-leak.patch: renamed to
0016-Fix-resource-leak-in-resolver-bug-19257.patch
- no-long-double.patch: renamed to
0006-Don-t-use-long-double-math-functions-if-NO_LONG_DOUB.patch
- glibc-gcc6.patch: renamed to
0023-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
- glibc-c-utf8-locale.patch: fix bad standard in LC_IDENTIFICATION categories
- glibc-2.3.locales.diff.bz2: likewise

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- Import patches from 2.23 branch
0001-Updated-translations-for-2.23.patch
0002-Regenerate-libc.pot-for-2.23.patch
0003-Regenerated-configure-scripts.patch
0004-x86_64-Set-DL_RUNTIME_UNALIGNED_VEC_SIZE-to-8.patch
0005-Add-fts64_-to-sysdeps-arm-nacl-libc.abilist.patch
0006-Don-t-use-long-double-math-functions-if-NO_LONG_DOUB.patch
0007-NEWS-2.23-Fix-typo-in-bug-19048-text.patch
0008-Update-NEWS.patch
0009-sln-use-stat64.patch
0010-Add-sys-auxv.h-wrapper-to-include-sys.patch
0011-mips-terminate-the-FDE-before-the-return-trampoline-.patch
0012-Use-HAS_ARCH_FEATURE-with-Fast_Rep_String.patch
0013-Mention-BZ-19762-in-NEWS.patch
0014-Define-_HAVE_STRING_ARCH_mempcpy-to-1-for-x86.patch
0015-Or-bit_Prefer_MAP_32BIT_EXEC-in-EXTRA_LD_ENVVARS.patch
0016-Fix-resource-leak-in-resolver-bug-19257.patch
0017-math-don-t-clobber-old-libm.so-on-install-BZ-19822.patch
0018-resolv-Always-set-resplen2-out-parameter-in-send_dg-.patch
0019-S390-Save-and-restore-fprs-vrs-while-resolving-symbo.patch
0020-S390-Extend-structs-La_s390_regs-La_s390_retval-with.patch
0021-CVE-2016-3075-Stack-overflow-in-_nss_dns_getnetbynam.patch
0022-configure-fix-test-usage.patch
0023-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
0024-nss_db-Propagate-ERANGE-error-if-parse_line-fails-BZ.patch
0025-getnameinfo-Do-not-preserve-errno.patch
0026-getnameinfo-Refactor-and-fix-memory-leak-BZ-19642.patch
0027-getnameinfo-Reduce-line-length-and-add-missing-comme.patch
0028-getnameinfo-Avoid-calling-strnlen-on-uninitialized-b.patch
0029-getnameinfo-Return-EAI_OVERFLOW-in-more-cases-BZ-197.patch
0030-hesiod-Remove-RCS-keywords.patch
0031-hesiod-Always-use-thread-local-resolver-state-BZ-195.patch
0032-hesiod-Avoid-heap-overflow-in-get_txt_records-BZ-200.patch
0033-malloc-Remove-NO_THREADS.patch
0034-Fix-malloc-threaded-tests-link-on-non-Linux.patch
0035-malloc-Run-fork-handler-as-late-as-possible-BZ-19431.patch
0036-malloc-Remove-malloc-hooks-from-fork-handler.patch
0037-malloc-Add-missing-internal_function-attributes-on-f.patch
0038-nss_dns-Fix-assertion-failure-in-_nss_dns_getcanonna.patch
0039-nss_dns-Validate-RDATA-length-against-packet-length-.patch
0040-resolv-nss_dns-Remove-remaining-syslog-logging-BZ-19.patch
0041-nss_dns-Check-address-length-before-creating-addrinf.patch
0042-nss_dns-Skip-over-non-PTR-records-in-the-netent-code.patch
0043-resolv-Always-set-resplen2-out-parameter-in-send_vc-.patch
0044-tst-audit4-tst-audit10-Compile-AVX-AVX-512-code-sepa.patch
0045-Fix-tst-audit10-build-when-mavx512f-is-not-supported.patch
0046-tst-audit10-Fix-compilation-on-compilers-without-bit.patch
0047-strfmon_l-Use-specified-locale-for-number-formatting.patch
0048-glob-Simplify-the-interface-for-the-GLOB_ALTDIRFUNC-.patch
0049-CVE-2016-1234-glob-Do-not-copy-d_name-field-of-struc.patch
0050-ldconfig-Do-not-remove-stale-symbolic-links-with-X-B.patch
0051-Report-dlsym-dlvsym-lookup-errors-using-dlerror-BZ-1.patch
0052-Fix-tst-dlsym-error-build.patch
0053-Remove-trailing-newline-from-date_fmt-in-Serbian-loc.patch
0054-Revert-Report-dlsym-dlvsym-lookup-errors-using-dlerr.patch
0055-CVE-2016-3706-getaddrinfo-stack-overflow-in-hostent-.patch
0056-Fix-strfmon_l-Use-specified-locale-for-number-format.patch
- CVE-2016-3075 CVE-2016-1234 CVE-2016-3706 bsc#973164 bsc#969727
- resolv-mem-leak.patch: renamed to
0016-Fix-resource-leak-in-resolver-bug-19257.patch
- no-long-double.patch: renamed to
0006-Don-t-use-long-double-math-functions-if-NO_LONG_DOUB.patch
- glibc-gcc6.patch: renamed to
0023-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
- glibc-c-utf8-locale.patch: fix bad standard in LC_IDENTIFICATION categories
- glibc-2.3.locales.diff.bz2: likewise

==== help2man ====
Version update (1.47.3 -> 1.47.4)

- Update to 1.47.4
* Update Serbian translation (thanks to ???????? ???????).
* Add Chinese (simplified) translation of info page (thanks to
Mingye Wang).
* Update Brazilian Portuguese translation (thanks to Rafael
Fontenelle).
* Reduce the minimum translation to 60% for info files.
* Extract version from dpkg-parsechangelog using the new flag,
rather than sed.
* Add hardening flags via DEB_BUILD_MAINT_OPTIONS.
* Use secure VCS URIs.
* Update standards version to 3.9.8.

==== kactivities5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kactivitymanagerd ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== karchive ====
Version update (5.21.0 -> 5.22.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kauth ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kbookmarks ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kcm_sddm ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kcmutils ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kcodecs ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kcompletion ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kconfig ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kconfigwidgets ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kcoreaddons ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.22.0 (boo#980066)
* Provide a way to disable inotify use in KDirWatch
* Fix KAboutData::applicationData() to init from current
Q*Application metadata
* Make clear that KRandom is not recommended for cryptography purposes
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php
- Drop upstreamed 0001-Missing-rand-qrand.patch
- Added 0001-Missing-rand-qrand.patch (kde#362161)

==== kcrash ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdbusaddons ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.22.0 (boo#980066)
* KDBusService: turn '-' into '_' in object paths
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kde-cli-tools5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kde-gtk-config5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kde-user-manager ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kdeclarative ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Update to 5.22.0 (boo#980066)
* Don't crash if we have no openGL context
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kded ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kded-devel

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdelibs4support ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.22.0 (boo#980066)
* Provide a fallback MAXPATHLEN if not defined
* Fix KDateTime::isValid() for ClockTime values (kde#336738)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdesignerplugin ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdesu ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdewebkit ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdnssd-framework ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kdoctools ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kdoctools-devel kdoctools-lang

- Update to 5.22.0 (boo#980066)
* Added entity applications
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kemoticons ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kernel-firmware ====
Version update (20160421 -> 20160503)
Subpackages: ucode-amd

- Update to version 20160503:
* radeon: update CIK UVD firmware
* ath10k: QCA6174 hw2.1: update firmware-5.bin to
SW_RM.1.1.1-00157-QCARMSWPZ-1
* ath10k: QCA6174 hw2.1: add board-2.bin
* ath10k: QCA6174 hw3.0: add board-2.bin
* ath10k: QCA9377 hw1.0: add firmware and board files

==== kfilemetadata5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kfilemetadata5-devel

- Update to 5.22.0 (boo#980066)
* Fixed external plugins and tests
* Added support for external writer plugins
* Added writer plugin support
* Add external extractor plugin support
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kglobalaccel ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kguiaddons ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== khotkeys5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: khotkeys5-devel

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== khtml ====
Version update (5.21.0 -> 5.22.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.22.0 (boo#980066)
* Implement toString for Uint8ArrayConstructor and friends
* Merge in several Coverity-related fixes
* Correctly use QCache::insert
* Fix some memory leaks
* Sanity check CSS web font parsing, avoid potential mem leak
* dom: Add tag priorities for 'comment' tag
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== ki18n ====
Version update (5.21.0 -> 5.22.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.22.0 (boo#980066)
* libgettext: Fix potential use-after-free using non-g++ compilers
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kiconthemes ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.22.0 (boo#980066)
* Use appropriate container for internal pointer array
* Add opportunity to reduce unneeded disk accesses,
introduces KDE-Extensions
* Save some disk accesses
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kidletime ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kimageformats ====
Version update (5.21.0 -> 5.22.0)

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kinfocenter5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kinit ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kinit-devel

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kio ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kio-core kio-devel

- Update to 5.22.0 (boo#980066)
* kurlnavigatortoolbutton.cpp - use buttonWidth in paintEvent()
* New file menu: filter out duplicates (e.g. between .qrc and
system files) (kde#355390)
* Fix error message on startup of the cookies KCM
* Remove kmailservice5, it can only do harm at this point
(kde#354151)
* Fix KFileItem::refresh() for symlinks. The wrong size, filetype
and permissions were being set
* Fix regression in KFileItem: refresh() would lose the file type,
so a dir became a file (kde#353195)
* Set text on QCheckbox widget rather than using a separate label
(kde#245580)
* Don't enable acl permissions widget if we don't own the file
(kde#245580)
* Fix double-slash in KUriFilter results when a name filter is set
* KUrlRequester: add signal textEdited (forwarded from QLineEdit)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kitemmodels ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.22.0 (boo#980066)
* Fix template syntax for test case generation
* Fix linking with Qt 5.4 (wrongly placed #endif)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kitemviews ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kjobwidgets ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kjs ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kjs-devel libKF5JS5 libKF5JSApi5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kjsembed ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kmediaplayer ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kmenuedit5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== knewstuff ====
Version update (5.21.0 -> 5.22.0)
Subpackages: knewstuff-devel libKF5NewStuff5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== knotifications ====
Version update (5.21.0 -> 5.22.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== knotifyconfig ====
Version update (5.21.0 -> 5.22.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kpackage ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kpackage-devel

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kparts ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.22.0 (boo#980066)
* Fix the layout of the BrowserOpenOrSaveQuestion dialogue
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kpeople5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kpeople5-devel

- Update to 5.22.0 (boo#980066)
* Add a check for PersonData being valid
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kplotting ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kpty ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kross ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kross-devel

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== krunner ====
Version update (5.21.0 -> 5.22.0)

- Update to 5.22.0 (boo#980066)
* Fix metainfo.yaml: KRunner is neither a porting aid nor deprecated
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kscreen5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kscreenlocker ====
Version update (5.6.3 -> 5.6.4)
Subpackages: libKScreenLocker5

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kservice ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kservice-devel

- Update to 5.22.0 (boo#980066)
* Remove too-strict maximum string length in KSycoca database
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== ksshaskpass5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== ksysguard5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== ktexteditor ====
Version update (5.21.0 -> 5.22.0)
Subpackages: ktexteditor-devel

- Update to 5.22.0 (boo#980066)
* Use proper char syntax '"' instead of '\"'
* doxygen.xml: Use default style dsAnnotation for "Custom Tags"
as well (less hard-coded colors)
* Add option to show the counter of words
* Improved foreground color contrast for search & replace
highlightings
* Fix crash when closing Kate through dbus while the print
dialog is open (kde##356813)
* Cursor::isValid(): add note about isValidTextPosition()
* Add API {Cursor, Range}::{toString, static fromString}
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== ktextwidgets ====
Version update (5.21.0 -> 5.22.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kunitconversion ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.22.0 (boo#980066)
* Inform the client if we don't know the conversion rate
* Add ILS (Israeli New Shekel) currency (kde#336016)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kwallet ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.22.0 (boo#980066)
* Disable seession restore for kwalletd5
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kwayland ====
Version update (5.6.3 -> 5.22.0)
Subpackages: kwayland-devel

- Update to 5.22.0 (boo#980066)
* KWayland is now part of KDE Frameworks
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kwidgetsaddons ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.22.0 (boo#980066)
* KNewPasswordWidget: Remove size hint on spacer, which was
leading to some always empty space in the layout
* KNewPasswordWidget: fix QPalette when widget is disabled
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kwin5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: kwin5-devel

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== kwindowsystem ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.22.0 (boo#980066)
* Fix generation of path to xcb plugin
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kxmlgui ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== kxmlrpcclient5 ====
Version update (5.21.0 -> 5.22.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== libKF5ModemManagerQt ====
Version update (5.21.0 -> 5.22.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== libKF5NetworkManagerQt ====
Version update (5.21.0 -> 5.22.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== libkdecoration2 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== libksba ====
Version update (1.3.3 -> 1.3.4)

- libksba 1.3.4:
* Fixed two OOB read access bugs which could be used to force a DoS.
boo#979261 CVE-2016-4574, CVE-2016-4579
* Fixed a crash due to faulty curve OID lookup code.
* Synced the list of supported curves with those of Libgcrypt.
* New configure option --enable-build-timestamp; a build timestamp is
not anymore used by default.

==== libkscreen2 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== libksysguard5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== liborcus ====

- Fix libixion -> liborcus typo

==== libverto ====
Subpackages: libverto-devel libverto1 libverto1-32bit

- Split off libev, glib and tevent module to sub-package

==== libwps ====
Version update (0.4.2 -> 0.4.3)

- Version update to 0.4.3:
* Few small fixes, see upstream news for detailed info

==== lsof ====

- submit utilities/lsof package to SUSE:SLE-12-SP2:GA [fate#320541]

==== milou5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== oxygen5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== p7zip ====

- Temporarily disable gui building
- Fix security issues:
- CVE-2016-2334: 7zip HFS+ NArchive::NHfs::CHandler::ExtractZlibFile
Code Execution Vulnerability (boo#979822)
- CVE-2016-2335: 7zip UDF CInArchive::ReadFileItem Code Execution
Vulnerability (boo#979823)
(CVE-2016-2334.patch, CVE-2016-2335.patch)
- Build 7zG (gui for p7zip) and added subpackage p7zip-gui for
openSUSE >= 13.2 and Leap 42.1.

==== pciutils-ids ====
Version update (20160428 -> 20160511)

- Update to 20160511

==== plasma-framework ====
Version update (5.21.0 -> 5.22.0)
Subpackages: plasma-framework-components plasma-framework-private

- Update to 5.22.0 (boo#980066)
* [QuickTheme] Fix properties
* highlight/highlightedText from proper color group
* ConfigModel: Don't try to resolve empty source path from package
* [calendar] Only show the events mark on days grid,
not month or year
* declarativeimports/core/windowthumbnail.h - fix -Wreorder warning
* Reload icon theme properly
* Always write the theme name to plasmarc, also if the
default theme is chosen
* [calendar] Add a mark to days containing an event
* Add Positive, Neutral, Negative text colors
* ScrollArea: Fix warning when contentItem is not Flickable
* Add a prop and method for aligning the menu against a corner
of its visual parent
* Allow setting minimum width on Menu
* Maintain order in stored item list
* Extend API to allow (re)positioning menu items during
procedural insert
* Bind highlightedText color in Plasma::Theme
* Fix unsetting associated application/urls for Plasma::Applets
* Don't expose symbols of private class DataEngineManager
* Add an "event" element in the calendar svg
* SortFilterModel: Invalidate filter when changing filter callback
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== plasma-nm5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== plasma5-addons ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== plasma5-desktop ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== plasma5-openSUSE ====
Subpackages: plasma5-desktop-branding-openSUSE
plasma5-workspace-branding-openSUSE

- Bump Plasma (Build)Requires to 5.6.4

==== plasma5-pa ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== plasma5-session ====
Version update (5.6.3 -> 5.6.4)

- Bump to 5.6.4

==== plasma5-workspace ====
Version update (5.6.3 -> 5.6.4)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php
- Drop upstreamed patches:
digitalclock-fix-show-seconds.patch and kuiserver5_qApp.patch

==== polkit-kde-agent-5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== powerdevil5 ====
Version update (5.6.3 -> 5.6.4)

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== rubygem-ruby-dbus ====
Version update (0.11.0 -> 0.11.1)

- 0.11.1
Bug fixes:
* Fix default path finding on FreeBSD (Greg)
* Service#unexport fixed to really return the unexported object
Requirements:
* made tests compatible with RSpec 3

==== solid ====
Version update (5.21.0 -> 5.22.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== sonnet ====
Version update (5.21.0 -> 5.22.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.22.0 (boo#980066)
* Install parsetrigrams tool for cross compiling
* hunspell: Load/Store a personal dictionary
* Support hunspell 1.4
* configwidget: notify about changed config when ignored
words updated
* settings: don't immediately save the config when
updating ignore list
* configwidget: fix saving when ignore words updated
* Fix failed to save ignore word issue (kde#355973)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php
- Drop upstreamed sonnet-hunspell-1.4.patch

==== suse-module-tools ====

- Ignore failures when loading the kernel sysctl (bsc#977715).
- Add a systemd service to load /boot/sysctl.conf-`uname -r`
(bsc#977715).

==== sushi ====
Version update (3.19.90 -> 3.20.0)

- Update to version 3.20.0:
+ Link directly with harfbuzz.
+ Updated translations.
- Add pkgconfig(harfbuzz) BuildRequires and version it. New
explicit dependency.

==== systemsettings5 ====
Version update (5.6.3 -> 5.6.4)
Subpackages: systemsettings5-devel

- Update to 5.6.4
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.6.4.php

==== threadweaver ====
Version update (5.21.0 -> 5.22.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php

==== v4l-utils ====
Subpackages: libv4l libv4l-devel libv4l1-0 libv4l1-0-32bit libv4l2-0
libv4l2-0-32bit libv4l2rds0 libv4lconvert0 libv4lconvert0-32bit

- Don't build qv4l2 on arm

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- bsc#978173 - Cannot install sles-10-sp4 on sles-12-sp1 host
virtinst-use-xenpae-kernel-for-32bit.patch
- bsc#978937 - New qemu virtual virtio gpu not selectable in
virt-manager
8ba48f52-add-virtio-device-model-and-accel3d-attribute.patch

==== wine ====
Version update (1.9.9 -> 1.9.10)
Subpackages: wine-32bit

- Updated to 1.9.10 development snapshot
- High resolution ("Retina") rendering option on Mac OS X.
- More compatible directory enumeration.
- A number of C++ runtime fixes.
- Video output improvements.
- Various bug fixes.
- updated winetricks

==== xalan-c ====

- %__isa_bits instead of ifarch conditional

==== yast2 ====
Version update (3.1.186 -> 3.1.189)
Subpackages: yast2-devel-doc

- bnc#972575
- filter out INTERFACETYPE option from ifcfg files. This option
used to be written with incorrect value by older versions of
yast.
- 3.1.189
- remove invalid_hostname check (fate#319639)
- 3.1.188
- Add Repository and Repository products classes to the packages
library API (part of FATE#320494)
- 3.1.187
- Fix "when" key in FinishClient#info

==== yast2-installation ====
Version update (3.1.184 -> 3.1.187)

- Visual improvement in the SSH keys importing proposal summary
- The user is now informed about SSH keys to be reused (copied
from a previous system) during system installation.
- The user can select a different partition (or none) to read the
keys from and whether to also copy config files.
- SSH import functionality not longer depending from
"copy_to_system" feature.
- Fate#319624
- 3.1.187
- SSH installation: handle closing the initial installation screen
by the window manager close button (bsc#979499)
- 3.1.186
- Do not copy licenses from inst-sys to target system.
Showing EULA location in the installed system.
(fate#219341)
- 3.1.185

==== yast2-packager ====
Version update (3.1.97 -> 3.1.100)

- Select the new default product patterns also when adding an
add-on from media in installed system (FATE#320199)
- 3.1.100
- Showing location of installed licenses.
(fate#219341)
- 3.1.99
- Local repositories are disabled at the end of the installation
if there is an online replacement available (FATE#320494)
- 3.1.98

==== yast2-vm ====
Version update (3.1.26 -> 3.1.28)

- fate#319328 rejected. Revert the last commit
- 3.1.28
- fate#319328 - Add virsh console conf to KVM Guests
- 3.1.27

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages