Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
Re: [opensuse-factory] solved: New Tumbleweed snapshot 20160514 released!


Am 2016-05-19 um 15:58 schrieb Wolfgang Bauer:
Am Donnerstag, 19. Mai 2016, 10:48:55 schrieb Rainer Klier:
the chronology was:
1. updated pam and kscreenlocker with yast.

Why with YaST? And what packages exactly?

i always use yast2 for updating.
i am used to it.
i updated all packages which the post "New Tumbleweed snapshot 20160514 released!" listed as updated.
and additionally the updated packages from repo "KDE:Frameworks5 / openSUSE_Factory".

Might have been caused by the order in which you installed the packages too,
though.

yes.
i don't remember in which order yast2 installed pam and kscreenlocker....

4. rebooted in maintenance mode and restored old pam config files.

What do you mean with "maintenance mode"?

single user mode, by adding "1" to the kernel options line in grub.

Or do you mean you logged in in text mode?

as single user mode is only text-based, yes.
but i could login as root not because it was text based, but because it was single user mode.

But that was before we added the forced PAM change to pam_unix to the Plasma
packages (which was done on 2015-10-23, a month later).

aha, ok.

At that point, pam_unix2 was not changed to pam_unix automatically, causing
the screenlocker to fail on upgraded systems (pam_unix is the default since

ok, this was my issue back in 2015-10-23.

so, you suggest to remove the links and make normal files?
so, copy the *-pc files over the appropriate links?
so that afterwards i simply have:
common-account
common-auth
common-password
common-session


Basically yes.
pam-config only modifies the common-xxx-pc files, but the actual config is
read from common-xxx. If the latter are not symlinks to common-xxx-pc, the
actual config will not be changed automatically (and pam-config will even bail
out if it notices this).

aha, thanks for this info.

But again, this is only necessary if you have some custom PAM configuration
that you don't want to be changed automatically.

i think i don't have this.

Well, I can only suppose something got messed up in the (automatically
generated) PAM config somehow then (reinstalling kscreenlocker will regenerate
the config).

yes, this sounds possible.
and reinstalling kscreenlocker fixed it by generate new and working pam config files.


thanks for the explanations and infos.

i hope, next time pam and/or kscreenlocker become updated, i will not have a problem any more.....
--
Best Regards | Freundliche Grüße | Cordialement | Cordiali Saluti |
*DI Rainer Klier*
Research & Development, Technical Sales Consultant

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups