Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed: how to "enable" (run at boot) postgresql 9.4.4 service
27.10.2015 06:44, Evan McClain пишет:
On Sun, Oct 11, 2015 at 11:37:49AM +0300, Andrei Borzenkov wrote:
11.10.2015 11:31, André Verwijs пишет:

Tumbleweed: how to "enable" (run at boot) PostgrwSQL 9.4.4 service

when i run....

OpenSUSE-TW:~ # systemctl enable postgresql.service

postgresql.service is not a native service, redirecting to
Executing /usr/lib/systemd/systemd-sysv-install enable postgresql
Failed to execute /usr/lib/systemd/systemd-sysv-install: No such file or

it is part of package systemd-sysvinit.

Sorry for the late response, but I just found this thread from google.

I seem to have hit a similar issue for plex media server, where both systemd
.service and sysvinit scripts are included. When starting the service, the
systemd .service file was used but when enabling the sysvinit script was
attempted to be called with the same error as above.

I don't seem to have systemd-sysv-install in my systemd-sysvinit package:

Indeed; it is in spec in Base:System but it apparently did not hit Factory/TW yet.

# rpm -ql systemd-sysvinit

It turns out this isn't really an issue for me since my "solution" was to
remove the sysvinit script since the packaged systemd service works as
expeced. If anything, the fact that the sysvinit script was used over a
systemd service of the same name when enabling (but not when starting) is a

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >