Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
[opensuse-factory] Re: leap42 - minimum server pattern has become too minimum
  • From: Jim Henderson <hendersj@xxxxxxxxx>
  • Date: Sun, 25 Oct 2015 21:40:02 +0000 (UTC)
  • Message-id: <n0ji7i$2m3$1@ger.gmane.org>
On Sun, 25 Oct 2015 14:21:08 +0100, Stefan Seyfried wrote:

Am 24.10.2015 um 21:30 schrieb Jim Henderson:
Then that's a bug and should be fixed.

YaST does have a lot of dependencies, though, so it's perhaps not
surprising. But if you want YaST, then arguably (because of the
dependencies), you're not looking for a "minimal server". You're
looking for a server.

But the only server pattern available is the "minimal server" pattern.
All others have X and other *really* bloated stuff inside :-)

A quick check of my system shows that I have 60 packages with "yast" in
the title on my 13.2 system, with a total of 258 unique requirements
(some of them are going to be interdependencies between YaST modules,
though - 147 of them do not include 'yast' in the dependency string).

Total space consumed by files in the YaST packages on my system is about
45 MB. That doesn't include the dependencies, like perl and the perl
modules that YaST depends on. Nor does it include the ruby requirements.

For a minimal system, that might be a significant amount of space -
especially for something like a docker container.

Jim

--
Jim Henderson
Please keep on-topic replies on the list so everyone benefits

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread