Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: eth0 in leap 42.1 (was: [opensuse-factory] leap42 - minimum server pattern has become too minimum)
On Sat, Oct 24, 2015 at 12:45:27PM +0200, Jan Engelhardt wrote:

On Saturday 2015-10-24 11:38, Dr. Werner Fink wrote:

Leap is SLES-12 based and most (nearly all) customers and vendors of
SLES-12 had insist on using the persistent net rules. The predictable
naming scheme had resulted in a lot of complaints.

It should be noted that to respect those complaints was not my decision
but as SLES-12 is product for customers and vendors I can live with it.

This depends on the configuration of the project, that is this can
be changed by setting the suse_version != 1315.

So the %if line should in fact include %is_opensuse rather than
just suse_version=1315.

Where can I find this macro?

grep is_opensuse
/abuild/oscbuild/{SLE-12-SP1,openSUSE_Factory}/{usr/lib,etc}/rpm/ -rs


show nothing here.

Werner

--
"Having a smoking section in a restaurant is like having
a peeing section in a swimming pool." -- Edward Burr
< Previous Next >
This Thread