Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20151017 released!
Changed packages:

==== Mesa ====
Version update (11.0.0 -> 11.0.2)
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1 libgbm1-32bit
libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- Update to 11.0.2
* This is a emergency release which covers the final dEQP
regressions introduced in the 11.0 development cycle.
- update upstream status:
* remove n_i965-Remove-early-release-of-DRI2-miptree.patch
* add U_i965-Remove-early-release-of-DRI2-miptree.patch
- Update to 11.0.1
* i965/vec4: Fix saturation errors when coalescing registers
* i965/vec4_nir: Load constants as integers
* meta: Abort meta pbo path if TexSubImage need signed unsigned
conversion
* docs: add sha256 checksums for 11.0.0
* Update version to 11.0.1
* docs: add release notes for 11.0.1
* mesa: Fix GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE for default
framebuffer.
* t_dd_dmatmp: Make "count" actually be the count
* t_dd_dmatmp: Clean up improper code formatting from previous
patch
* t_dd_dmatmp: Use '& 3' instead of '% 4' everywhere
* t_dd_dmatmp: Pull out common 'count -= count & 3' code
* t_dd_dmatmp: Use addition instead of subtraction in loop
bounds
* st/mesa: avoid integer overflows with buffers >= 512MB
* nv50, nvc0: fix max texture buffer size to 128M elements
* freedreno/a3xx: fix blending of L8 format
* nv50,nvc0: detect underlying resource changes and update tic
* nv50,nvc0: flush texture cache in presence of coherent bufs
* radeonsi: load fmask ptr relative to the resources array
* nir: Fix a bunch of ralloc parenting errors
* i965/vec4: Don't reswizzle hardware registers
* configure.ac: Add support to enable read-only text segment on
x86.
* gbm: convert gbm bo format to fourcc format on dma-buf import
* mesa: fix errors when reading depth with glReadPixels
* i965: fix textureGrad for cubemaps
* mesa: Fix texture compression on big-endian systems

==== NetworkManager-gnome ====
Subpackages: libnm-gtk0 typelib-1_0-NMGtk-1_0

- Align the name of the appdata file with the desktop file: rename
org.gnome.nm-connection-editor.appdata.xml to
nm-connection-editor.appdata.xml

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- start_apache2: reintroduce sysconfig.d, include it on
command line (not in httpd.conf) instead of individual directives
[bnc#949434] (internal), [bnc#941331]

==== apparmor-abstractions ====
Subpackages: apparmor-docs apparmor-parser apparmor-profiles apparmor-utils
libapparmor-devel libapparmor1 libapparmor1-32bit pam_apparmor
pam_apparmor-32bit perl-apparmor python3-apparmor

- add syslog-ng-profile-boo948584.diff - add several permissions needed
by latest syslog-ng (boo#948584, boo#948753)
- add upstream-profile-updates-r3205-3241.diff with several profile updates:
- add /usr/share/locale-bundle/** to abstractions/base
- allow dnsmask to use /bin/sh (boo#940749) and /bin/dash
- allow dovecot imap to read /run/dovecot/mounts
- allow avahi-daemon to write to /run/systemd/notify
- allow ntpd to read $PATH directory listings (boo#945592, boo#948752)
- update dhclient profile
- allow skype to read @{PROC}/@{pid}/net/dev (boo#939568)
- and some other small updates
- drop upstreamed apparmor-winbindd-r3213.diff (included in the
upstream-profile-updates patch)

==== at ====

- add at-3.1.16-handle_malformed_jobs.patch to prevent creation of
the corrupted files and their looping [bnc#945124]

==== btrfsmaintenance ====
Version update (0.1.1 -> 0.1.2)

- version 0.1.2
- change default config for trim: off
- journal loggin should work (fixed a typo)

==== clutter-gst-devel ====
Version update (3.0.10 -> 3.0.12)
Subpackages: gstreamer-plugin-gstclutter-3_0 libclutter-gst-3_0-0
typelib-1_0-ClutterGst-3_0

- Update to version 3.0.12:
+ Fix leak with color balance.
+ Enable DVD events forwarding upstream the pipeline.

==== dhcp ====
Version update (4.2.6 -> 4.3.3)
Subpackages: dhcp-client dhcp-doc dhcp-relay dhcp-server

- Applied a patch by Jiri Popelka catching dhcp server aborts with
"Unable to set up timer: out of range" on very long or infinite
timer intervals / lease lifetimes (bsc#947780)
[+ 0019-dhcp-4.2.4-P1-interval.patch]
- Corrected patch references in and a missed (bsc#919959) patch
description in previous changelog entry.
- Update to dhcp-4.3.3 (fate#319067) provinding many bug fixes,
features and obsoletes several patches we were using before.
For complete changelog, please read the RELNOTES file shipped
along with this package or online at:
https://kb.isc.org/article/AA-01297/82/DHCP-4.3.3-Release-Notes.html
- Replaced hostname patch with a dhcpv6 and fqdn aware variant:
[- 0006-dhcp-4.2.5-dhclient-send-hostname-rml.patch,
+ 0006-dhcp-4.3.2-dhclient-send-hostname-or-fqdn.patch]
- Removed obsolete patches included upstream now:
[- 0007-dhcp-4.2.6-ldap-mt01.patch,
- 0009-dhcp-4.2.6-xen-checksum.patch,
- 0013-dhcp-4.2.3-P1-dhclient-log-pid.patch,
- 0015-Ignore-SIGPIPE-to-not-die-in-socket-code.patch,
- 0016-server-log-DHCPv6-addresses-assigned-to-clients.patch,
- 0019-dhcp-4.2.x-ldap-debug-write.bnc835818.patch,
- 0021-dhcp-4.2.4-P2-bnc878846-conf-to-ldap.patch,
- 0022-dhcp-4.2.x-contrib-conf-to-ldap-reorder.886094.patch,
- 0023-dhcp-4.2.x-ddns-tsig-hmac-sha-support.890731.patch,
- 0025-dhcp-4.2.x-dhcpv6-retransmission-until-MRD.872609.patch,
- 0026-dhcp-4.2.x-disable-unused-ddns-port-in-server.891655.patch]
- Adjusted patch numbers in the spec file:
[- 0008-dhcp-4.1.1-P1-lpf-bind-msg-fix.patch,
- 0010-dhcp-4.2.2-dhclient-option-checks.patch,
- 0011-dhcp-4.2.6-close-on-exec.patch,
- 0012-dhcp-4.2.2-quiet-dhclient.patch,
- 0014-Fixed-linux-interface-discovery-using-getifaddrs.patch,
- 0020-dhcp-4.2.x-chown-server-leases.bnc868253.patch,
- 0024-dhcp-4.2.x-dhcpv6-decline-on-DAD-failure.872609.patch,
+ 0007-dhcp-4.1.1-P1-lpf-bind-msg-fix.patch,
+ 0008-dhcp-4.2.2-dhclient-option-checks.patch,
+ 0009-dhcp-4.2.6-close-on-exec.patch,
+ 0010-dhcp-4.2.2-quiet-dhclient.patch,
+ 0011-Fixed-linux-interface-discovery-using-getifaddrs.patch,
+ 0012-dhcp-4.2.x-chown-server-leases.bnc868253.patch,
+ 0013-dhcp-4.2.x-dhcpv6-decline-on-DAD-failure.872609.patch]
- Fixed to not pass DHCPv6 address lifetimes a positive (unsigned
32bit) integers to scripts and properly format timestamps as long
to not break them on 64bit architectures (bsc#926159).
[+ 0014-dhclient6-unsigned-lifetimes-for-script-bsc-926159.patch]
- dhclient: expose next-server DHCPv4 option to script (bsc#928390)
[+ 0015-Expose-next-server-DHCPv4-option-to-dhclient-script.patch]
- Replaced infiniband support patch with fixed variant (bsc#910984):
[- 0017-dhcp-4.2.6-lpf-ip-over-ib-support.patch,
- 0018-dhcp-4.2.6-improved-xid.patch,
- 0027-dhcp-4.2.x-handle-ifa_addr-NULL.909189.patch,
+ 0016-infiniband-support.patch]
- Moved dhcp-devel package include files and static libraries
to /usr/include/dhcp and /usr/lib/dhcp subdirectories.
DHCP requires a specific bind library version and conflicts
with the files shipped by bind-devel package, which is not
source and binary compatible (bsc#910686).
- Corrected changes to provide complete patch file references.
- Fixed server to not report success before send (bsc#919959)
[+ 0017-server-no-success-report-before-send.919959.patch]
- Fixed dhclient to check pre-init results reported by dhclient-script
and fail if pre-init fails for a requested interface (bsc#912098).
[+ 0018-client-fail-on-script-pre-init-error-bsc-912098.patch]

==== ethtool ====
Version update (4.0 -> 4.2)

- Update to new upstream release 4.2
* Feature: Support soldered-on modules in module EEPROM dump
(-m option)
* Feature: Add register dump support for VMware vmxnet3
(-d option)
* Feature: Update register dump support for IBM EMAC (-d option)
(requires Linux 4.3 or a future stable update to 4.1 or 4.2)
* Doc: Fix typo in man page

==== gedit ====
Subpackages: python3-gedit

- Change gedit-devel Group: to include Development/ to silence a
RPMLINT warning.

==== gnome-bluetooth ====
Subpackages: libgnome-bluetooth13 typelib-1_0-GnomeBluetooth-1_0

- Nothing in gnome-bluetooth now needs gnome-control-center so
remove the recommendation as non-GNOME solutions based on
gnome-bluetooth exist.

==== install-initrd-openSUSE ====
Version update (14.198 -> 14.200)

- drop console=ttyS0 from s390x cd boot options (bsc#944443)
- 14.200
- fix SUSEConnect integration (bsc#949934)
- 14.199

==== kernel-default ====
Version update (4.2.1 -> 4.2.3)
Subpackages: kernel-default-devel

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kernel-docs ====
Version update (4.2.1 -> 4.2.3)

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kernel-pv-devel ====
Version update (4.2.1 -> 4.2.3)

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kernel-devel ====
Version update (4.2.1 -> 4.2.3)
Subpackages: kernel-macros kernel-source

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kernel-syms ====
Version update (4.2.1 -> 4.2.3)

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kernel-xen ====
Version update (4.2.1 -> 4.2.3)
Subpackages: kernel-xen-devel

- rpm/kernel-obs-build.spec.in: Add virtio_rng to the initrd
This allows to feed some randomness to the OBS workers.
- commit fbb0589
- Linux 4.2.3.
- commit f17d4c9
- config: armv7hl: Enable missing STMMAC Ethernet options
This attempts to fix regressions from 4.1 like built-in Ethernet on
Cubietruck not working.
(cherry picked from commit 68608454650632c84ab3c4c67a923ba834be6c59)
- commit 2a10792
- Obsolete kernel-desktop also in Tumbleweed
- commit 35c44c6
- apparmor: temporary work around for bug while unloading policy
(boo#941867).
- commit 1193b90
- Update config files. (bsc#947816)
Put # CONFIG_KEXEC_VERIFY_SIG is not set (bsc#947816)
- commit 0dc8788
- Update config files.
(vanilla)
- commit b3ecf72
- Linux 4.2.2 (bnc#934531).
- Delete
patches.fixes/mmc-sdhci-fix-dma-memory-leak-in-sdhci_pre_req.patch.
- Delete
patches.fixes/workqueue-Make-flush_workqueue-available-again-to-no.patch.
- Update config files.
- commit 5256b5c

==== kexec-tools ====

- kexec-tools-load-crash-kernel-high.patch: Load crash kernel high
on x86 (bsc#946365).

==== konsole ====
Version update (15.08.1 -> 15.08.2)
Subpackages: konsole-part

- Update to KDE Applications 15.08.2
* KDE Applications 15.08.2
* https://www.kde.org/announcements/announce-applications-15.08.2.php
- Own directory %_kf5_sharedir/appdata to fix build on Leap

==== libgee-0_8-2 ====

- Add baselibs.conf: provide libgee-0_8-2 as required by
libskk0-32bit (boo#949452).

==== libqb0 ====
Version update (0.17.2+git20150824.4d817cc -> 0.17.2+git20151001.1a7ea3b)

- ipc: Prevent fd and memory leaks in handle_new_connection() (bsc#947341)
* bug-947341_libqb-ipc-fd-memory-leaks.patch
- log: don't call dlopen inside dl_iterate_phdr()
- ipc: Don't send the dispatch_del() function a closed fd
- Upstream version cs: 1a7ea3b8d8bf9d5ffbbfdc785ace2b81e9f2356d

==== gdk-pixbuf-loader-rsvg ====
Version update (2.40.10 -> 2.40.11)
Subpackages: librsvg-2-2 librsvg-devel typelib-1_0-Rsvg-2_0

- Update to version 2.40.11:
+ Add project files for building on Visual Studio (bgo#753555).
+ Added an "--export-id" option to rsvg-convert(1). This lets you
select a single object to export, for example, to pick out a
group from a multi-part drawing. Note that this is mostly
useful for PNG output right now; for SVG output we don't
preserve many attributes which could be useful in the extracted
version. Doing this properly requires an internal "output to
SVG" backend instead of just telling Cairo to render to SVG.

==== libyui-qt-pkg7 ====
Version update (2.45.4 -> 2.45.5)

- Better handling of secondary repository filters when there is
no enough screen space (bnc#876540)
- 2.45.5

==== libsnmp30-32bit ====

- Request pkgconfig(libssl) instead of openssl-devel to support
using LibreSSL as well.
- update to upstream version 5.7.3
- remove patch that is now present in the upstream release:
* net-snmp-5.7.2-fix-snmptrapd-remote-denial-of-service.patch
- rename patches to new version number 5.7.3:
delete:
* net-snmp-5.7.2-fix-snmpd-crashing-when-an-agentx-disconnects.patch
* net-snmp-5.7.2-net-snmp-config-headercheck.patch
* net-snmp-5.7.2-perl-tk-warning.patch
* net-snmp-5.7.2-pie.patch
* net-snmp-5.7.2-socket-path.patch
* net-snmp-5.7.2-testing-empty-arptable.patch
* net-snmp-5.7.2-velocity-mib.patch
add:
* net-snmp-5.7.3-fix-snmpd-crashing-when-an-agentx-disconnects.patch
* net-snmp-5.7.3-net-snmp-config-headercheck.patch
* net-snmp-5.7.3-perl-tk-warning.patch
* net-snmp-5.7.3-pie.patch
* net-snmp-5.7.3-socket-path.patch
* net-snmp-5.7.3-testing-empty-arptable.patch
* net-snmp-5.7.3-velocity-mib.patch
- add build requirement 'procps' to fix a net-snmp-config error
(bsc#935863)
- enable DTLS and TLS support (FATE#318789)
new binary 'snmptls' was added
- add support for hostname netgroups (FATE#316305)
'@hostgroup' can be specified for multiple hosts
* net-snmp-5.7.3-netgroups.patch
- suppress network statistics output in snmpstatus (FATE#316289)
'-Sn' don't print any info about the network
'-Si' don't print the operational status of network interfaces
* net-snmp-5.7.3-snmpstatus-suppress-output.patch
- also stop snmptrapd on removal
- update to upstream version 5.7.3.pre5
- remove patches that are now present in the upstream release:
* net-snmp-5.7.2-build-fix-for-strlcat.patch
* net-snmp-5.7.2-fix-mib-representation-of-timeout-values.patch
* net-snmp-5.7.2-fix-perl-trap-handler.patch
- net-snmp-5.7.2-fix-snmptrapd-remote-denial-of-service.patch:
refresh and add patch header
- added net-snmp-5.7.2-fix-snmptrapd-remote-denial-of-service.patch:
fix remote denial of service problem inside snmptrapd when started
with the "-OQ" option (CVE-2014-3565)(bnc#894361)
- added net-snmp-5.7.2-fix-perl-trap-handler.patch: fix potential
remote denial of service problem inside the snmptrapd Perl trap
handler (CVE-2014-2285)(bnc#866942)
- merge some old fixes from SLE 11:
* init script should provide snmpd. (bnc#466805)
* stop all snmp agents when stopping the daemon. (bnc#473328)
- recompress .tar.gz - it has trailing garbage, hope we can readd
source url on next update
- update to upstream version 5.7.2.1, fixing one security issue:
* A denial of service attack vector was discovered on the Linux
implementation of the ICMP-MIB. (CVE-2014-2284, bnc#866942)
- net-snmp-5.7.2-fix-mib-representation-of-timeout-values.patch:
fix mib representation of timeout values (bnc#833153)
- use _rundir macro
- remove old workaround for ppc/ppc64 migrations which is no longer
needed (bnc#437293)
- add support for python bindings
- improve snmptrapd init script (avoid to overwrite the logfile
on restart)
- Disable parallelism during build. The dependencies between the
Perl module and libnetsnmp are not defined correctly and might
result in broken linkage (bnc#819497, bnc#818907)
- Add Source URL, see https://en.opensuse.org/SourceUrls
- net-snmp-5.7.2-build-fix-for-strlcat.patch: fix exported strlcat()
prototype that could conflict with other packages (bnc#793548)
- update to version 5.7.2: several bug fixes in the agent, client
utilities and libraries. The CHANGES file shipped with the
package contains a comprehensive list of fixes and improvements
- rebase patches to apply cleanly:
* net-snmp-5.7.2-perl-tk-warning.patch
* net-snmp-5.7.2-socket-path.patch
* net-snmp-5.7.2-testing-empty-arptable.patch
* net-snmp-5.7.2-pie.patch
* net-snmp-5.7.2-velocity-mib.patch
* net-snmp-5.7.2-fix-snmpd-crashing-when-an-agentx-disconnects.patch
- remove patches that are now present in the upstream release:
* net-snmp-5.7.0-recognize-reiserfs.patch
* net-snmp-5.7.1-snmplib-zero-timeout.patch
* net-snmp-5.7.1-old-api-double-free.patch
* net-snmp-5.7.1-use-pclose-to-close-pipes.patch
* net-snmp-5.7.1-fix-handling-of-large-filesystems.patch
* net-snmp-5.7.1-snmplib-default-retries.patch
* net-snmp-5.7.1-fsys-memory-leak.patch
* net-snmp-5.7.1-adjust-copyright-in-agent-txt-file.patch
* net-snmp-5.7.1-recognize-ocfs2.patch
* net-snmp-5.7.1-properly-clean-up-old-requests-in-subagents.patch
* net-snmp-5.7.1-reduce-code-duplication-in-agentx.patch
* net-snmp-5.7.1-log-agentx-disconnections.patch
* net-snmp-5.7.1-more-robust-handling-of-agentx-errors.patch
* net-snmp-5.7.1-report-problems-with-setundo-processing.patch
* net-snmp-5.7.1-fix-array-index-error.patch
- Remove redundant sections from specfile
- Avoid shipping .la files
- fix array index error that could lead to a crash (CVE-2012-2141)
(bnc#759352)
- fix agent crash when reloading a subagent (AgentX) during a query
(bnc#670789)
- add OCFS2 to the list of known file systems
- update copyright notice of AGENT.txt allowing us to redistribute
the file in our package (from Dave Shield) (bnc#750704)
- fix license to be in spdx.org format
- logrotate: use "reload" instead of "try-restart" to avoid an
unnecessary stop/start cycle in the agent (bnc#707636)
- net-snmp-5.7.1-fsys-memory-leak.patch: fix a memory leak in
agent/mibgroup/hardware/fsys (bnc#725766)
- net-snmp-5.7.1-snmplib-default-retries.patch: change default
number of retries back from 0 to 5 (bnc#725766)
- net-snmp-5.7.1-fix-handling-of-large-filesystems.patch: fix
bug in handling large (>8TB) filesystems (bnc#725766)
- net-snmp-5.7.1-use-pclose-to-close-pipes.patch: use pclose()
instead of fclose() to close a pipe (bnc#725766)
- net-snmp-5.7.1-old-api-double-free.patch: agent: avoid double
free when netsnmp_register_old_api() fails (bnc#725766)
- net-snmp-5.7.1-snmplib-zero-timeout.patch: snmplib: avoid
waiting indefinitely if a session has timeout zero (bnc#725766)
- update to version 5.7.1: minor release including some bug fixes
- enable net-snmp-devel on all baselib architectures
- make sure all delegated requests are removed before closing an
AgentX session (bnc#670789)
- update to version 5.7.1.rc1 but keep package version as 5.7.1
to avoid update problems when the final version is released
- small fixes to snmpd and snmptrapd init scripts:
- if $SNMPD_LOGLEVEL is not defined, use LOG_NOTICE instead of
LOG_DEBUG
- improve messages printed and service description
- write snmptrapd logs to /var/log/net-snmpd.log
- update README.SUSE to reflect some recent changes and drop a bit
of outdated information
- update baselibs to reflect new library version
- spec file cleanup: rename some source files for consistency
- add ReiserFS to the list of known file systems (bnc#715199)
- install snmptrapd init script by default (bnc#712175)
- fix logging option in snmptrapd init script (bnc#712174)
- update upstream patches from branch V5-7-patches to 20110714
- update to version 5.7:
new features and lots of bug fixes
- remove patches that are no longer needed:
net-snmp-5.6.0-enable-hrh-filesys.patch
net-snmp-5.6.1-recognize-jfs-and-xfs.patch
net-snmp-5.6.1-rpm490.patch
- refresh and rename patches to apply cleanly after update:
net-snmp-5.7.0-pie.patch
net-snmp-5.7.0-velocity-mib.patch
- switch from rpmdb to rpmts to support rpm-4.9.0
- update upstream patches from branch V5-6-patches to 20110512
- add JFS and XFS to the list of known file systems (bnc#687327)
- update upstream patches from branch V5-6-patches to 20110328
- fix libsnmp version in baselibs.conf
- update to version 5.6.1:
new features and lots of bug fixes
- update upstream patches from branch V5-6-patches to 20110104
- remove patches that are no longer needed:
net-snmp-5.6.0-ethtool-speed.patch
- remove /var/adm/perl-modules/net-snmp from the Perl module
- update upstream patches from branch V5-6-patches to 20101129
- spec file cleanup: upstream uses -fno-strict-aliasing by default
now
- remove patches that are no longer needed:
net-snmp-5.5.0-rpmdb-h-detect.patch
net-snmp-5.6.0-vendorperl.patch
- if-mib: add support for more speeds with ethtool (bnc#650558)
- update upstream patches from branch V5-6-patches to 20101101,
fixing a segmentation fault on shutdown (bnc#650282)
- enable new implementation of hrStorage and hrFilesys to fix
persistent indexes in FS and Storage tables (bnc#648364)
- update upstream patches from branch V5-6-patches to 20101021
- update to version 5.6:
new features and lots of bug fixes
- refresh and rename patches to apply cleanly after update:
net-snmp-5.6.0-pie.patch
net-snmp-5.6.0-vendorperl.patch
net-snmp-5.6.0-net-snmp-config-headercheck.patch
- update upstream patches from branch V5-5-patches to 20100803
- change default log level from DEBUG to NOTICE (bnc#623497)
- spec file cleanup: remove old backward compatibility scripts
- update upstream patches from branch V5-5-patches to 20100602:
fixed potential buffer overflow in parsing OIDs in config files
- update upstream patches from branch V5-5-patches to 20100531
- add net-snmp-5.5.0-rpmdb-h-detect.patch:
workaround for autoconf failing to detect rpm/rpmdb.h
- remove patches that are no longer needed:
net-snmp-5.5.0-use-lmsensors-v3.patch
- create /var/run/agentx during startup to support systems that
mount /var/run as tmpfs
- update libsnmp package name to reflect the library version we
are currently shipping
- remove patches that are obsolete:
net-snmp-5.4.rc2-versinfo.diff
net-snmp-5.4.2_snmpconf-selinux.patch
- refresh all patches to apply as "-p1"
- spec file cleanup: remove conditionals to build on unsupported
versions of the distribution
- update upstream patches from branch V5-5-patches to 20100428
- add net-snmp-5.5.0_upstream-20100405.patch:
merge all patches committed to upstream branch V5-5-patches
- remove patches that are now upstream:
net-snmp-5.4.2_audit.patch
net-snmp-5.5.0_autoconf.patch
net-snmp-5.4.2_overflow.patch
net-snmp-5.4.2.1-rpm4.7.patch
net-snmp-5.5.0_gcc45.patch
- Fix strncat properly (from Andreas Jaeger)
- Fix code errors found by gcc 4.5
- build for libsensors4 instead of libsensors3
- remove sparcv9-specific baselib exceptions (not needed)
- remove net-snmp-5.4.1.2-rmon-mib-revised_3.patch from sources
(upstream since 5.5)
- refresh net-snmp-5.5.0_autoconf.patch
- spec file cleanup: update package description
- update to version 5.5:
new features and lots of bug fixes, including:
- fix hrSWRunPath for processes other than init (bnc#486270)
- remove patches that are now upstream:
Add-Default-Router-Table-support.patch
Add-ICMP-Statistics-Tables-support.patch
Add-IPv6-Scope-Zone-Index.patch
Add-IPv6-support-on-Internet-Address-Translation-Tab.patch
Fix-for-IPv6-Interface-Table.patch
Fix-for-Internet-Address-Prefix-Table.patch
Fix-for-Internet-Address-Table.patch
Fix-for-tcpConnnectionTable-tcpListenerTable-udpEn.patch
Improve-IP-Statistics-tables.patch
net-snmp-5.3.0.1_trap-agent-addr_v2.patch
net-snmp-5.4.1.2-etherlike-mib-revised_4.patch
net-snmp-5.4.x_embedded_perl_error_message.patch
- add baselibs.conf as a source
- add baselib defs for SPARC
- Fix build with rpm 4.7 (net-snmp-5.4.2.1-rpm4.7.patch)
- make patch0 usage consistent

==== libopenal1 ====
Subpackages: libopenal1-32bit openal-soft openal-soft-devel

- replace openal-soft-arm_neon-only-for-32bit.patch with
fix-neon-build.patch to fix the build instead of disabling neon

==== perl-Bootloader ====
Version update (0.843 -> 0.844)
Subpackages: perl-Bootloader-YAML

- rework boot.readme (bsc#948778)
- 0.844

==== libpurple-branding-openSUSE ====
Version update (13.2 -> 42.1)

- Bump version to 42.1, to prepare for next version of openSUSE.

==== pinentry ====
Version update (0.9.5 -> 0.9.6)
Subpackages: pinentry-gtk2 pinentry-qt4

- update to 0.9.6
* changelog:
+ Many improvements for the dump tty pinentry
+ Use the standard GTK+-2 text entry widget instead of our outdated
and back-then-it-was-more-secure text widget
+ Use the standard Qt text widget
+ Allow for building a static Qt variant
+ Fix regression in w32 pinentry
* remove qt4-disable-inputmethod-for-passwords.diff (patched file
is no longer present)
* remove regenerating of qt4/qsecurelineedit.moc in specfile as
qt4/qsecurelineedit.h was deleted. Adjust paths for the rest
of the moc files (qt4 -> qt).
* '--enable-pinentry-qt4' is now '--enable-pinentry-qt'
* '--enable-pinentry-qt4-clipboard' option was removed
* add backward compatibility link for pinentry-qt4
- use spec-cleaner

==== libpoppler-cpp0 ====
Version update (0.36.0 -> 0.37.0)
Subpackages: libpoppler-devel libpoppler-glib8 poppler-tools

- Update to version 0.37.0:
+ core:
- CairoOutputDev: Use mask for even-odd fill (fdo#84527).
- SplashOuputDev: Protect calls to set/getAA with the proper
[#]if guards (fdo#92006).
- SplashOuputDev: Try to use an external font if the internal
one is invalid.
- PageTransition D is a number not an int (fdo#92040).
- Catalog::getNumPages(): validate page count.
- Catalog::cachePageTree(): recover from out of memory
condition.
- Fix crashes in malformed documents.
+ build system: configure: fix openjpeg detection.
- Use pkgconfig(libopenjp2) BuildRequires for openSUSE newer than
13.1, stay with openjpeg-devel for older releases.
- Bump soname following upstream changes.

==== libpoppler-qt4-4 ====
Version update (0.36.0 -> 0.37.0)

- Update to version 0.37.0:
+ core:
- CairoOutputDev: Use mask for even-odd fill (fdo#84527).
- SplashOuputDev: Protect calls to set/getAA with the proper
[#]if guards (fdo#92006).
- SplashOuputDev: Try to use an external font if the internal
one is invalid.
- PageTransition D is a number not an int (fdo#92040).
- Catalog::getNumPages(): validate page count.
- Catalog::cachePageTree(): recover from out of memory
condition.
- Fix crashes in malformed documents.
+ build system: configure: fix openjpeg detection.
- Use pkgconfig(libopenjp2) BuildRequires for openSUSE newer than
13.1, stay with openjpeg-devel for older releases.
- Bump soname following upstream changes.

==== libpoppler-qt5-1 ====
Version update (0.36.0 -> 0.37.0)
Subpackages: libpoppler-qt5-devel

- Update to version 0.37.0:
+ core:
- CairoOutputDev: Use mask for even-odd fill (fdo#84527).
- SplashOuputDev: Protect calls to set/getAA with the proper
[#]if guards (fdo#92006).
- SplashOuputDev: Try to use an external font if the internal
one is invalid.
- PageTransition D is a number not an int (fdo#92040).
- Catalog::getNumPages(): validate page count.
- Catalog::cachePageTree(): recover from out of memory
condition.
- Fix crashes in malformed documents.
+ build system: configure: fix openjpeg detection.
- Use pkgconfig(libopenjp2) BuildRequires for openSUSE newer than
13.1, stay with openjpeg-devel for older releases.
- Bump soname following upstream changes.

==== postfix ====
Version update (2.11.6 -> 2.11.7)
Subpackages: postfix-doc

- upstream update postfix 2.11.7:
* The Postfix Milter client aborted with a panic while adding a
message header, after adding a short message header with the
header_checks PREPEND action. Fixed by invoking the header
output function while PREPENDing a message header.
* False alarms while scanning the Postfix queue. Fixed by resetting
errno before calling readdir(). This defect was introduced
19970309.
* The postmulti command produced an incorrect error message.
* The postmulti command now refuses to create a new MTA instance
when the template main.cf or master.cf file are missing. This
is a common problem on Debian-like systems.
* Turning on Postfix SMTP server HAProxy support broke TLS
wrappermode. Fixed by temporarily using a 1-byte VSTREAM buffer
to read the HAProxy connection hand-off information.
* The xtext_unquote() function did not propagate error reports
from xtext_unquote_append(), causing the decoder to return
partial output, instead of rejecting malformed input. The Postfix
SMTP server uses this function to parse input for the ENVID and
ORCPT parameters, and for XFORWARD and XCLIENT command parameters.

==== python-cryptography ====

- require the cffi version it was built against to avoid (bsc#948198)
- Add 2293.patch for "osrandom engine already registered" (bnc#947679)

==== rsync ====

- better disable slp by default, it doesn't seem to be used much
and it often caused problems (eg boo#898513, bsc#922710)
* set "use slp" in rsyncd.conf to enable
* modified rsync-add_back_use_slp_directive.patch
- add a compatibility flag to avoid checksum collisions (bsc#900914)
* fixes rsync equivalent of librsync's CVE-2014-8242
* added rsync-equivalent_of_CVE-2014-8242.patch
- modify rsync-add_back_use_slp_directive.patch

==== libsgutils2-1_41-2 ====
Subpackages: sg3_utils

- Add sg3_utils-58-scsi-sg3_symlink-fixup.patch: Fix broken line in
script (boo#940833, boo#940834, boo#947947).

==== libspice-server1 ====
Version update (0.12.5 -> 0.12.6)

- Update to version 0.12.6
+ Removed spicec client code, it has been superseded by remote-viewer
and other spice-gtk based clients
+ Unix socket support
+ LZ4 support
+ Let clients specify their preferred image compression format
+ Allow to record and replay a spice-server session
+ Fixes for CVE-2015-3247 CVE-2015-5260 and CVE-2015-5261
bsc#944787, bsc#948976
+ spice-protocol submodule has been removed, spice-protocol must
now be installed when building spice-server
+ Remove write polling in chardevs to reduce wakeups
- Remove upstream merged patches:
+ spice-Don-t-use-48kHz-for-playback-recording-rates.patch
+ password-length-check.patch
+ cve-2015-3247.patch

==== libspice-client-glib-2_0-8 ====
Version update (0.29 -> 0.30)
Subpackages: libspice-client-gtk-2_0-4 libspice-client-gtk-3_0-4
libspice-controller0 python-SpiceClientGtk typelib-1_0-SpiceClientGlib-2_0
typelib-1_0-SpiceClientGtk-3_0

- Update to version 0.30:
+ spice-protocol is no longer bundled with spice-gtk. Requires
spice-protocol >= 0.12.10
+ Handle single headed monitors that have a non-zero x, y config
+ Various small improvements to 'spicy' test application
+ Fix build with automake < 1.13
+ various bug fixes and improvements
+ New API:
- spice_main_update_display_enabled()
- Add SpiceSession::preferred-compression property and
- -spice-preferred-compression commandline switch (requires a
yet-to-be-released version of spice server)
+ Ability to set the SpiceDisplay::keypress-delay property via a
new SPICE_KEYPRESS_DELAY environment variable
- Add python-six BuildRequires: New dependency, that configure
fails to look for.

==== libwicked-0-6 ====
Version update (0.6.25 -> 0.6.26)
Subpackages: wicked wicked-service

- version 0.6.26
- nanny: add link device references to policy match (bsc#941611)
This causes, that nanny checks and waits until the configuration
for link references is applied by ifup (master device worker is
available) in order to not start managing ports/slaves and fail
on unresolvable requirements with "document error" first.
Unavailable reference matches caused a timing race, where nanny
omits to enslave ports into master (e.g. a dummy into ovsbr),
but was not limited to ovs setups.
- dhcp4: fix to request offer by default in --test (bsc#942278)
- teamd: adjust permissions of the teamd interface config to be
owned by teamd user if available and to always re-read dbus
busname from the service file (bsc#947542)

==== yast2-auth-client ====
Version update (3.3.3 -> 3.3.4)

- Increase width of the left panel on main dialog. bsc#948432

==== yast2-trans-af ====
Subpackages: yast2-trans-ar yast2-trans-bg yast2-trans-bn yast2-trans-bs
yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da yast2-trans-de
yast2-trans-el yast2-trans-en_GB yast2-trans-en_US yast2-trans-es
yast2-trans-et yast2-trans-fa yast2-trans-fi yast2-trans-fr yast2-trans-gl
yast2-trans-gu yast2-trans-hi yast2-trans-hr yast2-trans-hu yast2-trans-id
yast2-trans-it yast2-trans-ja yast2-trans-jv yast2-trans-ka yast2-trans-km
yast2-trans-ko yast2-trans-lo yast2-trans-lt yast2-trans-mk yast2-trans-mr
yast2-trans-nb yast2-trans-nl yast2-trans-pa yast2-trans-pl yast2-trans-pt
yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru yast2-trans-si yast2-trans-sk
yast2-trans-sl yast2-trans-sr yast2-trans-sv yast2-trans-ta yast2-trans-th
yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa yast2-trans-xh
yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Updated languages: lt.
- Updated languages: af am ar be bg bn bs ca cs cy da de el eo es et eu
fa fi fr gl gu he hi hr hu id it ja jv ka km kn ko ku lo lt mk mr ms my
nb nl nn pa pl pt ro ru si sk sl sr sv sw ta tg th tk tr uk vi wa xh zu
en_GB en_US pt_BR zh_CN zh_TW ast nds.

==== yelp-xsl ====
Version update (3.18.0 -> 3.18.1)

- Update to version 3.18.1:
+ Fixed broken selector entity in DocBook chunker.
+ Updated translations.




Removed packages:
bbswitch-kmp-desktop
crash-kmp-desktop
hdjmod-kmp-desktop
ipset-kmp-desktop
kernel-desktop
> kernel-desktop-devel
pcfclock-kmp-desktop
libpoppler55
vhba-kmp-desktop
virtualbox-guest-kmp-desktop
> virtualbox-host-kmp-desktop
xen-kmp-desktop
xtables-addons-kmp-desktop


Added packages:
libpoppler56
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages