Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
[opensuse-factory] YaST2 doesn't use a Qt GUI
  • From: Kyrill Detinov <lazy.kent@xxxxxxxxxxxx>
  • Date: Fri, 16 Oct 2015 22:47:00 +0300
  • Message-id: <20151016224700.3b39b356@lazy>

Hello.

After the recent Tumbleweed update YaST2 doesn't use a Qt GUI.

# cat /etc/os-release
NAME=openSUSE
VERSION="Tumbleweed"
VERSION_ID="20151012"
PRETTY_NAME="openSUSE Tumbleweed (20151012) (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:20151012"
BUG_REPORT_URL="https://bugs.opensuse.org";
HOME_URL="https://opensuse.org/";
ID_LIKE="suse"

# yast2 --qt
Qt GUI wanted but not found, falling back to ncurses.

# zypper se -is yast
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch |
Repository
--+----------------------------+-------------+-------------+--------+------------------------
i | YaST | application | | noarch |
openSUSE:Tumbleweed:Oss
i | yast2 | package | 3.1.149-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-apparmor | package | 3.1.3-1.2 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-audit-laf | package | 3.1.3-1.3 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-bootloader | package | 3.1.151-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-branding-openSUSE | package | 3.1.34-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-control-center | package | 3.1.5-2.3 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-control-center-qt | package | 3.1.5-2.3 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-core | package | 3.1.17-3.4 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-country | package | 3.1.24-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-country-data | package | 3.1.24-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-fonts | package | 3.1.16-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-hardware-detection | package | 3.1.7-1.3 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-ldap | package | 3.1.13-1.5 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-metapackage-handler | package | 3.1.4-2.2 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-network | package | 3.1.131-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-nfs-client | package | 3.1.16-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-nfs-common | package | 3.1.8-1.4 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-ntp-client | package | 3.1.19-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-packager | package | 3.1.77-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-pam | package | 3.1.1-3.4 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-perl-bindings | package | 3.1.2-3.5 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-pkg-bindings | package | 3.1.29-1.2 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-printer | package | 3.1.2-2.4 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-qt-branding-openSUSE | package | 13.2-11.3 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-ruby-bindings | package | 3.1.38-2.2 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-scanner | package | 3.1.2-2.4 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-security | package | 3.2.0-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-services-manager | package | 3.1.39-2.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-sound | package | 3.1.7-1.4 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-storage | package | 3.1.69-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-sudo | package | 3.1.2-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-sysconfig | package | 3.1.3-1.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-trans-ru | package | 3.1.0-7.1 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-trans-stats | package | 2.19.0-17.4 | noarch |
openSUSE:Tumbleweed:Oss
i | yast2-transfer | package | 3.1.2-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-users | package | 3.1.40-1.1 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-xml | package | 3.1.1-3.4 | x86_64 |
openSUSE:Tumbleweed:Oss
i | yast2-ycp-ui-bindings | package | 3.1.9-1.3 | x86_64 |
openSUSE:Tumbleweed:Oss

# strace yast2 --qt
http://susepaste.org/view/simple/76663779

I see this:

stat("/usr/lib64/YaST2/plugin/libpy2qt.so.2", 0x7ffde6693630) = -1 ENOENT (No
such file or directory)
fcntl(1, F_GETFD) = 0
fcntl(1, F_DUPFD, 10) = 10
fcntl(1, F_GETFD) = 0
fcntl(10, F_SETFD, FD_CLOEXEC) = 0
dup2(2, 1) = 1
fcntl(2, F_GETFD) = 0
write(1, "Qt GUI wanted but not found, fal"..., 54Qt GUI wanted but not found,
falling back to ncurses.

What is missing?

--
WBR
Kyrill
< Previous Next >
Follow Ups