Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: [opensuse-factory][solved] 32bit apps on OS 13.2 64bit responses with Bad system call
Am Sat, 3 Oct 2015 21:00:27 +0300
schrieb Andrei Borzenkov <arvidjaar@xxxxxxxxx>:

Well, it is probably got copied into initrd so every process now
inherits filter. You need to also recreate initrd after commenting
out SystemCallArchitectures.


I commented out line SystemCallArchitectures=
raven:~ # edit /etc/systemd/system.conf:
....
# SystemCallArchitectures=
....

created a new initramfs
raven:~ # /sbin/mkinitrd

did a reboot

checked seccomp status
raven:~ # cat /proc/self/status | grep -i seccomp
Seccomp: 0
that looks well!

tested 32bit programs
peter@raven:~> wine
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
peter@raven:~> acroread
-> acroread window pop-up

OK, 32bit apps are able to run! No "Bad system call" any more.
Problem solved.

Many thanks for your great help and patience, Andrei.

A deliriously happy openSuSE user.
Kind Regards

Peter Ragosch

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >