Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: [opensuse-factory] [Leap 42.1] zyper dup fails on grub update because can't find awk.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2015-10-02 12:04, Dominique Leuenberger / DimStar wrote:
On Fri, 2015-10-02 at 11:58 +0200, Carlos E. R. wrote:

Copied error message from /var/log/zypper.log


Please file a but report - this is certainly something that must not be
forgotten.

Ok, will do.

The issue is probably that the rpm scriptlet of gawk produced an
error..

If you run

/usr/sbin/update-alternatives \
--install /bin/awk awk /usr/bin/gawk 20 \
--slave /usr/bin/awk usr-bin-awk /usr/bin/gawk \
--slave /usr/share/man/man1/awk.1.gz awk.1.gz \
/usr/share/man/man1/gawk.1.gz

can you confirm that 'awk' works again?

Yes, it does.

It appears that the previous "zypper dup" was incomplete, though. I repeated it
and found another 600MB of updates, with vendor changes.

[...]

Wow. While doing this, the machine, which was running in level 3, rebooted on
its own before finishing the zypper dup run, over an ssh session:

...
( 689/1757) Installing: libattr1-32bit-2.4.47-3.2
.......................................................[done]
( 690/1757) Installing: glibc-locale-32bit-2.19-4.1
.....................................................[done]
( 691/1757) Installing: libpoppler44-0.24.4-5.2
.........................................................[done]
( 692/1757) Installing: libbluray1-0.8.1-3.2
............................................................[done]
( 693/1757) Installing: libass5-0.12.3-4.2
..............................................................[done]
( 694/1757) Installing: libXft2-2.3.2-1.1
...............................................................[done]
( 695/1757) Installing: gd-2.1.0-8.2
....................................................................[done]
( 696/1757) Installing: xrdb-1.1.0-3.2
..................................................................[done]
( 697/1757) Installing: apparmor-abstractions-2.10-2.1
.................................................<100%>[\]Write failed: Broken
pipe
cer@Telcontar:~>
cer@Telcontar:~> ssh -X root@192.168.74.110
Password:
Last login: Fri Oct 2 12:56:44 2015 from 192.168.74.1
Have a lot of fun...
Eleanor-421:~ # zypper dup
...

1161 packages to upgrade, 11 new, 2 to remove, 1161 to change vendor.
Overall download size: 37,9 MiB. Already cached: 562,5 MiB After the
operation, additional 27,3 MiB will be used.
Continue? [y/n/? shows all options] (y):


...

Well, succeeded on the end.

partially...



Eleanor-421:~ # yast
No such server module ncurses

Run 'yast2 -h' for help on usage
Eleanor-421:~ #


This is a first.

And:

Eleanor-421:~ # yast2 &
[1] 1920
Eleanor-421:~ # libGL error: failed to load driver: swrast
Run command: /sbin/yast2 sw_single &
No such server module qt

Run 'yast2 -h' for help on usage

Eleanor-421:~ #


I can't run yast software management module...


Too many failures for my liking.



Eleanor-421:~ # zypper dup
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you continue.
See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Nothing to do.
[1]+ Done yast2
Eleanor-421:~ # zypper up
Loading repository data...
Reading installed packages...

The following 35 package updates will NOT be installed:
PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE
PackageKit-lang cheese empathy eog eog-lang evince evolution evolution-lang
gedit gedit-lang
gnome-calculator gnome-clocks gnome-color-manager gnome-contacts
gnome-control-center gnome-control-center-color gnome-control-center-lang
gnome-dictionary gnome-documents
gnome-documents-lang gnome-documents_books-common gnome-maps gnome-screenshot
gnome-shell-search-provider-documents gnome-software gnome-terminal
gnome-weather
libpackagekit-glib2-18 libsolv-tools libzypp yast2-pkg-bindings zypper

Nothing to do.
Eleanor-421:~ #

Eleanor-421:~ # zypper ll
# | Name | Type | Repository
- --+---------------------------+---------+-----------
1 | plymouth | package | (any)
2 | gnome-packagekit | package | (any)
3 | PackageKit-browser-plugin | package | (any)
4 | apper | package | (any)
5 | ntp | package | (any)
Eleanor-421:~ #


Eleanor-421:~ # zypper up libzypp
Loading repository data...
Reading installed packages...
There is an update candidate for 'libzypp', but it is from a different vendor.
Use 'zypper install libzypp-15.17.0-1.1.x86_64' to install this candidate.
Resolving package dependencies...

Nothing to do.
Eleanor-421:~ # zypper install libzypp-15.17.0-1.1.x86_64
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: zypper-1.11.32-4.1.x86_64 requires libzypp.so.1439()(64bit), but this
requirement cannot be provided
Solution 1: Following actions will be done:
install zypper-1.12.16-1.1.x86_64 (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
install yast2-pkg-bindings-3.1.29-6.3.x86_64 (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
deinstallation of libyui-qt-pkg6-2.44.7-2.5.x86_64
deinstallation of libyui-ncurses-pkg6-2.46.1-2.4.x86_64
install PackageKit-backend-zypp-1.0.7-3.3.x86_64 (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
install libsolv-tools-0.6.12-1.1.x86_64 (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
install PackageKit-1.0.7-3.3.x86_64 (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
install PackageKit-branding-openSUSE-13.2-8.2.noarch (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
install PackageKit-lang-1.0.7-3.3.noarch (with vendor change)
obs://build.opensuse.org/openSUSE:42 --> openSUSE
Solution 2: do not install libzypp-15.17.0-1.1.x86_64
Solution 3: break zypper-1.11.32-4.1.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): 1
Resolving dependencies...
Resolving package dependencies...

The following 5 NEW packages are going to be installed:
libyui-ncurses-pkg7 libyui-ncurses7 libyui-qt-graph7 libyui-qt-pkg7
libyui-qt7

The following 2 packages are going to be REMOVED:
libyui-ncurses-pkg6 libyui-qt-pkg6

The following 8 packages are going to be upgraded:
PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE
PackageKit-lang libsolv-tools libzypp yast2-pkg-bindings zypper

The following 8 packages are going to change vendor:
PackageKit obs://build.opensuse.org/openSUSE:42 -> openSUSE
PackageKit-backend-zypp obs://build.opensuse.org/openSUSE:42 -> openSUSE
PackageKit-branding-openSUSE obs://build.opensuse.org/openSUSE:42 -> openSUSE
PackageKit-lang obs://build.opensuse.org/openSUSE:42 -> openSUSE
libsolv-tools obs://build.opensuse.org/openSUSE:42 -> openSUSE
libzypp obs://build.opensuse.org/openSUSE:42 -> openSUSE
yast2-pkg-bindings obs://build.opensuse.org/openSUSE:42 -> openSUSE
zypper obs://build.opensuse.org/openSUSE:42 -> openSUSE


8 packages to upgrade, 5 new, 2 to remove, 8 to change vendor.
Overall download size: 6,0 MiB. Already cached: 0 B After the operation,
additional 3,4 MiB will be used.
Continue? [y/n/? shows all options] (y):



I have to manually call "zypper up specific-package" one by one to install all
of them updates :-(

I also see kernel errors in the log. Ugh... I can't find them now, the log is
filled with gdm entries :-(
I have to do something in syslog about that.

- --
Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 "Bottle" at Telcontar)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)

iEYEARECAAYFAlYOa+MACgkQtTMYHG2NR9UZggCdEg0j6FF0CPtk3fVOJvfzNQ+W
YxcAn1CC1IzxnavJT7/0HgJuarZ1KeWe
=o+zk
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >