Mailinglist Archive: opensuse-factory (437 mails)

< Previous Next >
Re: [opensuse-factory] removal of obsolete packages (here: gstreamer-0_10)
  • From: Marc Dietrich <marc.dietrich@xxxxxxxxxxxx>
  • Date: Tue, 28 Apr 2015 14:04:28 +0200
  • Message-id: <3045756.FtOSYs3bcy@fb07-iapwap2>
Am Freitag, 24. April 2015, 14:29:22 schrieb Stanislav Brabec:
Dimstar / Dominique Leuenberger wrote:
Would it be possible to get an overview just as the one above with
respective links wherever upstream has patches (if you find them that
is). Once we know exactly what packages we really have to care for, we
can take the decision much easier, instead of a meta-discussion that
it would be good to get rid of it (off my head I know that pidgin's
patch set is in a terrible state - we had that for a while, but
reverted, and xfce still has an applet that depends on it - there were
plans to get a PA frontend, not sure what the situation is there by
now).

There is a quick way to check all packages for possible source-level
compatibility with gstreamer-1.0:

- Create a new OBS project.
- Create a special prjconf:
Substitute: gstreamer-0_10-devel gstreamer-1_0-devel
.. and the same for all other sub-packages.
- Link there all packages that have gstreamer-0_10* in BuildRequires.

If such experiment makes sense, I could create it. I did something
similar for wxWidgets in past.

Why not just remove gstreamer-0_10 alltogether and fix the fallouts? Of
course, this is only recommended after a new stable series has branched (e.g.
not now).

Marc

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >