Mailinglist Archive: opensuse-factory (437 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20150412 released!
Changed packages:

==== PackageKit ====
Version update (1.0.5 -> 1.0.6)
Subpackages: PackageKit-backend-zypp PackageKit-browser-plugin
PackageKit-gstreamer-plugin PackageKit-gtk3-module libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Update to version 1.0.6:
+ New Features:
- Add dbus method for returning prepared packages.
- Add pk_backend_is_transaction_inhibited.
- gstreamer plugin: Add support for v2 of the PK session
service interface.
+ Bugfixes:
- Don't recursive lock the debug mutex when using --verbose
without a tty.
- Make "reboot" the default action for no action file.
- gstreamer plugin: Adapt to gstreamer missing plugin changes.
- gstreamer plugin: Avoid criticals when some of the parameters
are NULL.
+ Backend enhancements/fixes: alpm and hif.

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- remove 'exit 0' from the %post section in the specfile that was
placed here incorrectly and caused that the rest of the %post
section couldn't be executed.
- /etc/init.d/apache2 reload -> systemctl reload apache2.service
in apache2.logrotate [bnc#926523]
- authz_default -> authz_core in sysconfig.apache2/APACHE_MODULES
[bnc#922236]

==== dia ====
Subpackages: dia-lang

- Add dia-intltool-0.51.patch: Fix installation of translations
using intltool 0.51.

==== java-1_8_0-openjdk ====
Subpackages: java-1_8_0-openjdk-headless

- Build the accelerated aarch64 hotspot anew

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-mysql libreoffice-calc
libreoffice-calc-extensions libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions

- --disable-collada
* reportedly it does not work in LibreOffice 4.4
- added version numbers to some BuildRequires lines
- Require flow engine too on base
- Fix build on SLE12 and 13.1 by adding conditional for appdata install
- Fixup the installed appdata.xml files: they reference a .desktop
file that are not installed by libreoffice (boo#926375).

==== libvirt-python ====
Version update (1.2.13 -> 1.2.14)

- Update to 1.2.14
- Add all new APIs and constants in libvirt 1.2.14

==== libxslt-devel ====
Subpackages: libxslt-tools libxslt1 libxslt1-32bit

- fix package with "soname" should obsolete libxslt package on suse < 12.2
(SLE11)

==== apache2-mod_php5 ====
Subpackages: php5 php5-bcmath php5-bz2 php5-calendar php5-ctype php5-curl
php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear php5-pgsql
php5-shmop php5-snmp php5-sockets php5-sqlite php5-suhosin php5-sysvsem
php5-sysvshm php5-tidy php5-tokenizer php5-wddx php5-xmlreader php5-xmlwriter
php5-xsl php5-zip php5-zlib

- systzdata patch updated to r10
- php5-systzdata-v7.patch
+ php5-systzdata-r10.patch
- build against system gd and libzip only for 13.2 and above

==== libpulse-devel ====
Subpackages: libpulse-mainloop-glib0 libpulse0 libpulse0-32bit pulseaudio
pulseaudio-bash-completion pulseaudio-module-bluetooth pulseaudio-module-gconf
pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11
pulseaudio-module-zeroconf pulseaudio-utils

- create symlink providing extra-hdmi.conf (pointing to
default.conf)
it seems that some HW may get unitialized without this (check
pulseaudio RC1 announce)

==== python3-nose ====
Version update (1.3.4 -> 1.3.6)

- update to version 1.3.6:
* Re-release of 1.3.5 with wheels fixed.
- changes from version 1.3.5:
* Fix #875: nose doesn't collect tests when subpackage is given as
arg
* Fix #809: tests not discovered for namespace packages on Windows
* Fix #815: "ValueError: unsupported pickle protocol" with --with-id
* Wrap the working dir path name in quotes when reporting an error.
Patch by ?ry Máté.
* Fix #887: Fix a discrepancy in test names between Python 2 and
Python 3
* Fix #131: Use os.stat() to check if file is executable Patch by
Arnon Yaari.
* Fix #820 and #719: Fix coverage plugin with multiprocess Patch by
Nicolas Grasset.

==== xchat ====
Subpackages: xchat-lang xchat-perl xchat-python xchat-tcl

- Add xchat-use-tls.patch: Replace SSLv3_method by SSLv23_method.
SSLv3 is SSL3.0 only, SSLv23_method will select the best
(TLS 1.2, 1.1, 1.0 or 3.0).
https://sourceforge.net/p/xchat/bugs/1598/

==== xen ====
Subpackages: xen-doc-html xen-kmp-default xen-kmp-desktop xen-libs xen-tools
xen-tools-domU

- Add xen-no-array-bounds.patch and blktap-no-uninit.patch to selectively
turn errors back to warnings to fix build with GCC 5.
- Amend xen.stubdom.newlib.patch to pull in declaration of strcmp to
avoid implicit-fortify-decl rpmlint error.
- Fix quoting of __SMBIOS_DATE__ in xen.build-compare.smbiosdate.patch.
- xentop: Fix memory leak on read failure
551ac326-xentop-add-support-for-qdisk.patch
- Dropped xentop-add-support-for-qdisk.patch in favor of upstream
version
551ac326-xentop-add-support-for-qdisk.patch

==== xf86-input-keyboard ====
Version update (1.8.0 -> 1.8.1)

- Update to version 1.8.1:
+ linux: bring our process group to the foreground (fdo#89653).
+ Mark xf86OSKbdPreInit as _X_EXPORT in header to match
definitions.
+ Init LEDs to zero before querying the value.
+ Detangle inet keys and jp Henkan/ Muhenkan keys.

==== yast2-bootloader ====
Version update (3.1.125 -> 3.1.126)

- fix abort when importing bootloader values in autoyast
(bnc#914812)
- 3.1.126




Removed packages:
bundle-lang-common-fi
pulseaudio-esound-compat


Added packages:
esound-daemon
flute
libbase
libfonts
libformula
liblayout
libloader
librepository
libserializer
pentaho-libxml
pentaho-reporting-flow-engine
sac
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages