Mailinglist Archive: opensuse-factory (437 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20150403 released!
Changed packages:

==== Mesa ====
Version update (10.5.1 -> 10.5.2)
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1 libgbm1-32bit
libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- Update to 10.5.2
+ fdo#88534 - include/c11/threads_posix.h PTHREAD_MUTEX_RECURSIVE_NP not
defined
+ fdo#89328 - python required to build Mesa release tarballs
+ fdo#89530 - FTBFS in loader: missing fstat
+ fdo#89590 - Crash in glLinkProgram with shaders with multiple constant
arrays
+ fdo#89680 - Hard link exist in Mesa 10.5.1 sources
+ glsl: Generate link error for non-matching gl_FragCoord redeclarations
+ docs: Add sha256 sums for the 10.5.1 release
+ automake: add missing egl files to the tarball
+ st/egl: don't ship the dri2.c link at the tarball
+ loader: include <sys/stat.h> for non-sysfs builds
+ auxiliary/os: fix the android build - s/drm_munmap/os_munmap/
+ cherry-ignore: add commit non applicable for 10.5
+ c11/threads: Use PTHREAD_MUTEX_RECURSIVE by default
+ i965: Set nr_params to the number of uniform components in the VS/GS path.
+ freedreno/a3xx: use the same layer size for all slices
+ freedreno: fix slice pitch calculations
+ radeonsi: increase coords array size for
radeon_llvm_emit_prepare_cube_coords
+ glx: Handle out-of-sequence swap completion events correctly. (v2)
+ mapi: Make private copies of name strings provided by client.
+ freedreno: update generated headers
+ glsl: optimize (0 cmp x + y) into (-x cmp y).
+ glsl: fix names in lower_constant_arrays_to_uniforms
+ clover: Return 0 as storage size for local kernel args that are not set v2

==== accerciser ====
Subpackages: accerciser-lang

- Replace pyatspi (Build)Requires with py3atspi: accerciser is
a python3 application.
- Split out an accerciser-plugin-IPython package, providing the
IPython console widget.
- Add python3-setuptools and pytho3-IPython Requires to
accerciser-plugin-IPython: IPython-view plugin imports
pkg_resources, which is part of setuptools and, as the name
suggests, is based in IPython.
- Remove %py_requires: it was python2 related and is since auto-
detected.
- Change BuildArch to noarch: accerciser has no binary files.

==== ant ====
Subpackages: ant-jmf ant-scripts ant-swing

- Fix build with new javapackages-tools

==== ant-junit ====

- Fix build with new javapackages-tools

==== apache-commons-codec ====

- Fix build with new javapackages-tools

==== apache-commons-collections ====

- Fix build with new javapackages-tools

==== apache-commons-daemon ====

- Drop gpg verification. We can stick to what osc services do for us
- Drop unused patches:
* 0001-execve-path-warning.patch
* config-guess-sub-update.patch
* jsvc-libcap-relative.patch
- Fix build with new javapackages-tools

==== apache-commons-io ====

- Fix build with new javapackages-tools

==== apache-commons-lang ====

- Fix build with new javapackages-tools

==== apache-commons-logging ====

- Drop maven conditionals that were never triggered.
- Drop gpg offline and rely on service
- Fix build with new javapackages-tools

==== appstream-glib ====
Version update (0.3.5 -> 0.3.6)
Subpackages: libappstream-builder7 libappstream-glib7

- Update to version 0.3.6:
+ trivial: post release version bump.
+ trivial: Make the UTF-8 test actually match the comment.
+ Also subsume application licenses.
+ Do not fail due to style warnings when using relaxed
validation.
+ Add --batch-output to be able to disable the progress panel
when building.
+ configure.ac: gcab is a hard requirement.
+ Remove the gtk3 dep from libappstream-glib.
+ configure.ac: fix typo.
+ Use the correct image URL for HiDPI screenshots.
+ Allow uninstalling AppStream files from /var/cache.
+ Use the upstream screenshot when we are using appstream-builder
- -no-net.
+ Make the AppStream builder support optional.
+ Assume the INF DriverVer is UTC.
+ Always upscale screenshots if they are too small.
+ Teach asb_utils_write_archive() how to write other archive
formats.
+ Put all the screenshots in a file rather than just writing to
the upload path.
+ If the API version is unspecified when building use the latest
released version.
+ Add the source-only tags when outputting AppData files.
+ Add a 'replace-screenshots' command to appstream-util.
+ Update the checksums for the gcab-generated firmware.
+ Do not trust the result of FcConfigAppFontAddFile().
+ Release version 0.3.6.
- Drop appstream-glib-uninstall-var-cache.patch: fixed upstream.
- Add appstream-glib-cairo-link.patch: link the font plugin to
cairo and gtk3.

==== autoyast2 ====
Subpackages: autoyast2-installation

- New autoinst flag in general/mode section: final_restart_services.
Restarting all services after finishing the installation.
The default is "true" which is a backward compatible value.
(bnc#923992)

==== axis ====

- Fix build with new javapackages-tools

==== bcel ====

- Drop gpg-offline
- Drop conditional for manual that is never triggered

==== bsf ====

- Remove gpg-offline dep and cleanup with spec-cleaner
- Fix build with new javapackages-tools

==== cabextract ====
Version update (1.5 -> 1.6)

- Update to version 1.6:
* further UTF-8 fixes
* sanitize file names
- Add -fno-strict-aliasing for md5.c: 114, 115.

==== calligra ====
Subpackages: calligra-doc calligra-extras-dolphin calligra-extras-okular
calligra-krita calligra-stage calligra-words-common

- Added new build requirement Vc-devel-static (for krita).
- Remove soprano as a buildrequires.

==== curl ====
Subpackages: libcurl-devel libcurl4

- don't hardcode /etc/ssl/certs. Use openssl's default instead
(curl-7.41.0-use-openssl-s-built-in-verify-path-as-fallback.diff)

==== libavcodec56 ====
Version update (2.5.3 -> 2.6.1)
Subpackages: libavformat56 libavutil54

- Update to new upstream release 2.6.1
* Maintenance release with some bugfixes
- Update to new upstream release 2.6
* The VP9 decoder is now usable on x86(-32) and pre-SSSE3 CPUs.
* 10-bit support in the SPP video filter
* New video filters: "colorlevels", "tblend", "palettegen",
"paletteuse". New audio filters: "dcshift".
* The old libmpcodecs wrapper is finally gone
* API changes: introduction of device inputs and outputs

==== gcab ====
Version update (0.5 -> 0.6)
Subpackages: libgcab-1_0-0

- Update to version 0.6:
+ Fix for the AFL-detected crashes.
+ Add file information getters (get_attributes(), get_date(),
get_size()).
+ gcab learned --list-details to list files with those
informations.
+ Fix the file date when creating cab.
+ Build-sys fixes.

==== geronimo-j2ee-1_4-apis ====
Subpackages: geronimo-specs-poms

- Fix build with new javapackages-tools

==== gnome-settings-daemon ====

- Drop systemd build condition and pkgconfig(libsystemd-login)
BuildRequires: this hasn't been a dependency since version 3.8.
- Change RPM group of -devel package to
"Development/Languages/C and C++".
- No longer pass --enable-systemd, --enable-gconf-bridge and
- -with-pnpids to configure: those parameters are not available
anymore.
- Change from simple %defines to %bcond_with/without, as this
allows to be set in prjconf without the need to patch the .spec
files.
+ with_systemd, with_wacom, with_wayland, with_smartcard have
been replaced with their equivalent %bcond_with, resp.
%bcond_without, based on the value that was originally set,
resulting in no change for the build.

==== gnome-shell-search-provider-gnome-terminal ====
Subpackages: gnome-terminal nautilus-extension-terminal

- Add gnome-terminal-dark-theme.patch: Allow gnome-terminal to have
dark theme preferance.
- Add libtool BuildRequires and call autoreconf as the above patch
touches the buildsystem.

==== hamcrest ====

- Fix build with new javapackages-tools

==== jakarta-commons-dbcp ====

- Fix build with new javapackages-tools

==== javapackages-tools ====
Version update (2.0.1 -> 4.4.0)

- Drop dependency over source-highlight as it causes build cycle
- Try to break buildcycle detected on Factory
- Fix build on SLE11
- Use python-devel instead of pkgconfig to build on sle11
- Add python-javapackages as requirement for main package
- Update requires on python packages to properly have all the needed
dependencies on runtime
- Install macros to /etc/rpm as we do in SUSE:
* suse-macros-install-location.patch
- Cleanup with spec-cleaner
- Drop patches
* depgen.patch
* javapackages-2.0.1-fix-bashisms.patch
* javapackages-2.0.1-java9.patch
* maven_depmap-no-attribute-exit.patch
- Remove hacky workarounds
- Fix rpmlint errors
- Enable maven-local
- Avoid unsatisfiable dependencies
- Enable unit tests
- Update to version 4.4.0

==== jline ====

- Fix build with new javapackages-tools

==== junit ====

- Fix build with new javapackages-tools

==== kexec-tools ====

- kexec tools are included in the default initrd, we need
to regenerate if this package changes.
- Enable building on m68k

==== libdvdread-devel ====
Version update (5.0.2 -> 5.0.3)
Subpackages: libdvdread4

- Update to version 5.0.3:
* Cache IFO and BUP files (only for ImageFiles) in order to reduce
the number of read/seek access
* Fix compilation warnings for OS/2

==== libevdev-tools ====
Version update (1.3 -> 1.4)
Subpackages: libevdev2

- Update to 1.4:
* libevdev_uinput_destroy: don't close non-open FD
* include: update to 3.18 header
* tools: print the formula to calculate resolutions
* Shut up clang compiler warnings
* tools: fix clang compiler warning
* tools: note that the mouse frequency measured is the
highest frequency
* configure: rename BUILD_TESTS to ENABLE_RUNTIME_TESTS
* test: always build the build-tests
* tools: add a tool to change kernel devices
* test: use -std=c89 instead of c90 for the build test
* cosmetic: fix a couple of duplicate/missing empty lines
* Use memcpy/memmove instead of loop operations
- Update to 1.3.2:
* A new tool has been added to help measure the physical
resolution of a mouse device. This tool can (and should) be
used to create udev hwdb entries for systemd's 70-mouse.hwdb
* Other changes include documentation and tests fixes
- Changes since 1.3.1:
* INPUT_PROP_POINTINGSTICK is now parsed correctly.

==== gdk-pixbuf-loader-rsvg ====
Version update (2.40.8 -> 2.40.9)
Subpackages: librsvg-2-2 librsvg-devel typelib-1_0-Rsvg-2_0

- Update to version 2.40.9:
+ bgo#738367: V/v/H/h commands in path elements were not working.
+ bgo#605875: Gaussian-blurred objects were sometimes missing.
+ bgo#710163: Use _wfullpath() on Windows when canonicalizing
filenames.

==== libseccomp2 ====
Version update (2.1.1 -> 2.2.0)

- Update to new upstream release 2.2.0
* Added support for aarch64, mips, mips64, mips64n32 (BE/LE).
* Added support for using the new seccomp() syscall and the thread
sync functionality.
* Added Python bindings
- Remove 0001-build-use-autotools-as-build-system.patch
(merged). Add no-static.diff.
Add 0001-tools-add-the-missing-elf.h-header-file.patch

==== libsolv-devel ====
Version update (0.6.9 -> 0.6.10)
Subpackages: libsolv-tools perl-solv python-solv

- fix bug in dislike_old_versions that could lead to a segfault
[bnc#922352]
- bump version to 0.6.10

==== libtasn1 ====
Version update (4.3 -> 4.4)
Subpackages: libtasn1-6 libtasn1-6-32bit libtasn1-devel

- update to libtasn1 4.4 [bsc#924828]:
* Corrected a two-byte stack overflow in asn1_der_decoding.

==== libunwind ====

- added baselibs.conf for -xxbit packages

==== libva-drm1 ====
Version update (1.5.0 -> 1.5.1)
Subpackages: libva-egl1 libva-glx1 libva-x11-1 libva1 vaapi-dummy-driver

- Update to version 1.5.1
* API: correct the comment for num_token_partitions in struct
_VAEncPictureParameterBufferVP8
* VA/x11: fix double Unlocks/SyncHandle to avoid segmentation fault

==== libwacom-data ====
Version update (0.11 -> 0.12)
Subpackages: libwacom2

- Update to version 0.12:
+ Added libwacom_stylus_has_wheel() for relative wheel detection.
+ Added libwacom_stylus_get_axes() for a list of supported axes.
+ New devices:
- Cintiq 27QHD, Cintiq 27QHD Touch.
- DTU-1031X.
- Intuos Pen Medium.
+ Reworked udev rules:
- be more restrictive when to set ID_INPUT_TOUCHPAD.
- unset ID_INPUT_JOYSTICK on tablet devices.
- tag the Pad device as ID_INPUT_TABLET_PAD.

==== libwebp5 ====
Version update (0.4.2 -> 0.4.3)
Subpackages: libwebpmux1

- Update to new upstream release 0.4.3
* lossless decode fix and a multi-threading fix
* documentation / vwebp updates for animation

==== libzypp ====
Version update (14.37.0 -> 14.38.0)

- Suppress MediaChangeReport while testing multiple baseurls (bnc#899510)
- version 14.38.0 (30)
- add support for SHA224/384/512
- version 14.37.1 (30)

==== libzypp-plugin-appdata ====

- InstallAppdata.sh: pass --nonet to appstream-util when
validating appstream.xml.gz.
- InstallAppdata.sh: only install AppStream metadata, that
validates.
- Re-enable the actual libzypp plugin in place of shipping a static
version of appstream metadata (last updated for 13.2). We can do
this, as Tumbleweed now produces valid metadata. 3rd party repos
are not yet able to produce valid metadata it seems.

==== mailman ====
Version update (2.1.19 -> 2.1.20)

- update to 2.1.20
* fix for CVE-2015-2775 (path traversal vulnerability)
* new Address Change sub-section in the web admin Membership
Management section
* translation updates and bug fixes

==== mc ====
Version update (4.8.13 -> 4.8.14)
Subpackages: mc-lang

- GNU Midnight Commander 4.8.14:
* Core:
+ Minimal version of GLib is 2.14.0
+ Add new panel binding "SelectExt" to select/unselect files
with the same extension as the current file
+ Speed up of directory size calculation
+ Support of italic text
* Editor:
+ New syntax highlighting support: puppet
* Viewer:
+ Rewrite mcview's rendering and scrolling
+ Use VIEW_SELECTED_COLOR in plain mode
+ In QuickView panel, don't pass any chars to command line to
avoid unexpected command execution
* Misc:
+ Code cleanup
+ Bind poedit to Edit action for .po files
+ Better grammar mcedit user menu
* Various bug fixes

==== libXm4 ====

- Use url for source
- Cleanup spec file with spec-cleaner
- Remove old ppc obsoletes/provides

==== mysql-connector-java ====

- Fix build with new javapackages-tools

==== nano ====
Subpackages: nano-lang

- Add gpg signature

==== notification-daemon ====
Version update (3.15.2 -> 3.16.0)

- Update to version 3.16.0:
+ Free memory returned by g_find_program_in_path.
+ Updated translations.

==== perl-DBD-Pg ====
Version update (3.5.0 -> 3.5.1)

- Update to version 3.5.1 from 3.5.0
Upstream changes:
- Prevent core dump if the second argument to the quote() method
is anything but a hashref
- Better "support" for SQL_ASCII servers in the tests.
Allow env var DBDPG_TEST_ALWAYS_ENV to force use of DBI_DSN and DBI_USER
in tests.
- Fix client_encoding detection on pre-9.1 servers
- Fix operator existence check in tests on pre-8.3 servers
- Documentation fix
- Fix pg_switch_prepared database handle documentation

==== regexp ====

- Fix build with new javapackages-tools

==== rhino ====

- Fix build with new javapackages-tools

==== saxon9 ====
Subpackages: saxon9-scripts

- Fix build with new javapackages-tools

==== slf4j ====

- Fix build with new javapackages-tools

==== libsource-highlight4 ====
Version update (3.1.7 -> 3.1.8)
Subpackages: source-highlight

- Update to 3.1.8
* src/lang.map: .f mapped to fotran
* src/sh.lang: do not consider $' a variable
* https://savannah.gnu.org/bugs/?36613
- Use correct requires for info

==== libspice-client-glib-2_0-8 ====
Version update (0.27 -> 0.28)
Subpackages: libspice-client-gtk-2_0-4 libspice-client-gtk-3_0-4
libspice-controller0 python-SpiceClientGtk typelib-1_0-SpiceClientGlib-2_0
typelib-1_0-SpiceClientGtk-3_0

- Update to version 0.28:
+ webdav improvements:
- No longer spawn a server thread
- No longer use local TCP sockets & port
- Provides read-only mode with SpiceSession:share-dir-ro
- Requires libphodav-2.0 glib-2.0 >= 2.43.90 libsoup-2.4 >=
2.49.91
+ Drop gstreamer 0.10 in favour of 1.0
+ Add spice+unix://path connection support
+ Accept URI with empty parameters value, such as
spice://localhost?port=5900&tls-port=
+ Fixed lz4 support
+ Silence some harmless warnings
+ Misc API documentation improvements
+ Switch-host migration fixes
+ Learn to build --without-gtk
+ Bugs and regressions fixes
- Add pkgconfig(liblz4) BuildRequires and pass --enable-lz4 to
configure.

==== strace ====

- Drop strace-32bit, since the normal strace build is powerful
enough. [bnc#924827]

==== libsvn_auth_kwallet-1-0 ====
Version update (1.8.11 -> 1.8.13)
Subpackages: subversion subversion-bash-completion subversion-devel
subversion-perl subversion-python subversion-server subversion-tools

- Apache Subversion 1.8.13
This release fixes three vulerabilities:
* Subversion HTTP servers with FSFS repositories were vulnerable
to a remotely triggerable excessive memory use with certain
REPORT requests.
(bsc#923793 CVE-2015-0202)
* Subversion mod_dav_svn and svnserve were vulnerable to a
remotely triggerable assertion DoS vulnerability for certain
requests with dynamically evaluated revision numbers.
(bsc#923794 CVE-2015-0248)
* Subversion HTTP servers allow spoofing svn:author property
values for new revisions
(bsc#923795 CVE-2015-0251)
- Non-security updates:
* fixes number of client and server side non-security bugs
* improved working copy performanc
* reduction of resource use
* stability improvements
* usability improvements
- 1.8.12 was not released

==== tei-xsl-stylesheets ====
Version update (5.4.24 -> 7.32.0)

- Update to version 7.32.0
* needs table wrapper around free-standing constraints in a schemaSpec
* allow for docProps file to not be present (eg from Google docs)
* handle meeting data more convincingly
* Update for v9 of word styles
* added param for currentDir and added slash as separator
* add tei to simple conversion
* added param for currentDir and added slash as separator
* changed FO results
* add paramete for FO lineheight application rules
* add paramete for FO lineheight application rules
* add parameters for front, body, back line-height
* add parameters for front, body, back line-height
* at the moment only applied to tei:p[not(parent::tei:note)]
- For the other news, please read the changelog
- Cleanup specfile
- Update download Url
- Remove changelog entries from specfile
- Remove obsolete %clean and AUTHORS sections
- Remove duplicate files with fdupes

==== tomcat ====
Subpackages: tomcat-admin-webapps tomcat-el-2_2-api tomcat-jsp-2_2-api
tomcat-lib tomcat-servlet-3_0-api tomcat-webapps

- Fix previous commit. Fix one rpmlint warning
- Drop gpg verification from spec, it is done by obs
- Fix build with new jpackage-tools

==== vaapi-intel-driver ====
Version update (1.5.0 -> 1.5.1)

- Update to version 1.5.1:
+ Fix forward reference requirement for Bob deinterlacing.
+ Fix a lot of potential rendering issues on GEN8+.
+ Fix scaling of NV12 surfaces when no output_region is set.
+ Fix the broken attribute setting of i965_GetConfigAttrib.
+ Fix the GetConfigAttributes() for JPEGBaseline profile.
+ Fix the wrong overlap setting for VC-1 decoding on GEN6+.
+ Fix VP8 decoding issue on GEN8+, HW needs 1 extra byte for each
partition.
+ Fix JPEG encoding issue.
+ Add support for aub dump.
+ Enhance STD on GEN8+.
+ Implement max width and height in QuerySurfaceAttributes.
+ Add new SKL PCI ids.

==== virt-install ====
Subpackages: virt-manager virt-manager-common

- virtman-allow-creating-i686-vm.patch: Allow creating i686 VM on x86_64
(bsc#919692)
- Revert the last commit
- virtman-allow-creating-i686-vm.patch: Allow creating i686 VM on x86_64

==== libjavascriptcoregtk-4_0-18 ====
Subpackages: libwebkit2gtk-4_0-37 typelib-1_0-JavaScriptCore-4_0
typelib-1_0-WebKit2-4_0 webkit2gtk-4_0-injected-bundles

- Change webkit2gtk-4_0-injected-bundles Recommends to Requires:
apps fail to load webkit if the bunldes are not available.

==== wireless-regdb ====
Version update (2014.10.07 -> 2015.01.30)

- Update to 2015.01.30

==== wsdl4j ====

- Fix build with new javapackages-tools

==== xf86-video-trident ====
Version update (1.3.6 -> 1.3.7)

- Update to version 1.3.7
* eventually a release which includes all changes required for
building with current Xserver sources since the previous
release in 2012
- removed upstreamed patches now in 1.3.7:
* U_Fix-loading-the-driver-without-XAA.patch
* U_Remove-mibstore.h.patch

==== xml-commons ====
Subpackages: xml-commons-jaxp-1.1-apis xml-commons-jaxp-1.3-apis
xml-commons-resolver10 xml-commons-which10

- Fix build with new javapackages-tools

==== xmlgraphics-commons ====

- Fix build with new javapackages-tools

==== xmlgraphics-fop ====

- Fix build with new javapackages-tools

==== xorg-x11-server ====
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk

- U_os-XDMCP-options-like-query-etc-should-imply-listen.patch
* Enable listening on tcp when using -query. (bnc#924914)

==== yast2-core ====
Version update (3.1.16 -> 3.1.17)
Subpackages: yast2-core-devel

- Fix YCP symbol comparison with GCC 5 (thanks schubi for
performance measurement and mvidner for review) (boo#914255)
- 3.1.17




Removed packages:
libdirectfb-1_7-6


Added packages:
libdirectfb-1_7-7
python-javapackages
python-pyxb
xf86-input-libinput
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages