Mailinglist Archive: opensuse-factory (548 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20150115 released!
Changed packages:

==== NetworkManager ====
Subpackages: NetworkManager-devel libnm-glib-vpn1 libnm-glib4 libnm-util2
typelib-1_0-NMClient-1_0 typelib-1_0-NetworkManager-1_0

- Add NetworkManager-dhcpv6.patch: dhcp: let dhclient handle
requesting the 'server-id' option (boo#912315).

==== libSDL-1_2-0 ====
Subpackages: libSDL-devel

- libspe2 only exists for ppc and ppc64
- Avoid bs_sched computation failure by expanding %power64

==== libSDL_Pango1 ====

- Use pkgconfig() symbols for pulling in BuildRequires

==== libSDL_gfx15 ====

- Remove redundant requires

==== libSDL_image-1_2-0 ====

- Improve package summary and description. Drop --with-pic which
is enabled implicitly anyway, remove redundant Requires.

==== libSDL_mixer-1_2-0 ====

- Improve package summary and description. Drop --with-pic which
is enabled implicitly anyway, remove redundant Requires.
- Enable modplug support

==== libSDL_net-1_2-0 ====

- Improve package summary and description. Drop --with-pic which
is enabled implicitly anyway, remove redundant Requires.

==== libSDL_sound-1_0-1 ====

- Improve package summary and description. Drop --with-pic which
is enabled implicitly anyway.

==== libSDL_ttf-2_0-0 ====

- Improve package summary and description. Drop --with-pic which
is enabled implicitly anyway, remove redundant Requires.

==== abcde ====
Version update (2.3.99.6 -> 2.6)

- Update to version 2.6
+ Fix finding $CDROM on OS X. Closes issue 71.
+ USEID3 and USEID3V2 variables are unused now, so remove them.
Closes issue 73.
+ Clean up movement to eyeD3, remove id3v2 remnants. Closes issue 74.
+ Fix infinite loop if cddb fails. Closes: #687038 in Debian
+ Switch from Musepack SV7 to SV8.
+ Allow aac encoding with neroAacEnc. Closes issue 8.
+ Allow opus encoding with opusenc. Closes issue 70.
+ Fix typo: s/CUEWAVEFILE/CUEWAVFILE/ so that abcde.mkcue should now
produce working cue files. Closes issue 78.
+ Remove no-op -q option. Closes issue 106.
+ Fix issue 112: perl encoding pragma deprecation.
+ Fix option parsing for multiple output formats. Closes issue 115.
+ Fix eyeD3 tagging for cddb entries without year. Closes issue 107
+ Add mention of CD-TEXT support in the man page. Closes issue 102.
+ Make Y/N prompting more consistent. Closes issue 95
+ Remove the no-op -B option. Closes: #426531 in Debian
+ Document the need to escape parentheses in tag comments.
Closes: #256941 in Debian.
+ Concatenate option steps on -t/-T option. Closes: #391294 in Debian
+ Try to use bsd-mailx where possible to force UTF-8 for cddb-tool mail
submissions. If not possible, attempt to force UTF-8 via the
environment and fall back to mail instead. Closes: #756289 in Debian,
issue 111.
- Make cd-discid live in it's own package
- Update Urls and dowload sources
- Refresh the old abcde_2.3.99.6-quote.patch to abcde_2.6-quote.patch

==== alpine-branding-openSUSE ====

- Disable IMAP-over-SSH by defualt [bnc#912611]

==== amarok ====

- Add 0008-Clean-up-the-leftover-of-strigi-removal.patch:
remove unneeded Strigi reference in the Ampache plugin build
system
- Add 0009-Fix-Ampache-plugin-connections.patch: unbreak Ampache
plugin connection due to wrong hashing algorithm being used

==== amor ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- Redone lost patch to fix boo#859439
+ service reload can cause log data to be lost with logrotate
under some circumstances: remove "-t" from service reload.
[bnc#859439]
- Fix URL syntax in various files

==== appstream-glib ====
Version update (0.3.1.git.20141031.f9c620c -> 0.3.1.git.20150103.a7941d7)
Subpackages: libappstream-builder7 libappstream-glib7

- Update to version 0.3.1.git.20150103.a7941d7:
+ Assume that stock icons are available in HiDPI sizes.
+ Blacklist the IBus desktop files used in gnome-control-center.
+ Add several more non-applications to the blacklist.
+ Blacklist KDE3 KCM components.
+ Assume <image>foo</iimagemg> is a source image kind for AppData
files.
+ trivial: Support ASB_PACKAGE_ENSURE_VCS for RPM packages.
+ Handle other-endian MO files.
+ trivial: Add 4 more stock icons to the whitelist.
+ Fall back to the dumb tokenizer for keywords with special
chars.

==== ark ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkerfuffle4

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== autoyast2 ====
Version update (3.1.71 -> 3.1.72)
Subpackages: autoyast2-installation

- Selecting needed yast packages for the second stage correctly.
(bnc#909751)
- 3.1.72

==== bdftopcf ====
Version update (1.0.4 -> 1.0.5)

- Update to version 1.0.5:
This minor maintenance release fixes a couple of issues with the
usage messages printed for incorrect options, and updates the
configure scripts to the latest X.Org standards.

==== bison ====
Version update (2.7 -> 3.0.2)

- Update to version 3.0.2
+ Generated source files when errors are reported
+ %empty is used in reports
+ When C++ variant support is enabled, an error triggered via YYERROR,
but not caught via error recovery, resulted in a double deletion.
- Remove location-eof-check.patch; merged on upstream release
- location-eof-check.patch: Fix broken EOF check
- Update to bision 3.0
* deep overhaul/improvements of the diagnostics
* more versatile means to describe semantic value types,
including the ability to store genuine C++ objects in C++ parsers
* push-parser interface extended to Java
* parse-time semantic predicates for GLR parsers.
* This is a major update, please see https://lwn.net/Articles/561990/
for all details and backward incompatible changes.

==== blinken ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== bovo ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== brltty ====
Version update (5.1 -> 5.2)
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-espeak
brltty-driver-speech-dispatcher brltty-driver-xwindow libbrlapi0_6
python3-brlapi xbrlapi

- Add a dependency to python3 for building; brltty fails in his staging
project because of mssing python3-xml module
- Update to version 5.0.2
+ Too many changes; please read ChangeLog :
usr/share/doc/packages/brltty/ChangeLog
- API version is now 0.6.3
- Remove obsolete patches;
+ brltty-python-prefix.patch
+ brltty-5.1-fix-bashisms.patch

==== cairo-devel ====
Subpackages: libcairo-gobject2 libcairo-script-interpreter2 libcairo2
libcairo2-32bit

- Add cairo-tor-scan-convertor.patch: tor-scan-converter: can't
do_fullrow when intersection in row + 0.5subrow (fdo#85151).

==== calibre ====
Version update (2.15.0 -> 2.16.0)

- Update to version 2.16.0:
* New features:
- Edit Book: Add support for snippets -- small pieces of text
that are often re-used.
* Bug fixes:
- Edit Book: When importing files and the book has an orphaned
entry in the manifest for that file, but the file itself is
not present, rename the file instead of erroring out.
- Book Details panel: Fix author links with URL schemes other
than http or file preventing context menu from working.
- PDF Output: Make the minimum height for headers and footers
scale with the base font size
- Fix a typo that prevented the Cybook Muse from being detected
on some computers.
- Fix regression in 2.15 that broke calibre on OS X 10.7 and
10.8
* Improved news sources:
- Various updated Turkish news sources
- tyzden
- Sueddeutsche Zeitung
* New news sources:
- title: Ajans Firat and Edebiyat Haber
author: asalet_r
* For details, see http://calibre-ebook.com/whats-new
- Update no-update patch to actually inverse the logic and let
user override it:
* calibre-no-update.diff
- Do not use bundled beautifulsoup
- No need to build without strict aliasing
- Remove code that unpacks csselect directly as it was 12.2 only
which is obsolete for quite time already

==== cervisia ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== cpio ====

- build with PIE

==== cracklib ====
Version update (2.9.0 -> 2.9.2)
Subpackages: libcrack2 libcrack2-32bit

- Update to version 2.9.2
+ support build of python support outside of source tree
+ fix bug in Python string distance calculation
+ fix bug #16 / debian bug 724570 - broken optimization with packlib
prevblock
- Adapt patch to upstream changes
+ cracklib-visibility.patch > cracklib-2.9.2-visibility.patch

==== curl ====
Version update (7.39.0 -> 7.40.0)
Subpackages: libcurl-devel libcurl4

- update to 7.40.0:
* fixes CVE-2014-8150 (bnc#911363)
* Changes:
http_digest: Added support for Windows SSPI based authentication
version info: Added Kerberos V5 to the supported features
Makefile: Added VC targets for WinIDN
config-win32: Introduce build targets for VS2012+
SSL: Add PEM format support for public key pinning
smtp: Added support for the conversion of Unix newlines during mail send
smb: Added initial support for the SMB/CIFS protocol
Added support for HTTP over unix domain sockets,
via CURLOPT_UNIX_SOCKET_PATH and --unix-socket
sasl: Added support for GSS-API based Kerberos V5 authentication

==== cyrus-sasl ====
Subpackages: cyrus-sasl-crammd5 cyrus-sasl-devel cyrus-sasl-digestmd5
cyrus-sasl-gssapi cyrus-sasl-plain libsasl2-3 libsasl2-3-32bit

- bnc#908883 cyrus-sasl-scram refers to wrong RFC

==== diffutils ====

- build with PIE

==== dragonplayer ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== dvb ====

- add dvb-scan-dont-segfault.patch to avoid dvbscan segfault in
usage message if called without any parameter

==== e2fsprogs ====
Subpackages: e2fsprogs-devel libcom_err-devel libcom_err2 libcom_err2-32bit
libext2fs-devel libext2fs2

- e2fsck-fix-free-pointer-dereferences.patch: Fix use after free (bnc#912229)

==== elfutils ====
Version update (0.158 -> 0.161)
Subpackages: libasm1 libdw1 libelf1 libelf1-32bit

- CVE-2014-9447: elfutils: Directory traversal vulnerability (bnc#911662)
Add patch: elfutils-fix-dir-traversal-vuln-in-ar-extraction.patch
- Update to version 0.161
+ libdw: New function dwarf_peel_type. dwarf_aggregate_size now uses
dwarf_peel_type to also provide the sizes of qualified types.
dwarf_getmacros will now serve either of .debug_macro and
.debug_macinfo transparently. New interfaces
dwarf_getmacros_off, dwarf_macro_getsrcfiles,
dwarf_macro_getparamcnt, and dwarf_macro_param are available
for more generalized inspection of macros and their parameters.
dwarf.h: Add DW_AT_GNU_deleted, DW_AT_noreturn, DW_LANG_C11,
DW_LANG_C_plus_plus_11 and DW_LANG_C_plus_plus_14.
- Remove merged patches
+ elfutils-robustify.patch
+ elfutils-no-po-test-build.diff
+ elfutils-check-for-overflow-before-calling-malloc-to-uncompress-data.patch
- Refreshed patch (from Fedora sources)
+ elfutils-portability.patch > elfutils-portability-0.161.patch
- Add a lang subpackage

==== eog ====
Version update (3.14.2 -> 3.14.3)

- Update to version 3.14.3:
+ Fix preferences dialog when using aggressive linker settings
(bgo#739618).
+ Fixed a few memory leaks (bgo#740348).
+ Updated translations.

==== fetchmail ====

- Cleanup with spec-cleaner
- Remove support for <12.3 as it does not build anyway.
- Fix krb5 switches
- Provide proper rcbla controler for the service
- build with PIE

==== findutils ====

- findutils-oldfind-fix-dotdot-skipping.patch: Add upstream patch
to fix 'oldfind' which skipped all files starting with ".."
(e.g. "..file").
- findutils.spec: Add BuildRequires:dejagnu - otherwise only a
very limited set of the tests was run by 'make check'.

==== flex ====

- Add flex-compatible-with-bison3.patch
* fix tests with bison3, see
http://sourceforge.net/p/flex/flex/ci/c376be574e99b5f64a7dad71cfc7c0b1f71b747b/

==== fonts-config ====

- added Command: metadata to relevant sysconfig variables
[bnc#912279]

==== frogr ====
Version update (0.10 -> 0.11)
Subpackages: frogr-lang

- Update to version 0.11:
+ Moved to GtkHeaderBar plus a new menu button for GTK+ >= 3.12.
+ Added new option to replace "date posted" with "date taken" for
new uploads.
+ Speeded up picture loading when the "import tags" feature is
enabled.
+ Fixed random crashes due to missing initialization of the
gcrypt library.
+ Fixed issue setting inconsistent state of toggle buttons for
multiple pictures.
+ Removed deprecated usage of GtkAlignment and
gtk_misc_set_padding().
+ Removed usage of deprecated icon names (use those from the Icon
Naming Spec).
+ Normalized .doap file (added 'category' and
'programming-language').
+ Set the minimum required version of gcrypt to 1.5.0.
+ Bugs fixed: bgo#732475, bgo#734193, bgo#734202, bgo#738863.
+ Updated translations.

==== libgc1 ====
Version update (7.2d -> 7.4.2)

- Update to version 7.4.2
* Add config option to use STGRTMIN-based signals for thread
suspend/resume.
* Allow parallel mark to be enabled on powerpc-linux systems.
* Fix 'Array subscript is above array bounds' GCC warning in
GC_new_kind/proc.
* Fix 'attribute declaration must precede definition' warning.
* Fix GC_finalized_malloc failure on disclaim_test.
* Fix GC_sig_suspend initialization when non-constant SIGRTMIN used.
* Fix data roots registration for Android/x86 and NDK ARM 'gold'
linker.
* Fix find stackbottom on BlueGene P/Q systems.
* Fix machdep .lo files path in configure (SPARC, IA-64).
* Fix ok_init assignment (missing cast) in GC_new_kind_inner.
- Remove aarch64-support.patch; merged on upstream release
- gc project has a new home; update URL tag and download source URL

==== grep ====

- build with PIE enabled

==== libgssdp-1_0-3 ====
Version update (0.14.10 -> 0.14.11)

- Update to version 0.14.11:
+ Don't use inet_netof to filter for correct source networks.
+ Add gssdp_resource_browser_rescan() function.
+ Allow custom TTL values for GSSDPClient.
+ Bugs fixed: bgo#656406, bgo#668922, bgo#692516.

==== glade-catalog-gtksourceview ====
Version update (3.14.2 -> 3.14.3)
Subpackages: gtksourceview-devel libgtksourceview-3_0-1
typelib-1_0-GtkSource-3_0

- Update to version 3.14.3:
+ Bug fixes.
+ Updated translations.

==== libgupnp-1_0-4 ====
Version update (0.20.12 -> 0.20.13)

- Update to version 0.20.13:
+ Fix cyclic includes.
+ Avoid redefinition of symbols.
+ Fix missing function declaration.
+ Don't check for connman.pc.
+ Allow actions without arguments.
+ Respect "prefer_bigger" even if there is no icon size.
+ DOAP fixes.
+ Fix VAPI generation.
+ Fix reference counting.
+ Port to new libsoup API.
+ Bugs fixed: bgo#722696, bgo#731209, bgo#731457, bgo#733241,
bgo#740267, bgo#742075.

==== gvfs ====
Version update (1.22.2 -> 1.22.3)
Subpackages: gvfs-backend-afc gvfs-backends gvfs-fuse

- Update to version 1.22.3:
+ Fix metadata deamon crashes.
+ Several improvements to unmounting reliability.
+ Several smaller bugfixes.
+ Updated translations.

==== hwinfo ====
Version update (21.10 -> 21.11)
Subpackages: hwinfo-devel

- Add PowerNV platform support
- 21.11

==== icewm ====
Subpackages: icewm-default icewm-lite

- Fix the bnc#905159:shutdown and reboot commands not working.
Change the shutdown and reboot command in preference.
Add patch: icewm-1.3.8-shutdown-reboot-command.patch
and updated from upstream:https://github.com/bbidulock/icewm.

==== inkscape ====
Subpackages: inkscape-extensions-dia inkscape-extensions-extra
inkscape-extensions-fig inkscape-extensions-gimp inkscape-extensions-skencil
inkscape-lang

- Add inkscape-gc-detection.patch: Use pkg-config to detect bdw-gc.

==== iproute2 ====
Version update (3.17 -> 3.18)

- Update to new upstream release 3.18
* Human readable output for `ip -s link` (ip -s -h link)
* Permit filtering `ip monitor` events by device per "dev NAME".
* Permit filtering `ip link` output by device per "master NAME",
and by type per `type T` (e.g. type vlan).
* Permit filtering `ip addr` output by flags like "tentative" and
"-tentative".
- fix bashisms in gaiconf script
- add patches:
* iproute2-3.16.0-fix-bashisms.patch

==== irssi ====

- build with PIE

==== java-1_8_0-openjdk ====
Version update (1.8.0.40~b12 -> 1.8.0.40~b20)
Subpackages: java-1_8_0-openjdk-headless

- Upgrade to upstream tag jdk8u40-b20
* Switch to the jdk8u40 stabilisation branch that will result in
the jdk8u40 release
- Removed patch:
* hotspot-build-j-directive.patch
- integrated in the jdk8u40-b20 version of hotspot
- Added patches:
* aarch64-b12tob20.patch
- port the relevant changes between builds b12 and b20 to the
aarch64 tarball that is on the upstream tag of jdk8u40-b12
* cplusplus-interpreter.patch
- fix a build of C++ interpreter that is used with Zero virtual
machine.
- zero-javadoc-verbose.patch: Avoid triggering inactivity timeout while
generating javadoc in zero VM

==== juk ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kalzium ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kio_kamera ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== katomic ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kblackbox ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kblocks ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kbounce ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kbreakout ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kbruch ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kcachegrind ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kcalc ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kcharselect ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kchmviewer ====
Version update (6.1 -> 7.2.1)

- Update to 7.2.1
* Fixed a crash when indexing (in search) certain malformed HTML files.
* Fixed parsing CHM files whose filenames contained URL-encoded characters.
- Remove upstreamed ftbfs.patch

==== kcolorchooser ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kcron ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kde-mplayer-thumbnailer ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kde4-print-manager ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdeartwork4-decorations ====
Version update (4.14.3 -> 14.12.0)
Subpackages: kdeartwork4-screensaver

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdebase4-runtime ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdenetwork4-filesharing ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kio_svn ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdesdk-strigi-analyzers ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kfilereplace ====
Version update (4.14.3 -> 14.12.0)
Subpackages: kimagemapeditor klinkstatus

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdf ====
Version update (4.14.3 -> 14.12.0)
Subpackages: kwikdisk

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdiamond ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdnssd ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kexec-tools ====

- Fix x86 callback prototypes (bnc#905090)
Add patch: kexec-tools-callback-function-proto.patch

==== kfloppy ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kgamma ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kgeography ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kget ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kgoldrunner ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kgpg ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kio_audiocd ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kiriki ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== fonts-KanjiStrokeOrders ====
Version update (4.14.3 -> 14.12.0)
Subpackages: kiten

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kjumpingcube ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== klettres ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmag ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmahjongg ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmines ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmousetool ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmouth ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kmplot ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== knavalbattle ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== knetwalk ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kolf ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kollision ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kolourpaint ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kompare ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== konquest ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kopete ====
Version update (4.14.3 -> 14.12.0)

- build with PIE
- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kpat ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kppp ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kqtquickcharts ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== krb5 ====
Version update (1.12.2 -> 1.13)
Subpackages: krb5-32bit krb5-client krb5-devel

- Update to krb5 1.13
* Add support for accessing KDCs via an HTTPS proxy server using the
MS-KKDCP protocol.
* Add support for hierarchical incremental propagation, where slaves
can act as intermediates between an upstream master and other downstream
slaves.
* Add support for configuring GSS mechanisms using /etc/gss/mech.d/*.conf
files in addition to /etc/gss/mech.
* Add support to the LDAP KDB module for binding to the LDAP server using
SASL.
* The KDC listens for TCP connections by default.
* Fix a minor key disclosure vulnerability where using the "keepold" option
to the kadmin randkey operation could return the old keys. [CVE-2014-5351]
* Add client support for the Kerberos Cache Manager protocol. If the host
is running a Heimdal kcm daemon, caches served by the daemon can be
accessed with the KCM: cache type.
* When built on OS X 10.7 and higher, use "KCM:" as the default cache type,
unless overridden by command-line options or krb5-config values.
* Add support for doing unlocked database dumps for the DB2 KDC back end,
which would allow the KDC and kadmind to continue accessing the database
during lengthy database dumps.
- Removed patches, useless or upstreamed
* krb5-1.9-kprop-mktemp.patch
* krb5-1.10-ksu-access.patch
* krb5-1.12-doxygen.patch
* bnc#897874-CVE-2014-5351.diff
* krb5-1.13-work-around-replay-cache-creation-race.patch
* krb5-1.10-kpasswd_tcp.patch
- Refreshed patches
* krb5-1.12-pam.patch
* krb5-1.12-selinux-label.patch
* krb5-1.7-doublelog.patch

==== krdc ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kremotecontrol ====
Version update (4.14.3 -> 14.12.0)
Subpackages: liblibkremotecontrol1

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kreversi ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== krfb ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kruler ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksaneplugin ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kscd ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kshisen ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksirk ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksnapshot ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kspaceduel ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksquares ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kstars ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksudoku ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ksystemlog ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kteatime ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ktimer ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ktouch ====
Version update (4.14.3 -> 14.12.0)

- Require libqt4-sql-sqlite, ktouch does not work without it
- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kturtle ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== ktux ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kubrick ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kwalletmanager ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kwordquiz ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== liblasem-0_4-4 ====

- Add lasem-bison-3.0.patch: Fix build with bison 3.0.

==== lftp ====
Version update (4.6.0 -> 4.6.1)

- lftp 4.6.1:
* new mirror option --scan-all-first.
* mirror --Remove-source-files now removes files already present
at the target.
* added a workaround for FUSE with HadoopFS I/O error during
rename(2).
* fixed du to round file size up to block size.
* fixed compilation with libressl.
* fixed OPTS MLST, removed trailing semicolon.
* fixed put to sftp with special files (like /dev/stdin).
* fixed ftp to copy SID properly with GnuTLS
* fixed mirror to follow redirections to files

==== libevdev-tools ====
Version update (1.2 -> 1.3)
Subpackages: libevdev2

- Update to 1.3:
* m4: fix CC_CHECK_WERROR and CC_FLAG_VISIBILITY macros
* Add per-device log handlers
* include: update to Linux 3.15 header
* uinput: use the UI_GET_SYSNAME ioctl if available
* uinput: change strcpy/strcat usage for snprintf
* include: add uinput.h header as well
* include: update to Linux 3.16 header
* uinput: check errno against the positive value
* uinput: preserve the errno before cleaning up
* configure: move the python check down to re-unite the
gcov check outputs
* Add libevdev_property_from_name()
* Rename symbols leaking from static library to
avoid name clashes
* uinput: close the managed fd on error
* tools: pass -rc to strerror, not rc
* uinput: explicitly ignore the UI_DEV_DESTROY return value
* Hook up nm to check for leaking symbols in the static library
* Add some minimal documentation about static linking

==== libjpeg-turbo ====
Version update (1.3.1 -> 1.4.0)
Subpackages: libjpeg8 libjpeg8-32bit libturbojpeg0

- Update to version 1.4.0
+ Fixed a build issue on OS X PowerPC platforms (md5cmp failed to build
because OS X does not provide the le32toh() and htole32() functions.)
+ The non-SIMD RGB565 color conversion code did not work correctly on big
endian machines. This has been fixed.
+ Fixed an issue in tjPlaneSizeYUV() whereby it would erroneously return 1
instead of -1 if componentID was > 0 and subsamp was TJSAMP_GRAY.
+ Fixed an issue in tjBufSizeYUV2() wherby it would erroneously return 0
instead of -1 if width was < 1.
+ The Huffman encoder now uses clz and bsr instructions for bit counting on
ARM64 platforms (see 1.4 beta1 [5].)
+ The close() method in the TJCompressor and TJDecompressor Java classes is
now idempotent. Previously, that method would call the native tjDestroy()
function even if the TurboJPEG instance had already been destroyed. This
caused an exception to be thrown during finalization, if the close() method
had
already been called. The exception was caught, but it was still an
expensive
operation.
+ The TurboJPEG API previously generated an error ("Could not determine
subsampling type for JPEG image") when attempting to decompress grayscale
JPEG
images that were compressed with a sampling factor other than 1 (for
instance,
with 'cjpeg -grayscale -sample 2x2'). Subsampling technically has no
meaning
with grayscale JPEGs, and thus the horizontal and vertical sampling factors
for such images are ignored by the decompressor. However, the TurboJPEG API
was being too rigid and was expecting the sampling factors to be equal to 1
before it treated the image as a grayscale JPEG.
+ cjpeg, djpeg, and jpegtran now accept an argument of -version, which will
print the library version and exit.
+ Referring to 1.4 beta1 [15], another extremely rare circumstance was
discovered under which the Huffman encoder's local buffer can be overrun
when a buffered destination manager is being used and an
extremely-high-frequency block (basically junk image data) is being encoded.
Even though the Huffman local buffer was increased from 128 bytes to 136
bytes
to address the previous issue, the new issue caused even the larger buffer
to
be overrun. Further analysis reveals that, in the absolute worst case
(such as
setting alternating AC coefficients to 32767 and -32768 in the JPEG scanning
order), the Huffman encoder can produce encoded blocks that approach double
the
size of the unencoded blocks. Thus, the Huffman local buffer was increased
to
256 bytes, which should prevent any such issue from re-occurring in the
future.
+ The new tjPlaneSizeYUV(), tjPlaneWidth(), and tjPlaneHeight() functions
were not actually usable on any platform except OS X and Windows, because
those functions were not included in the libturbojpeg mapfile. This has
been
fixed.
+ Restored the JPP(), JMETHOD(), and FAR macros in the libjpeg-turbo header
files. The JPP() and JMETHOD() macros were originally implemented in
libjpeg
as a way of supporting non-ANSI compilers that lacked support for prototype
parameters. libjpeg-turbo has never supported such compilers, but some
software packages still use the macros to define their own prototypes.
Similarly, libjpeg-turbo has never supported MS-DOS and other platforms that
have far symbols, but some software packages still use the FAR macro. A
pretty
good argument can be made that this is a bad practice on the part of the
software in question, but since this affects more than one package, it's
just
easier to fix it here.
+ Fixed issues that were preventing the ARM 64-bit SIMD code from compiling
for iOS, and included an ARMv8 architecture in all of the binaries
installed by
the "official" libjpeg-turbo SDK for OS X.
- Adapt patches to upstream changes
libjpeg-ocloexec.patch > libjpeg-1.4.0-ocloexec.patch
libjpeg-turbo-1.3.0-int32.patch > libjpeg-turbo-1.4.0-int32.patch
- Remove libjpeg-turbo-CVE-2014-9092.patch; fixed on upstream release
- Bump tminor to 1

==== libjpeg62 ====
Subpackages: libjpeg62-devel

- Update to version 1.4.0
+ Fixed a build issue on OS X PowerPC platforms (md5cmp failed to build
because OS X does not provide the le32toh() and htole32() functions.)
+ The non-SIMD RGB565 color conversion code did not work correctly on big
endian machines. This has been fixed.
+ Fixed an issue in tjPlaneSizeYUV() whereby it would erroneously return 1
instead of -1 if componentID was > 0 and subsamp was TJSAMP_GRAY.
+ Fixed an issue in tjBufSizeYUV2() wherby it would erroneously return 0
instead of -1 if width was < 1.
+ The Huffman encoder now uses clz and bsr instructions for bit counting on
ARM64 platforms (see 1.4 beta1 [5].)
+ The close() method in the TJCompressor and TJDecompressor Java classes is
now idempotent. Previously, that method would call the native tjDestroy()
function even if the TurboJPEG instance had already been destroyed. This
caused an exception to be thrown during finalization, if the close() method
had
already been called. The exception was caught, but it was still an
expensive
operation.
+ The TurboJPEG API previously generated an error ("Could not determine
subsampling type for JPEG image") when attempting to decompress grayscale
JPEG
images that were compressed with a sampling factor other than 1 (for
instance,
with 'cjpeg -grayscale -sample 2x2'). Subsampling technically has no
meaning
with grayscale JPEGs, and thus the horizontal and vertical sampling factors
for such images are ignored by the decompressor. However, the TurboJPEG API
was being too rigid and was expecting the sampling factors to be equal to 1
before it treated the image as a grayscale JPEG.
+ cjpeg, djpeg, and jpegtran now accept an argument of -version, which will
print the library version and exit.
+ Referring to 1.4 beta1 [15], another extremely rare circumstance was
discovered under which the Huffman encoder's local buffer can be overrun
when a buffered destination manager is being used and an
extremely-high-frequency block (basically junk image data) is being encoded.
Even though the Huffman local buffer was increased from 128 bytes to 136
bytes
to address the previous issue, the new issue caused even the larger buffer
to
be overrun. Further analysis reveals that, in the absolute worst case
(such as
setting alternating AC coefficients to 32767 and -32768 in the JPEG scanning
order), the Huffman encoder can produce encoded blocks that approach double
the
size of the unencoded blocks. Thus, the Huffman local buffer was increased
to
256 bytes, which should prevent any such issue from re-occurring in the
future.
+ The new tjPlaneSizeYUV(), tjPlaneWidth(), and tjPlaneHeight() functions
were not actually usable on any platform except OS X and Windows, because
those functions were not included in the libturbojpeg mapfile. This has
been
fixed.
+ Restored the JPP(), JMETHOD(), and FAR macros in the libjpeg-turbo header
files. The JPP() and JMETHOD() macros were originally implemented in
libjpeg
as a way of supporting non-ANSI compilers that lacked support for prototype
parameters. libjpeg-turbo has never supported such compilers, but some
software packages still use the macros to define their own prototypes.
Similarly, libjpeg-turbo has never supported MS-DOS and other platforms that
have far symbols, but some software packages still use the FAR macro. A
pretty
good argument can be made that this is a bad practice on the part of the
software in question, but since this affects more than one package, it's
just
easier to fix it here.
+ Fixed issues that were preventing the ARM 64-bit SIMD code from compiling
for iOS, and included an ARMv8 architecture in all of the binaries
installed by
the "official" libjpeg-turbo SDK for OS X.
- Adapt patches to upstream changes
libjpeg-ocloexec.patch > libjpeg-1.4.0-ocloexec.patch
libjpeg-turbo-1.3.0-int32.patch > libjpeg-turbo-1.4.0-int32.patch
- Remove libjpeg-turbo-CVE-2014-9092.patch; fixed on upstream release
- Bump tminor to 1

==== libkcddb4 ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkcddb4-devel

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkcompactdisc4 ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkcompactdisc4-devel

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkdcraw-devel ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkdcraw23

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkdeedu4-devel ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkeduvocdocument4

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== kdegames4-carddecks-default ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkdegames libkdegames-devel libkdegames6

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkexiv2-11 ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkexiv2-devel

- BuildRequire at least libexiv2-devel >= 0.24
- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkipi-devel ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkipi11

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkmahjongg ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libkmahjongg-devel libkmahjongglib4

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libkomparediff2-4 ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libksane-devel ====
Version update (4.14.3 -> 14.12.0)
Subpackages: libksane0

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php
- Drop patch kde4_includes.patch due to upstream inclusion

==== libndp0 ====
Version update (1.3 -> 1.4)

- Update to version 1.4:
+ libndp: fix buffer overflow in ndp_msg_opt_dnssl_domain().

==== libpng16-16 ====
Version update (1.6.15 -> 1.6.16)
Subpackages: libpng16-16-32bit libpng16-devel

- updated to 1.6.16:
* Restored a test on width that was removed from png.c at libpng-1.6.9
(Bug report by Alex Eubanks).
* Fixed an overflow in png_combine_row with very wide interlaced images.

==== libQt5Core5 ====
Subpackages: libQt5DBus5 libQt5Gui5 libQt5Network5 libQt5OpenGL5
libQt5PrintSupport5 libQt5Sql5 libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk2

- Added Fix-use-after-free-bug.patch from upstream
(qtbug#43623, boo#870151)

==== libreoffice ====
Version update (4.3.5.2 -> 4.4.0.1)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql libreoffice-calc
libreoffice-calc-extensions libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions

- That verbose switch for configure was really really bad idea
- generic images.zip for galaxy icons seem gone so remove
- Do not supplement kde3 stuff, it is way beyond obsolete
- Remove vlc conditional
- korea.xcd is no more so remove
- Really use mergelib
- Disable telepathy, it really is experimental like hell
- Version bump to 4.4.0rc1:
* New 4.4 branch release with additional features
- Enable collada:
* New bundled collada2gltf tarball:
4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.bz2
- Obsoleted patches:
* jvmfwk-disable-gcj.diff
* libreoffice-4.3-plasma5-ui-decisions.patch
* libreoffice-4.3.0.3-themes-symlinks.patch
* office-cfg-linux-common-template-dir.diff
* libreoffice-boost-1.56.patch
- Refreshed patches:
* officecfg-help-in-usr-share.diff
* system-pyuno.diff

==== libsndfile-devel ====
Subpackages: libsndfile1 libsndfile1-32bit

- VUL-0: two buffer read overflows in sd2_parse_rsrc_fork()
(CVE-2014-9496, bnc#911796): backported upstream fix patches
sndfile-src-sd2.c-Fix-segfault-in-SD2-RSRC-parser.patch
sndfile-src-sd2.c-Fix-two-potential-buffer-read-overflows.patch

==== libvisio-0_1-1 ====
Version update (0.1.0 -> 0.1.1)

- Version bump 0.1.1:
* Various bugfixes around
- Remove obsol patch:
* libvisio-0.1.0-pkgconfig.patch
- Enable testsuite

==== libxshmfence-devel ====
Version update (1.1 -> 1.2)
Subpackages: libxshmfence1 libxshmfence1-32bit

- specfile: added baselibs.conf as source (new checkin policy)
- Update to version 1.2:
+ build fixes
+ FreeBSD umtx support
+ memfd_create support for kernel >= 3.17

==== lokalize ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== lskat ====
Version update (4.14.3 -> 14.12.0)

- Require kdegames4-carddecks-default, lskat doesn't really work
without a carddeck
- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== device-mapper ====
Subpackages: device-mapper-32bit lvm2

- Add lvm2-do-not-strip-pdata_tools.patch: Change build system to
not strip pdata_tools during installation. We need the file in
tact in order to be able to produce valid debuginfo packages
(boo#910327).

==== libastro1 ====
Version update (4.14.3 -> 14.12.0)
Subpackages: marble marble-data marble-devel marble-doc

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libmjpegutils-2_0-0 ====
Subpackages: mjpegtools

- BuildRequire at least libpng 1.14 due to usage of
PNG_TRANSFORM_GRAY_TO_RGB

==== mobipocket ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== libmpfr4 ====
Subpackages: mpfr-devel

- Add mpfr-3.1.2-patch11.diff to fix possible buffer overflow in
mpfr_strtofr (CVE-2014-9474). [bnc#911812]

==== mupdf ====
Version update (1.5 -> 1.6)

- update to version 1.6
* Features:
+ Color detection device (mudraw -T).
+ Sepia mode full-page color tinting in X11 and win32 viewer
(keybinding: shift-C).
+ Re-implement printf and strtod due to portability issue with
locales and number formatting.
+ Add experimental 'gsview' project: a Windows Modern UI viewer.
+ Improve XML parser interface.
* Bug fixes:
+ CBZ page ordering
+ ZIP64 support
+ iOS and Android bug fixes
+ Miscellaneous minor fixes

==== ntp ====
Subpackages: ntp-doc

- Enable avahi support

==== obconf ====

- added obconf-2.0.4-Spanish-translation-update.patch

==== okular ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== osc ====
Version update (0.149.0 -> 0.150.1)

- 0.150.1
- minor syntax fix
- 0.150.0
- support local builds using builenv (for same build environment as a former
build)
- add "osc api --edit" option to be able to edit some meta files directly
- follow the request order of the api (sorting according to priorization)
- add mr --release-project option for kgraft updates
- add support for makeoriginolder in request

==== oxygen-icon-theme ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== apache2-mod_php5 ====
Subpackages: php5 php5-bcmath php5-bz2 php5-calendar php5-ctype php5-curl
php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear php5-pgsql
php5-shmop php5-snmp php5-sockets php5-sqlite php5-suhosin php5-sysvsem
php5-sysvshm php5-tidy php5-tokenizer php5-wddx php5-xmlreader php5-xmlwriter
php5-xsl php5-zip php5-zlib

- added php-CVE-2014-9426.patch [bnc#911663]
- added php-CVE-2014-9427.patch [bnc#911664]

==== plasma-addons ====
Subpackages: plasma-addons-akonadi plasma-addons-kimpanel
plasma-addons-lancelot plasma-addons-marble

- Ensure that plasma-addons-marble works with KDE Applications 14.12

==== libpoppler-cpp0 ====
Version update (0.29.0 -> 0.30.0)
Subpackages: libpoppler-devel libpoppler-glib8 poppler-tools

- Update to version 0.30.0:
+ core:
- Openjpeg2 support (openjpeg 1 is preferred) (fdo#58906).
- Fix potential memory corruption on TextSelectionDumper
(fdo#84555).
- Check for invalid matrix in annotation (fdo#84990).
- Open some not conforming files (fdo#85919).
- PSOutputDev: Accept a list of pages indeces instead of first,
last (fdo#84833).
- Fix memory leak on error condition.
+ cpp: New API to set debug output function.
+ build system: configure: Improve support with older clang
versions (fdo#76963).
+ utils: pdfunite: Support output intents, optional content and
acroform.
- Bump poppler soname following upstream changes.

==== libpoppler-qt4-4 ====
Version update (0.29.0 -> 0.30.0)
Subpackages: libpoppler-qt4-devel

- Update to version 0.30.0:
+ core:
- Openjpeg2 support (openjpeg 1 is preferred) (fdo#58906).
- Fix potential memory corruption on TextSelectionDumper
(fdo#84555).
- Check for invalid matrix in annotation (fdo#84990).
- Open some not conforming files (fdo#85919).
- PSOutputDev: Accept a list of pages indeces instead of first,
last (fdo#84833).
- Fix memory leak on error condition.
+ cpp: New API to set debug output function.
+ build system: configure: Improve support with older clang
versions (fdo#76963).
+ utils: pdfunite: Support output intents, optional content and
acroform.
- Bump poppler soname following upstream changes.

==== kde4-l10n-devel ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== python-Pillow ====
Version update (2.6.1 -> 2.7.0)

- update to version 2.7.0:
- Look for OSX and Linux fonts in common places. #1054
- Fix potential PNG decompression DOS #1060
- Use underscores, not spaces, in TIFF tag kwargs. #1044, #1058
- Update PSDraw for Python3, add tests. #1055
- Use Bicubic filtering by default for thumbnails. Don't use Jpeg Draft mode
for thumbnails. #1029
- Fix MSVC compiler error: Use Py_ssize_t instead of ssize_t #1051
- Fix compiler error: MSVC needs varaibles defined at the start of the block
#1048
- The GIF Palette optimization algorithm is only applicable to mode='P' or
'L' #993
- Use PySide as an alernative to PyQt4/5.
- Replace affine-based im.resize implementation with convolution-based
im.stretch #997
- Replace Gaussian Blur implementation with iterated fast box blur. #961
Note: Radius parameter is interpreted differently than before.
- Better docs explaining import _imaging failure #1016, build #1017, mode
#1018, PyAccess, PixelAccess objects #1019 Image.quantize #1020 and Image.save
#1021
- Fix for saving TIFF image into an io.BytesIO buffer #1011
- Fix antialias compilation on debug versions of Python #1010
- Fix for Image.putdata segfault #1009
- Ico save, additional tests #1007
- Use PyQt4 if it has already been imported, otherwise prefer PyQt5. #1003
- Speedup resample implementation up to 2.5 times. #977
- Speed up rotation by using cache aware loops, added transpose to rotations.
#994
- Fix Bicubic interpolation #970
- Support for 4-bit greyscale TIFF images #980
- Updated manifest #957
- Fix PyPy 2.4 regression #952
- Webp Metadata Skip Test comments #954
- Fixes for things rpmlint complains about #942
- update to version 2.6.2:
- Fix potential PNG decompression DOS #1060
- Fix Regression in PyPy 2.4 in streamio #958

==== python-ldap ====
Version update (2.4.18 -> 2.4.19)

- Update to upstream release 2.4.19

==== python-pytz ====
Version update (2014.9 -> 2014.10)

- update to 2014.10:
+ Database update to 2014j

==== libpython3_4m1_0 ====
Subpackages: python3-base

- asyncio has been merged in python3 main package; provide and
obsolete it
- Remove obsolete AUTHORS section
- Remove redundant %clean section

==== python3-pip ====
Version update (1.5.6 -> 6.0.6)

- specfile: update copyright year
- Adapt pip-shipped-requests-cabundle.patch to upstream changes
> pip-6.0.6-shipped-requests-cabundle.patch
- Do not ship bundled cacert
- update to version 6.0.6:
* Continue the regression fix from 6.0.5 which was not a complete
fix.
- changes from version 6.0.5:
* Fix a regression with 6.0.4 under Windows where most commands
would raise an exception due to Windows not having the
os.geteuid() function.
- changes from version 6.0.4:
* Fix an issue where ANSI escape codes would be used on Windows even
though the Windows shell does not support them, causing odd
characters to appear with the progress bar.
* Fix an issue where using -v would cause an exception saying
TypeError: not all arguments converted during string formatting.
* Fix an issue where using -v with dependency links would cause an
exception saying TypeError: 'InstallationCandidate' object is not
iterable.
* Fix an issue where upgrading distribute would cause an exception
saying TypeError: expected string or buffer.
* Show a warning and disable the use of the cache directory when the
cache directory is not owned by the current use, commonly caused
by using sudo without the -H flag.
* Update PEP 440 support to handle the latest changes to PEP 440,
particularly the changes to >V and <V so that they no longer imply
!=V.*.
* Document the default cache directories for each operating system.
* Create the cache directory when the pip version check needs to
save to it instead of silently logging an error.
* Fix a regression where the -q flag would not properly suppress the
display of the progress bars.
- changes from version 6.0.3:
* Fix an issue where the implicit version check new in pip 6.0 could
cause pip to block for up to 75 seconds if PyPI was not
accessible.
* Make --no-index imply --disable-pip-version-check.
- changes from version 6.0.2:
* Fix an issue where the output saying that a package was installed
would report the old version instead of the new version during an
upgrade.
* Fix left over merge conflict markers in the documentation.
* Document the backwards incompatible PEP 440 change in the 6.0.0
changelog.
- changes from version 6.0.1:
* Fix executable file permissions for Wheel files when using the
distutils scripts option.
* Fix a confusing error message when an exceptions was raised at
certain points in pip?s execution.
* Fix the missing list of versions when a version cannot be found
that matches the specifiers.
* Add a warning about the possibly problematic use of > when the
given specifier doesn?t match anything.
* Fix an issue where installing from a directory would not copy over
certain directories which were being excluded, however some build
systems rely on them.
- changes from version 6.0:
* PROCESS Version numbers are now simply X.Y where the leading 1 has
been dropped.
* BACKWARD INCOMPATIBLE Dropped support for Python 3.1.
* BACKWARD INCOMPATIBLE Removed the bundle support which was
deprecated in 1.4. (PR #1806)
* BACKWARD INCOMPATIBLE File lists generated by pip show -f are now
rooted at the location reported by show, rather than one
(unstated) directory lower. (PR #1933)
* BACKWARD INCOMPATIBLE The ability to install files over the FTP
protocol was accidently lost in pip 1.5 and it has now been
decided to not restore that ability.
* BACKWARD INCOMPATIBLE PEP 440 is now fully implemented, this means
that in some cases versions will sort differently or version
specifiers will be interpreted differently than previou sly. The
common cases should all function similarly to before.
* DEPRECATION pip install --download-cache and pip wheel
- -download-cache command line flags have been deprecated and the
functionality removed. Since pip now automatically configures and
uses it?s internal HTTP cache which supplants the --download-cache
the existing options have been made non functional but will still be
accepted until their removal in pip v8.0. Fo r more information
please see
https://pip.pypa.io/en/latest/reference/pip_install.html#caching
* DEPRECATION pip install --build and pip install --no-clean are now
NOT deprecated. This reverses the deprecation that occurred in
v1.5.3. See #906 for discussion.
* DEPRECATION Implicitly accessing URLs which point to an origin
which is not a secure origin, instead requiring an opt-in for each
host using the new --trusted-host flag (pip install -
- trusted-host example.com foo).
* Allow the new --trusted-host flag to also disable TLS verification
for a particular hostname.
* Added a --user flag to pip freeze and pip list to check the user
site directory only.
* Fixed #1873. Silence byte compile errors when installation
succeed.
* Added a virtualenv-specific configuration file. (PR #1364)
* Added site-wide configuation files. (PR #1978)
* Added an automatic check to warn if there is an updated version of
pip available (PR #2049).
* wsgiref and argparse (for >py26) are now excluded from pip list
and pip freeze (PR #1606, PR #1369)
* Fixed #1424. Add --client-cert option for SSL client certificates.
* Fixed #1484. pip show ?files was broken for wheel installs. (PR
[#1635])
* Fixed #1641. install_lib should take precedence when reading
distutils config. (PR #1642)
* Send Accept-Encoding: identity when downloading files in an
attempt to convince some servers who double compress the
downloaded file to stop doing so. (PR #1688)
* Fixed #1559. Stop breaking when given pip commands in uppercase
(PR #1725)
* Fixed #1618. Pip no longer adds duplicate logging consumers, so it
won?t create duplicate output when being called multiple
times. (PR #1723)
* Fixed #1769. pip wheel now returns an error code if any wheels
fail to build.
* Fixed #1775. pip wheel wasn?t building wheels for dependencies of
editable requirements.
* Allow the use of --no-use-wheel within a requirements file. (PR
[#1859])
* Fixed #1680. Attempt to locate system TLS certificates to use
instead of the included CA Bundle if possible. (PR #1866)
* Fixed #1319. Allow use of Zip64 extension in Wheels and other zip
files. (PR #1868)
* Fixed #1101. Properly handle an index or ?find-links target which
has a <base> without a href attribute. (PR #1869)
* Fixed #1885. Properly handle extras when a project is installed
via Wheel. (PR #1896)
* Fixed #1180. Added support to respect proxies in pip search. It
also fixes #932 and #1104. (PR #1902)
* Fixed #798 and #1060. pip install ?download works with vcs
links. (PR #1926)
* Fixed #1456. Disabled warning about insecure index host when using
localhost. Based off of Guy Rozendorn?s work in PR #1718. (PR
[#1967])
* Allow the use of OS standard user configuration files instead of
ones simply based around $HOME. (PR #2021)
* Fixed #1825. When installing directly from wheel paths or urls,
previous versions were not uninstalled. This also fixes #804
specifically for the case of wheel archives. (PR #1838)
* Fixed #2075, detect the location of the .egg-info directory by
looking for any file located inside of it instead of relying on
the record file listing a directory. (PR #2076)
* Fixed #1964, #1935, #676, Use a randomized and secure default
build directory when possible. (PR #2122, CVE-2014-8991)
* Fixed #1433. Support environment markers in requirements.txt
files. (pull:2134)
* Automatically retry failed HTTP requests by default. (PR #1444,
pull:2147)
* Fixed #1100 - Handle HTML Encoding better using a method that is
more similar to how browsers handle it. (PR #1874)
* Reduce the verbosity of the pip command by default. (PR #2175, PR
[#2177], PR #2178)
* Fixed #2031 - Respect sys.executable on OSX when installing from
Wheels.
* Display the entire URL of the file that is being downloaded when
downloading from a non PyPI repository (PR #2183).
* Support setuptools style environment markers in a source
distribution (PR #2153).

==== python3-setuptools ====
Version update (11.0 -> 11.3.1)

- update to version 11.3.1:
* Issue #327: Formalize and restore support for any printable character in an
entry point name.
- changes from version 11.3:
* Expose "EntryPoint.resolve" in place of EntryPoint._load, implementing the
simple, non-requiring load. Deprecated all uses of "EntryPoint._load"
except for calling with no parameters, which is just a shortcut for
"ep.require(); ep.resolve();".
Apps currently invoking "ep.load(require=False)" should instead do the
following if wanting to avoid the deprecating warning::
getattr(ep, "resolve", lambda: ep.load(require=False))()
- changes from version 11.2:
* Pip #2326: Report deprecation warning at stacklevel 2 for easier diagnosis.
- changes from version 11.1:
* Issue #281: Since Setuptools 6.1 (Issue #268), a ValueError would be
raised in certain cases where VersionConflict was raised with two
arguments, which occurred in "pkg_resources.WorkingSet.find". This
release adds support for indicating the dependent packages while
maintaining support for a VersionConflict when no dependent package
context is known. New unit tests now capture the expected interface.

==== release-notes-openSUSE ====
Version update (13.2.20141103 -> 13.2.20150107)

- Expand entities (bnc#907112).

==== sed ====

- build with PIE

==== perl-Mail-SpamAssassin ====
Subpackages: spamassassin

- Fix for boo#911355
- Don't install init files when service files are installed
- Create symlinks for rcspamd and rcspampd when systemd is used
- Remove unnecessary cleanup section from spec files

==== squid ====
Version update (3.4.4 -> 3.4.10)

- Cleanup with spec-cleaner
- Version bump to 3.4.10:
* Fix bootstrap.sh dependency on SPONSORS.list
* HTTP/2: Support 421 (Misdirected Request) status code
* Alternate-Protocol is a hop-by-hop header
* Bug #4148: external_acl_type header format does not accept the new
libformat syntax
* Bug #4033: Rebuild corrupted ssl_db/size file
* Bug #3902: Docs: external_acl_type cache hash key
* Bug #4145: squid_endian.h compile errors with OpenBSD 5.6
* Fix segmentation fault in ACLUrlPathStrategy::match
- Remove support for other distros as we build for opensuse anyway
- remove permissions.easy and permissions.paranoid files from package
as they are not used any more
- remove setBadness in rpmlintrc as it should be already in Factory
permissions package handled
- %verifyscript is its own section, move out of the %postun section
- Use URLs to paths that the source validator actually understands
and make this acceptable for Tumbleweed.
- fix for boo#894636 (squid's logrotate snippet runs init script)
* modify squid.logrotate to work on both systemd and SysVinit
- Changes to 3.4.9 (31 Oct 2014):
+ Regression fix: ext_kerberos_ldap_group_acl typo in 3.4.7 update
+ Bug 4102: sslbump cert contains only a dot character in key usage extension
+ Bug 4093: source-maintenance.sh errors and warnings due to wrong
tools/options
+ Bug 4088: memory leak in external_acl_type helper with cache=0 or ttl=0
+ Bug 4024: Bad host/IP ::1 when using IPv4-only environment
+ Bug 3803: ident leaks memory on failure
+ kerberos_ldap_group/cert_tool: Remove ksh dependency;
obsoletes squid-cert_tool_use_bash_not_ksh.patch
+ ... and some automated code style updates
+ ... and some documentation updates
- Changes to 3.4.8 (15 Sep 2014):
+ Fix off by one in SNMP subsystem
+ pinger: Fix various ICMP handling issues; CVE-2014-7141; CVE-2014-7142;
http://www.squid-cache.org/Advisories/SQUID-2014_4.txt; bnc#891268
obsoletes squid-icmp-DoS.patch
- Remove dependency on gpg-offline as signature checking is implemented in the
source validator.
- fix spec and changes file
- update logrotate file
* postrotate now defaults to 'systemd'
- fix for icmp pinger DOS bnc#891268
- some spec cleanup
- some systemd/SysVinit fixes
- fix sysconfig file for ! suse_version
- replaced permissions handling using setuid bit with use of
linux capabilities (on supported systems)
- general cleanup of .spec file and systemd handling
- Changes to 3.4.7 (28 Aug 2014):
* Regression Fix: Kerberos LDAP authorizing groups with principle subdomain
* Bug 4080: worker hangs when client identd is not responding
* Bug 3966: Add KeyEncipherment when ssl-bump substitues RSA for EC
* HTTP/1.1: Ignore Range headers with unidentifiable byte-range values
* SSL-bump: Use v3 for fake certificate if we add _any_ certificate extension
* Enable compile-time override for MAXTCPLISTENPORTS
* ntlm_sspi_auth: Fix various build errors
* negotiate_wrapper: Fix build issues with non-portable vfork()
* negotiate_sspi_auth: Portability fixes for MinGW
* ext_lm_group_acl: Portability fixes for MinGW
* ... and several minor memory leaks
- fix for bnc#894636
* fix postrotate for systemd
- rebase patches
* squid-cert_tool_use_bash_not_ksh.patch
* squid-compiled_without_RPM_OPT_FLAGS.patch
* squid-nobuilddates.patch
* squid-config.patch
- fix for bnc#894840
* fix logrotate file (sharedscripts)
- add --disable-arch-native configure param as vmware does not
emulate all instruction set and squid fails with
"Illegal instruction" more info at
http://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
- squid-cert_tool_use_bash_not_ksh.patch:
/usr/sbin/cert_tool should use bash, not ksh. [bnc#891313]
- Changes to squid-3.4.6 (25 Jun 2014):
* Regression: segmentation fault logging with %tg format specifier
* Bug 4065: round-robin neighbor selection with unequal weights
* Bug 4056: assertion MemPools[type] from netdbExchangeStart()
* Bug 4050: segmentation fault in CommSelectEngine::checkEvents on helper
response
* Fix segmentation fault setting up server SSL connnection
* Fix hanging Non-HTTPS connections on SSL-bump enabled port
* Fix Cache Manager actions listed more than once
* ... and many minor memory leaks
* ... and several portability build issues
* ... and some documentation updates
- Changes to squid-3.4.5 (02 May 2014):
* Regression Bug 4051: inverted test on CONNECT payload existence
* Regression Fix: order dependency between cache_dir and maximum_object_size
* Fix logformat %note display
* Resolve 'dying from an unhandled exception: c'
* Copyright: Update CONTRIBUTORS list of copyright holders
- fix deps
* libtool >= 2.4
* older libtool needs --with-included-ltd
- Rename rpmlintrc to %{name}-rpmlintrc.
Follow the packaging guidelines.
- fix rhel/centos usermod parameter invocation order
- setuid handling for opensuse using permissions updated
- enable build for centos/rhel
- add centos/rhel init script
- add 'squid' as default group and added suid bit for /usr/sbin/pinger
[#] pinger needs 'root' privileges to be able to ping (cache peer)
* attr(4750,root,squid) /usr/sbin/pinger

==== libnfsidmap-sss ====
Version update (1.12.2 -> 1.12.3)
Subpackages: libsss_idmap0 libsss_nss_idmap0 libsss_sudo sssd sssd-32bit
sssd-krb5-common sssd-ldap

- Update to new upstream release 1.12.3
* SSSD now allows the IPA client to move from one ID view to
another after SSSD restart.
* It is possible to apply ID views to IPA domains as well.
Previous SSSD versions only allowed views to be applied to AD
trusted domains.
* Overriding SSH public keys is supported in this release.
* Move semanage related functions to a separate library.
- build with PIE

==== step ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== subversion ====
Subpackages: subversion-devel subversion-perl subversion-python
subversion-server subversion-tools

- fix sysconfig file generation (bnc#911620)

==== sweeper ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== tigervnc ====
Version update (1.3.1 -> 1.4.1)
Subpackages: xorg-x11-Xvnc

- Update to tigervnc 1.4.1 on xorg-server 1.16.1.
- Drop upstreamed or obsolete patches:
tigervnc-sf3492352.diff
u_aarch64-support.patch
u_tigervnc-check-shm-harder.patch
u_arch-Fix-image-and-bitmap-byte-order-for-ppc64le.patch
u_tigervnc-1.3.0-fix-use-after-free.patch
tigervnc-1.2.80-fix-int-to-pointer.patch

==== umbrello ====
Version update (4.14.3 -> 14.12.0)

- Update to KDE Applications 14.12.0
* KDE Applications 14.12.0
* See https://www.kde.org/announcements/announce-applications-14.12.0.php

==== virt-viewer ====
Version update (1.0 -> 2.0)

- Update to virt-viewer version 2.0
virt-viewer-2.0.tar.bz2
- Fix handling of zoom in/out accelerators
- Fix warning going in/out of fullscreen
- Add dialog showing info about the current guest
- Change format of fullscreen config setting to
allow for sparse guest displays
- Write VM name to config file as a comment
- Never use fallback CA certs when loading vv-file
- Remove extraneous '/' from oVirt URIs
- Support oVirt foreign menus
- Allow using numapad for zoom in/out accelerators
- Force geometry update when agent connects
- Fix misc crash bugs
- Fix misc memory leaks
- Allow viewing of password entry characters
- Don't fail when auth dialog is cancelled
- Only create extra windows on demand
- Use more sensible default window size
- Improve docs for URIs and config files
- Allow cancellation of SPICE auth dialog
- Use new libvirt API for --attach to avoid SELinux AVC
- Allow removable of CD images with oVirt connections
- Show VM choose dialog when oVirt VM name is missing
- Support usernames request with SASL auth
- Use socat instead of nc if available
- Use PNG instead of SVG for icons
- Support connection to UNIX sockets instead of TCP
- Honour zoom level from CLI args with VNC
- Switch to GTK3 instead of GKT2 for Windows builds
- Ensure dialogs have transient parent set
- Switch to gstreamer 1.0 instead of 0.10 for Windows builds
- Avoid accidentally connecting to localhost with VNC/SPICE
- Use a versioned install directory for Windows builds
- Dropped sources
virt-viewer-1.0.tar.bz2
report-error.patch

==== vsftpd ====

- Try to fix deny_file parsing to do more what is expected. Taken
from fedora. bnc#900326
* vsftpd-2.1.0-filter.patch

==== wine ====
Version update (1.7.33 -> 1.7.34)
Subpackages: wine-32bit

- Updated to 1.7.34 development snapshot
- Support for surround sound in DirectSound.
- Better text run support in DirectWrite.
- Many HTML engine fixes.
- More support for WBEM objects.
- A few more C/C++ runtime functions.
- Various bug fixes.

==== wireshark ====
Version update (1.12.2 -> 1.12.3)
Subpackages: wireshark-ui-gtk

- Wireshark 1.12.3
- The following vulnerabilities allowed Wireshark to be crashed by
injecting a malformed packet onto the wire or by convincing someone
to read a malformed packet trace file.
+ The WCCP dissector could crash
wnpa-sec-2015-01 CVE-2015-0559 CVE-2015-0560 [boo#912365]
+ The LPP dissector could crash.
wnpa-sec-2015-02 CVE-2015-0561 [boo#912368]
+ The DEC DNA Routing Protocol dissector could crash.
wnpa-sec-2015-03 CVE-2015-0562 [boo#912369]
+ The SMTP dissector could crash.
wnpa-sec-2015-04 CVE-2015-0563 [boo#912370]
+ Wireshark could crash while decypting TLS/SSL sessions.
wnpa-sec-2015-05 CVE-2015-0564 [boo#912372]
- Further bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-1.12.3.html

==== wwwoffle ====

- fix bashisms in contrib/kppp scripts: 'read' command without
arguments may be unsupported in other POSIX-complete shells
- add patches:
* wwwoffle-2.9i-fix-bashisms.patch

==== xproto-devel ====
Version update (7.0.26 -> 7.0.27)

- Update to version 7.0.27:
This release improves support for compiler attributes for the
clang and Solaris Studio 12.4 compilers, and makes builds on AIX
choose the right headers to include.

==== yast2-bootloader ====
Version update (3.1.113 -> 3.1.114)

- Do not crash with unsupported bootloader when resetting
bootloader to repropose during update (bnc#912595)
- 3.1.113

==== yast2-installation ====
Version update (3.1.125 -> 3.1.126)

- do not stuck during copy of logs files (bnc#897091)
- 3.1.126

==== yast2-security ====
Version update (3.1.6 -> 3.1.7)

- fix paths for systemd target links (bnc#911523)
- 3.1.7
- Fixed the interface to show and process correctly values from
sysctl.conf.
- Source code cleanup, including some minor fixes and new tests.

==== libyaz-devel ====
Version update (5.7.1 -> 5.8.1)
Subpackages: yaz

- Update to 5.8.1:
+ record conv: 'select' return org record if no x-path match YAZ-814
+ retrieval: pick matched element-set rule YAZ-813
+ Fix crash in record conv rule 'select' YAZ-812
+ record_conv: selection by X-Path YAZ-811
That's a new step in record conversion system (<select path=".."/>)
+ Document record render parameters for ZOOM - including base64
+ Fix application/x-www-form-urlencoded + empty YAZ-810
A SEGV occurred if Content-Type was "application/x-www-form-urlencoded"
and empty content was supplied.
+ Fix yaz-iconv man page for typos and incorrect example. YAZ-809
+ Fail hard if Bison is not found and is needed YAZ-808
+ Enable YAZ backtrace for programs YAZ-802
+ Fix daemon: parent process stops before child YAZ-806
Try to fix the situation where parent process stops before
child has acknowledged it .. SIGUSR2 back!
+ daemon: log message when keepalive stops.
- rename libpackage to libyaz5 to follow library naming
- small specfile cleanup




Removed packages:
libcmis-0_4-4
libhdf5-8
> libhdf5_hl8
libkdeedu4-data
libQt5Sql5-sqlite
libmarblewidget19
libpoppler48
libyaz4


Added packages:
cd-discid
libcmis-0_5-5
libhdf5-9
> libhdf5_hl9
kdeedu-data
libpagemaker-0_0-0
libQt5Sql5-postgresql
libmarblewidget20
libpoppler49
libyaz5
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages