Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
[opensuse-factory] Re: When was it decided to stop supporting remote desktops?
Jan Engelhardt wrote:
So I just pick another fucking host then,-- it still works and I
get chugging gears.
---
Ooops, sorry, thought you were joking the 1st time. No offense
intended...


12:13 ares08:~ > LIBGL_DEBUG=verbose glxgears
libGL: OpenDriver: trying /usr/lib64/dri/updates/i915_dri.so
libGL error: dlopen /usr/lib64/dri/updates/i915_dri.so failed
(/usr/lib64/dri/updates/i915_dri.so: cannot open shared object file: No such
file or directory)
libGL: OpenDriver: trying /usr/lib64/dri/i915_dri.so
libGL error: failed to open drm device: No such file or directory
libGL error: failed to load driver: i915
libGL: OpenDriver: trying /usr/lib64/dri/updates/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/updates/swrast_dri.so
libGL error: dlopen /usr/lib64/dri/updates/swrast_dri.so failed
(/usr/lib64/dri/updates/swrast_dri.so: cannot open shared object file: No such
file or directory)
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
----

The thing is -- on my server machine, I have those libraries
present in those locations. Yet it claims not to be able to find them.
???

42 frames in 5.0 seconds = 8.368 FPS
41 frames in 5.1 seconds = 8.086 FPS

(and pulls down about 27 Mbit/s over Ethernet)

And your gears turn??

I think my window didn't init correctly (tried it via cygwin ssh), but
with SecureCRT ssh (not sure why that would make a difference, I
get a picture of the gears, but no motion, THOUGH!, I do see my FRAPS
benchmark tool that shows frame rates in the corner of a directX/openGL
window -- and it is showing 30.

So it really is like it is almost working, but ... reading this didn't
give me much hope (wikipedia under Xgl):

On January 2, 2006 most [2], the source to Xgl was re-opened to the public,[3][4] and included in freedesktop.org, along with major restructuring to allow a wider range of supported display drivers. X server backends used by Xgl include Xglx and Xegl. In February 2006 the server gained wide publicity after a public display where the **Novell desktop** team demonstrated a desktop using Xgl with several visual effects such as translucent windows and a rotating 3D desktop.

... yay novell!

Then came AIGLX:
---(under AIGLX):
Accelerated Indirect GLX ("AIGLX") is an open source project founded by Red Hat and the Fedora community, to allow accelerated indirect GLX rendering capabilities to the X.Org Server and DRI drivers. This allows remote X clients to get fully hardware accelerated rendering over the GLX protocol; coincidentally, this development was required for OpenGL compositing window managers to function with hardware acceleration.
...However,....
==Relationship to Xgl==(also under AIGLX article)
Although the AIGLX project has features similar to Xgl, it was not intended to be a competing product. ...[however, despite code sharing between AIGLX] and Xgl, Xgl was removed from the X Server on June 12, 2008.


--Of note was a comment:

Glitz – was superseded by AIGLX
and I still have some glitz config files sitting around that don't
seem very current. But I have a feeling that was the last it worked.

Also of interest -- glx info DOES read what type of video card I hve
and it's GLX options... but then it seems to ignore that and go on to load
swrast...so, not sure what it is doing.

It looked too me like, at the very least, platform interoperability
was now a problem and not one before --

I get the same errors about not beign able to open drivers when I tried
xrdp and xdmcp which other people have not been able to get get to work either.

So it looks like the performance dropped from the previous (though I think
my earlier testing was done on a 1Gb hardwire -- quite a bit different
from a WiFi connection, so that might explain most of the diff.

Yet still no motion on my end... Hmmm...







--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups