Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
[opensuse-factory] Problems with sata_via and ahci driver on Opensuse 13.1 with chipset Via VT 8237
  • From: Juan Erbes <jerbes@xxxxxxxxx>
  • Date: Tue, 4 Mar 2014 01:40:55 -0300
  • Message-id: <CACB8RRat7ZeoZqGP0XQW4oRkW44dY=gW9V9HqcVuOq2v9FmAig@mail.gmail.com>
I had upgraded a computer with opensuse 11.3 to 13.1, which worked
fine in a computer with a Asus A7V600 motherboard and a Athlon XP2600+

At the first time from the beginin of the installation, I hear a noise
coming from the hard disk, like a beat from the HD heads. Once the
instalation was completed, I modified the file /etc/sysconfig/kernel
and added the module sata_via, and created a new initrd and the system
worked better with less beats from the HD heads, but not completely
resolved.

[ 7.376475] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0
[ 7.376483] ata1:00: failed command: READ DMA
[ 7.376489] ata1.00: cmd c8/00:40:20:00:00/00:00:00:00:00/e0 tag 0
dma 32768 in
[ 7.376490] res 51/84:2f:20:00:00/00:00:00:00:00/e0 Emask
0x12 (ATA bus error)
[ 7.376493] ata1.00: status: { DRDY }
(this is nearly the captured images from the computer screens)

I found a driver patch from viaarena and downloaded it:
http://www.viaarena.com/Driver/via_idepatch_linuxdriverpackage_1.7.0.zip

But they are for the kernel 2.26.27.19-5 from 4 years ago, and the
sata_via.c is version is 2.4 againsta version 2.6 from the actual
kernel 3.11.10-7.

The other problem is the system I installed is 32 bits, but on my pc
hay have X86-64.

Later I modified the file /etc/sysconfig/kernel and replaced the
module sata_via with ahci and created a new initrd, and the system
worked worst.

How can I resolve this problem?


--
USA LINUX OPENSUSE QUE ES SOFTWARE LIBRE, NO NECESITAS PIRATEAR NADA Y
NI TE VAS A PREOCUPAR MAS POR LOS VIRUS Y SPYWARES:
http://www.opensuse.org/es/
Puedes visitar mi blog en:
http://jerbes.blogspot.com.ar/
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages