Mailinglist Archive: opensuse-factory (443 mails)

< Previous Next >
Re: [opensuse-factory] wicked wicked
On Thu, Jan 23, Felix Miata wrote:

Yesterday I installed fresh. Result was too much screwed up to make sense of
it all. I tried zypper rm wicked, but couldn't get network to work except by
using yast to delete NIC and add it back at every boot. Network@eth0.service
refused to survive boot, if it ever got created at all. I couldn't find any
wicked instructions anywhere on opensuse.org. Its man page is too terse for
me to get a useful enough amount out of it. So I decided to install all over
again, starting by tabooing wicked.

wicked by itself should work. But whats most likely broken is writing
/etc/sysconfig/network/ifcfg-<interface_name>. What I see with fresh
SLE12 installs is that such files get written, but their name lacks the
"<interface_name>" part. So neither ifup nor wicked will do anything
with such file.

My guess is that the fix for the issue you are seeing is to create the
files manually, like ifcfg-eth0:
BOOTPROTO='dhcp'
STARTMODE='onboot'

But on the other hand, even though yast did not create the proper
ifcfg-* files during fresh install it does write proper files in the
running system.

So what is your installation source, how do you do a fresh install?

Ifup has always worked nicely with single NIC systems on a 100% wired LAN,
no network "management" required. Why does unneeded network "management"
need to be entangled in everything as wicked appears to be?

Appearently some package has Requires: wicked, and this package is in
turn required by other packages?

Olaf
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References