Mailinglist Archive: opensuse-factory (599 mails)

< Previous Next >
Re: [opensuse-factory] [12.3 RC1] nvidia driver 310.32 install fails [SOLVED]

Zitat von C <smaug42@xxxxxxxxxxxx>:

anybody already figured out why nvidia installer fails now in RC1 (installed
from openSUSE-12.3-DVD-Build0024-x86_64.iso)?

In Beta 1 nvidia installer worked with this old workaround:

cd /usr/src/linux
make cloneconfig
make prepare
cd /lib/modules/`uname -r`/source/arch/x86/include/
cp -v generated/asm/unistd*.h ./asm/


Did you try this?

cd /lib/modules/<$KERNEL-VERSION>/build/include/
ln -s generated/uapi/linux/

(replace <$KERNEL_VERSION> with.. your kernel version, eg 3.7.1-1-desktop)

And then run the nvidia installer.

This is all I had to do, even in the Betas.

C.

Thanks! That was it, funnily enough the old workaround did till Beta1 :)

solution:

cd /lib/modules/`uname -r`/build/include/
ln -s generated/uapi/linux

greetings,
0x90

PS: I apologize in advance for any multiple answers. Unstable Internet ... :-(
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References