Mailinglist Archive: opensuse-factory (389 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed 3.3.0-16.1 kernel does not allow install of nvidia driver
On 24/03/12 16:04, Larry Finger wrote:
On 03/23/2012 11:58 PM, Basil Chupin wrote:
On 24/03/12 15:40, Larry Finger wrote:
On 03/23/2012 05:51 AM, Basil Chupin wrote:
On 23/03/12 16:36, Larry Finger wrote:

[pruned]


My system has kernel 3.3 from mainline on it.

The term "mailine" must be local jargon as I don't know what it means.

I could finally get access to it. I downloaded a fresh copy of the patch,
applied it there, and rebuilt the x86_64 driver without any problems. A copy
of that patch is attached.

Larry

To begin, I offer my most sincere apologies for writing that your patch
contained an error (re "x86"). After all the attempts at getting the driver
patched my brain was addled. I now realised that I had altered that parameter
when I was looking for wording which did not match the 32-bit nvidia driver I
needed and seeing "x64_64" changed that to "x86" and without paying attention to
the "i386" just before it (I did say I haven't a damn clue what I am doing).

Anyway, the whole sheebang has beaten me into a pulp and I am giving up on the
whole business of getting a driver for MS #2. (MS #2 is, as far as I am
concerned, the worst disaster in oS history to date.)

The new patch which you provided with your reply worked OK but when I tried to
compile the driver I got the same result at the finish - Could not compile the
driver. I attach the log file for the sake of interest.

Many, many thanks for your help in this matter and I am sorry to have taken up
your time - and wasted your time with my alteration to your patch.

I finally figured it out. In /lib/modules/`uname -r` are two links called
"build" and "source". When you build your own kernel, those links are
identical, but with the openSUSE-installed kernel, the pointers are different.
Before 3.3, it did not matter, but now it does. There is a new patch for
Nvidia drivers 295.20 and 295.33 at http://www.lwfinger.com/nvidia_patches/.

Do not blame openSUSE for this problem - it is the fault of Nvidia for not
updating their driver to handle the differences between kernels 3.2 and 3.3!

Larry

Many thanks, Larry, for the above.

I have finally managed to install the (latest, 295.33) driver using the
information provided by Christian in the factory ML - see my reply to him which
I posted a minute or so ago.

The latest nVidia driver - 295.33 released yesterday - contains the patch which
you have but the darn thing still does NOT install unless you also use the
script file mentioned in that URL given by Christian. So, for the normal user
the nVidia driver is still unusable unless they know how to overcome the problem.

When you say, "When you build your own kernel, those links are identical, but
with the openSUSE-installed kernel, the pointers are different." and not to
blame openSUSE sounds a bit strange because it seems that openSUSE does a fiddle
with the kernel compilation. What happens with other distros using the 3.3
kernel? are they also in the poo re the nVidia driver installation? Just asking
'cause I don't know how these things work.

It is the difference between having built the kernel, and having downloaded the kernel headers. It is not the fault of openSUSE.

Larry

But who creates the kernel headers? And who compiles the kernel itself?

Someone mentioned here a few days ago that nVidia were aware of the problem quite a while back and before 3.3 was actually made available. Considering that nVidia in now gone all luvey-duvey re Linux how could they have totally stuffed up even their latest 295.33 released yesterday? The mind boggles...... :-) .


BC

--
Wife sent me to the doctor to get the pills for me to have an erection.
When I came back I gave her the packet of slimming pills.
I am still looking for somewhere to live.

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups