Mailinglist Archive: opensuse-factory (389 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed 3.3.0-16.1 kernel does not allow install of nvidia driver
On 03/21/2012 10:54 PM, Basil Chupin wrote:

Nope, didn't appear to work. Here is the output from the process:

--- kernel/conftest.sh
+++ kernel/conftest.sh
@@ -95,7 +95,7 @@
fi
fi

- CFLAGS="$CFLAGS $OUTPUT_CFLAGS -I$HEADERS $AUTOCONF_CFLAGS"
+ CFLAGS="$CFLAGS $OUTPUT_CFLAGS -I$HEADERS
-I$SOURCES/arch/x86/include/generated $AUTOCONF_CFLAGS"

test_xen

@@ -126,7 +126,7 @@
CFLAGS="$BASE_CFLAGS $MACH_CFLAGS $OUTPUT_CFLAGS -I$HEADERS $AUTOCONF_CFLAGS"

if [ "$ARCH" = "i386" -o "$ARCH" = "x86" ]; then
- CFLAGS="$CFLAGS -I$SOURCES/arch/x86/include"
+ CFLAGS="$CFLAGS -I$SOURCES/arch/x86/include
-I$SOURCES/arch/x86/include/generated"
elif [ "$ARCH" = "ARMv7" ]; then
CFLAGS="$CFLAGS -I$SOURCES/arch/arm/include"
fi



The other thing, when applying the patch it keeps coming up with something about
Reverse and then asks for response to Assume -R [n] - whatever that means. So I
tried both ways and during one of them the above was created.

In any case, the conftest.sh file did have today's date and time so I ran the
NVIDIA*.run anyway and got the usual failure to compile driver.

Once you have applied the patch, a second attempt will see that the change has been made, and then yield the "Assume -R" message. Use 'man patch' to see what that means.

Rerun the sequence


sh ./NVIDIA-Linux-x86-295.20.run -x
cd NVIDIA-Linux-x86-295.20
patch -p1 < nvidia_295_20_for_3.3_err
./nvidia-installer

When that fails, post the log file /var/log/nvidia-installer.log.

Larry

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups