Mailinglist Archive: opensuse-factory (1564 mails)

< Previous Next >
Re: [opensuse-factory] here an error, there an error, everywhere an error
On 11/10/2011 4:21 PM, David Hall wrote:
On Thu, Nov 10, 2011 at 2:21 PM, Brian K. White<brian@xxxxxxxxx> wrote:
On 11/10/2011 1:41 PM, David Hall wrote:

On Nov 9, 2011, at 12:36 AM, "Brian K. White"<brian@xxxxxxxxx> wrote:

I get all any user needs to get.
If the distribution sucks, it sucks.
You can't tell a user who pops the cd in, tries to use the system, and
encounters all those problems, that it's their fault.

Those branding packages *break some systems*.

I also taboo them because I CAN NOT have grub loading gfxboot and I CAN
NOT have the kernel trying to switch into graphical console modes, and I CAN
NOT have any xdm-alike trying to start up at all. I can not have these
things happen even the very first time so I can't let the installer install
whatever and then go in and adjust config files to disable the problem
actions. I will not be able to go in and do anything at all the instant any
of those things happens the very first time. So I have to prevent them from
even being installed in the first place during initial install, that way
even if I miss one of the several manual things I have to do during
text-only installs, and say, the menu.lst is left with the gfxboot line in
it and uncommented, if it's not installed the line becomes harmless since
the file isn't actually there and the console doesn't get killed and I can
resume the install without having to boot the install media from the network
to use it as a repair pla


When I remove the gfxboot, splashy and bootsplash packages, the branding
packages "require" them, so the branding packages end up going too.

It not our fault for needing to prevent these things, it's the distros
fault for being so thoughtlessly assembled that we have to go through such
contortions just to get installed.

Either that or suse should just stop all pretense of being a suitable OS
for servers.

During install, if you choose minimal server install, it seems to do what
you want. Or you can choose minimal X and then uncheck gfxboot, splashy,
and bootsplash.

I find opensuse to work perfectly for my servers, especially with the ease
of pulling in OBS packages that I build specially for my needs.


I install rather a lot of systems, remotely, text-only serial console and
ssh. I know what it does and doesn't do. Unless something changed very
recently in 12.1 because I haven't touched that yet, when you select the
minimal text-only system, it still installs gfxboot, and the kernel is
configured to switch to a graphical console mode. I have to fight the
installer to prevent it from installing gfxboot, and I have to go around
behind yasts's back and edit menu.lst manually, in another ssh session,
after yast has finished writing the bootloader, but before allowing yast to
exit, because when it exits the installer immediately reboots the system.
Or, I have to pxe-boot the system to the installer again, don't run yast
this time, use the shell to manually assemble the mdraid array and mount it,
or mount the usb thumb drive whatever that box is booting from, manually
edit menu.lst, umount and reboot and allow it to boot from the local disks
and resume the install 2nd stage.

There are multiple dialogs in the bootloader screens in yast that look like
they offer a way to do this all from within the installer nicely. There is
an input line for the message file which contains the gfxboot file. Ok yay
just clear that out, simple. Wrong. Yast just puts it back in there no
matter what.

Maybe there is something that acts differently in remote installation,
but I just downloaded the opensuse 12.1 RC2 (Build 25) DVD, ran it in
virtualbox, chose "Minimal Server Selection (Text Mode)", and it did
not install gfxboot, bootsplash, or splashy. If you find something
different happens when installing remotely, then it should be

Then it would seem complaining about it finally yielded a result! :)
It's only been a problem since ?? ever? 10.0 at least at a guess. I recently looked back as far as 9.1 to check every version to see when the text-only system option appeared, and which versions said "minimal" and or "server" in the wording of either the name or the description of the option. I only had media as far back as 9.1 and it was there in some form in every version from then to now, but I didn't actually install them and don't know how far back this gfxboot and bootsplash and graphical console behavior goes. I wasn't doing remote serial console installs until 10.3 or so.

This is really just one item though.

Next item, kernel by default tries to switch video modes for the console. Sometimes this actually crashes boxes. I had to discover for myself, somehow, by clairevoience or magic, the reason the box was crashing was not because there was anything wrong with the box, it was because the kernel was by default trying to use a buggy video driver. I had to discover the kernel command line option i915something-or-other=disable or i915.modeset=false or some such. I don't remember if the simpler "nomodeset" worked or not on that one.

It's fine to try to provide a nice gui, or at least high resolution text, experience and all that. Surely for most it is better to have a system that looks modern.

So, I don't necessarily expect these things to be all turned off by default since really that only serves a minority. I completely agree with that.

I do want a better install option to do it though, and I do want those text-mode options that are offered to be tested and to work. I also want the minimal install to be a lot more minimal.

For further examples of this:

When logging in on a serial console, something in bashrc keeps setting the LINES and COLUMNS to 80x24. It overrides them at every new command prompt even if I manually set them to whatever my terminal really has. It manages to screw up some apps, even if I manually set them and export them and readonly them. Some parent of the actual interactive shell still has them set and I can only change the final interactive shell and it's children.

This is annoying but not necessarily so bad until the next thing:

Some buttons & tabs in Yast do not appear anywhere on the screen unless the lines & columns are at least 80x25. It makes some screens non-functional.

This stilllll wouldn't be sooooo bad if it weren't for the fact that some of these screens are in the network setup, so you may not have the option of ssh-ing in to use a network terminal instead. Roadblock! (hm, you know it just occurred to me I never tried "ssh localhost" to see if that would work)

Usually I myself don't get all the way roadblocked like that because I usually use a machine for which the installer has a working nic driver and so installing via ssh works and the ssh session has no such problem.

But when I see that it just tells me that this stuff is not actually tested. Except by me. Which isn't enough.

It also implies it isn't even wanted, except by me, which isn't enough.

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >