Mailinglist Archive: opensuse-factory (1564 mails)

< Previous Next >
Re: [opensuse-factory] suspend/resume regressions
  • From: Hendrik Woltersdorf <hendrikw@xxxxxxxx>
  • Date: Sun, 06 Nov 2011 15:32:19 +0100
  • Message-id: <>
Am 06.11.2011 09:50, schrieb St. Quandt:

with each milestone of 12.1 i'm seeing increasing no. of regressions with
suspend/resume (both hibernate and to RAM) with my arrandale notebook (i915
integrated graphics).

1) The most recent (since RC2) is that the backlight of my notebook
reproducable stays switched off after resuming from suspend to RAM.

I can switch it on by quickly closing and opening the laptop lid.
But closing the lid triggers another suspend (which is not nullified by
reopening the lid).

2) Then i wanted to edit powermanagement systemsettings to prevent suspend on
closing the lid.
Interestingly beside the three usual "power profiles" I found 16 new ones with
names like "DirWatch", "Directories", "KDE URL Restrictions", "WM".

3) A bit older problem (may be RC1) are random suspend to RAM happening
spontaneous and multiple times without apparent reason.
Sometimes this is preceded with popup window requesting the root pasword for
the suspend action.
As soon as I cancel it, the computer suspends nevertheless.

4) With hibernate I see different phenomens with failing or incomplete resume,
frequently with kernel oops.
The most prominent (w/o oops) is that after resume the screen remains showing
the black text console in conjunction with an X cursor!
If i move the curser it changes its form over (invisible) application windows
or window frames.
In this situation I found no way to get kwin properly rendering windows by
switching around with Ctrl-Fx.

Anyone else seeing regressions like this?
Any hints for investigating or troubleshooting on issues like this?


Hi, the power-management worked for me (Laptop Fujitsu-Siemens H230 Celsius) until RC1; beside some graphical problems caused by the kernel. In RC2 I saw that the laptop did not go to suspend, when I closed the lid. When I checked your point 2) I saw the new profiles too, that I could not change. Than I clicked at the "restore standard profiles"-button (so I translate the german description). After that I had the known standard profile and closing the lid worked as before.


To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >