Mailinglist Archive: opensuse-factory (1564 mails)

< Previous Next >
Re: [opensuse-factory] proper way to link packages in openSUSE:Tumbleweed
On 10/17/2011 07:30 PM, Greg KH wrote:
Hi Adrian,

We talked at brainshare about the "correct" way to link packages in
Tumbleweed, and unfortunatly, I forgot one of the steps as I can't get
it to work now.

Here's what I remember:

- look up the xsrcmd5 from the "root" package. For example, in the
X11:xfce midori package I would do something like:
osc api /source/X11:xfce/midori | grep linkinfo | pick out xsrcmd5

(where 'pick out' is a regex)

- then run 'osc setlinkrev' with that md5 in the Tumbleweed repo.

It's that last step that I can't seem to get correct, what is the exact
command for it? I tried something like:

$ osc setlinkrev -r bc383278250a5673d3799c2b31c9e6ef openSUSE:Tumbleweed
filesystem
setting revision to bc383278250a5673d3799c2b31c9e6ef for package filesystem
Server returned an error: HTTP Error 400: Base
System/filesystem/bc383278250a5673d3799c2b31c9e6ef not in repository. Either
not existing or misconfigured server setting for '$nosharedtrees' setting in
BSConfig.pm
Base:System/filesystem/bc383278250a5673d3799c2b31c9e6ef: not in repository.
Either not existing or misconfigured server setting for '$nosharedtrees'
setting in BSConfig.pm

Any hints would be appreciated.

Hi, I tried that right now, and it works for me:
$ osc linkpac -f multimedia:libs libmatroska home:jirislaby:tumbleweed
Sending meta data...
Done.
Creating _link... Done.
$ osc api /source/multimedia:libs/libmatroska/ | \
sed -n 's@^.*linkinfo.*xsrcmd5="\([0-9a-f]*\)".*$@\1@ p'
7023adeac24e3401730a9731b340aac3
$ osc setlinkrev -r 7023adeac24e3401730a9731b340aac3
home:jirislaby:tumbleweed libmatroska
setting revision to 7023adeac24e3401730a9731b340aac3 for package libmatroska

Could you retry? (I tried midori too...)

regards,
--
js
suse labs
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups