Mailinglist Archive: opensuse-factory (505 mails)

< Previous Next >
[opensuse-factory] Re: using suse build service -- supposedly easy -- doesn't work at all (can't even checkout a package or see avail distros)
Tejas Guruswamy wrote:
the buildroot.

The default of this is /var/tmp/buildroot. It should make a difference where this is as long as it is accessible and writeable by you.
Yeah, but my /var/tmp only has about 5G free (it's only 7.8G total).
So I put it in a dir on /home...I knew the default, but my /var/tmp only has
5G/7.8G free,
'sides, my fastest would be /home, (or a few others on the same physical volume)
(my /home has 100's of gig free) -- to free up space on my /usr partition (15G),
I moved 'share' to /home/share, and use a -bind in my fstab to dup it onto
(meaning that broken 'bash' scripts in /etc/profile.d

Looking on the OBS, it doesn't look like you've successfully branched the package yet. What's your username?
On the website, after I branched it, I 'returned' my branch (deleted
since I was just using that from the wiki example.

Before I deleted it, I tried to list the branches and dists from the command line and still got the 404's.

(I was using the correct api addr to begin with, just that with things not
working, I tried "build...", soon as I figured out that wasn't right, I switched
it back to what it was previously. (

My non-comment params are:

apiurl =
packagecachedir = /home/packages/OSbuild/packagecache
su-wrapper = sudo
build-root = /home/packages/OSbuild/buildroot/
build-uid = caller
extra-pkgs = gvim vim gdb strace
plaintext_passwd = 0

Try 'osc bco openSUSE:Factory knock' again, what's the output (with the correct apiurl)?

osc bco openSUSE:Factory knock
Traceback (most recent call last):
File "/usr/bin/osc", line 21, in <module>
r =
File "/usr/lib/python2.7/site-packages/osc/", line 50, in run
return prg.main()
File "/usr/lib/python2.7/site-packages/osc/", line 309, in main
return self.cmd(args)
File "/usr/lib/python2.7/site-packages/osc/", line 332, in cmd
retval = self.onecmd(argv)
File "/usr/lib/python2.7/site-packages/osc/", line 448, in onecmd
return self._dispatch_cmd(handler, argv)
File "/usr/lib/python2.7/site-packages/osc/", line 1178, in
return handler(argv[0], opts, *args)
File "/usr/lib/python2.7/site-packages/osc/", line 2344, in
File "/usr/lib/python2.7/site-packages/osc/", line 4031, in branch_pkg
msg = msg.split('<summary>')[1]
IndexError: list index out of range

Well, it's different! But somehow I still don't think that's right...
Also tried:
osc co openSUSE:Factory knock
Server returned an error: HTTP Error 404: Not Found
Error getting meta for project 'openSUSE:Factory' package 'knock'

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
This Thread