Mailinglist Archive: opensuse-factory (838 mails)

< Previous Next >
Re: [opensuse-factory] openSUSE won't upgrade successfully from 11.3 to 11.4
Am Dienstag, 8. März 2011, 17:59:40 schrieb Larry Finger:
On 03/08/2011 10:14 AM, Stephan Kulow wrote:
Am Dienstag, 8. März 2011 schrieb Ralf Lang:
I just verified on two distinct installations that zypper dup from
11.3 to 11.4 will fail and break the package system by removing
liblzma. This might be a major pita when 11.4 is announced and the
average guy does an upgrade.

https://bugzilla.novell.com/show_bug.cgi?id=677678

OK, that bug should have a work around now. If someone could verify
(anyone still having 11.3? :) it would be fantastic.

The workaround in http://en.opensuse.org/openSUSE:Most_annoying_bugs_11.4
is good. If one does 'zypper up rpm' _before_ zypper dup, then it is OK.
That works from 11.3, 11.4 RC1 and 11.4 RC2.

To publicize the problem/workaround as much as possible, it was posted in
the opensuse.org.help.prerelease-beta forum, reposted in
o.o.h.install-boot-login, and added to http://tinyurl.com/64vyovj, the
Preinstallation FAQ.

How soon can the fix be put into the FTP upgrade sites? Once that is done,
the bug will no longer affect the people doing on-line upgrades, which
should cover the bulk of users. I, for one, never upgrade from the DVD.

I announced it to say that the FTP site is changed to work around the bug. The
actual fix is in zypper, but that will be 11.4+

Greetings, Stephan

--
Sent from openSUSE
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups