Mailinglist Archive: opensuse-factory (282 mails)

< Previous Next >
[opensuse-factory] Re: Compile problems
  • From: "Marco ''AlpVonKri'' Flores" <alpvonkri@xxxxxxxxxxxx>
  • Date: Sun, 3 Oct 2010 08:52:32 -0500
  • Message-id: <AANLkTina050O2Ud=aRbR0WbCMr8qwP+NzuS+m_T9MmpQ@xxxxxxxxxxxxxx>
Thanks to all for your advices, I solved the problem thanks to your
help, I found that I was compiling for KDE 4 and KDE 3, so this is how
the problem was solved:

./configure --with-distro=SUSE --disable-kde --enable-kde4
./download
make
bin/ooinstall /opt/libreoffice

And now I have this other error after all previously mentioned:

Config: --disable-binfilter --disable-crashdump --with-lang=""
--with-use-shell=bash --without-gpc --without-ag
--disable-fetch-external --with-vba-package-format=builtin
--disable-epm --with-openldap --with-build-version="libroffice-build
3.2.99.1" --without-fonts --with-system-jpeg --with-system-libxml
--with-system-mozilla --with-system-oenssl --with-system-python
--with-system-stdlibs --with-system-zlib --with-system-poppler
--with-unix-wrapper=ooffic3.3 --enable-evolution2 --enable-dbus
--with-alloc=system --enable-cairo=yes --enable-gtk --disable-kde
--enable-kde --with-vendor="Novell, Inc." --disable-access
--disable-odk --disable-qadevooo --enable-hids --enable-lockdown
--enble-minimizer --enable-mono --enable-opengl --enable-ogltrans
--enable-pdfimport --enable-presenter-console --enablereport-builder
--enable-wiki-publisher --without-stlport
--with-ant-home=/usr/share/ant
--with-external-dict-dir=/us/share/myspell
--with-external-hyph-dir=/usr/share/ooo/hyphen
--with-external-thes-dir=/usr/share/ooo/thesaurus
--wih-java-target-version=1.5 --with-jdk-home=$JAVA_HOME
--with-system-boost --with-system-cairo --with-system-curl
--wih-system-db --with-system-dicts --with-system-expat
--with-system-hunspell --with-system-icu --with-system-libwpd
--ith-system-libwpg --with-system-libwps --with-system-libxslt
--with-system-lpsolve --with-system-mozilla=libxul --wih-system-neon
--with-system-odbc-headers --with-system-sablot --with-system-xalan
--with-system-xerces --with-systemxml-apis
--with-system-xrender-headers --without-myspell-dicts
'--with-distro=SUSE' '--disable-kde' '--enable-kde4
ccache: no
icecream: no
distcc: no
Finishing the mono installation...
Failure adding assembly /opt/libreoffice/ure/lib/cli_basetypes.dll to
the cache: gac directories could not be create, possibly permission
issues.

Any ideas?

Best regards

On Sat, Oct 2, 2010 at 8:17 PM, Marco ''AlpVonKri'' Flores
<alpvonkri@xxxxxxxxxxxx> wrote:
Has anyone successfully compiled LibreOffice in openSUSE 11.3 with KDE
4, I'm stuck with a problem, I do the following:

./configure --with-distro=SUSE-11.2                *This is the mos recent
version, there is not 11.3 in the source
./download
make

And then it says:

...
checking for Qt headers... /usr/lib64/qt3/include
checking for Qt libraries... /usr/lib64/qt3/lib64
checking for moc... /usr/bin/moc
checking for KDE headers... no
configure: error: KDE headers not found.  Please specify the root of
your KDE installation by exporting KDEDIR before running "configure".
make: *** [stamp/build] Error 1


I have the packages "libkde4-devel & libkdecore4-devel" installed, so
why is this happening and how do I solve it, any help would be great.
:D

Best regards.


--
Marco "AlpVonKri" Flores
Computer Systems Engineer
Ing. Sistemas Computacionales
http://www.alpvonkri.co.cc
alpvonkri@xxxxxxxxxxxxxxx

openSUSE
Member ~ Ambassador ~ Weekly News
Miembro ~ Embajador ~ Noticias Semanales
http://wiki.opensuse.org/User:Alpvonkri
alpvonkri@xxxxxxxxxxxx




--
Marco "AlpVonKri" Flores
Computer Systems Engineer
Ing. Sistemas Computacionales
http://www.alpvonkri.co.cc
alpvonkri@xxxxxxxxxxxxxxx

openSUSE
Member ~ Ambassador ~ Weekly News
Miembro ~ Embajador ~ Noticias Semanales
http://wiki.opensuse.org/User:Alpvonkri
alpvonkri@xxxxxxxxxxxx
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
This Thread