Mailinglist Archive: opensuse-factory (487 mails)

< Previous Next >
Re: [opensuse-factory] Firefox won't start
  • From: Richard Creighton <ricreig@xxxxxxxxx>
  • Date: Thu, 6 May 2010 20:07:46 -0400
  • Message-id: <201005062007.46176.ricreig@xxxxxxxxx>
On Thursday 06 May 2010 18:29:55 s2_johnm wrote:
On 05/06/2010 01:34 PM, Richard Creighton wrote:
Ever since updating to >= 3.0 Firefox, I get some variation of the
following:


rcc@Athelon:~> firefox
returned PAC proxy string: direct
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to
enable).

** (firefox:10537): WARNING **: AT-SPI: Accessibility bus not found -
Using session bus.

/usr/bin/firefox: line 128: 10537 Segmentation fault $MOZ_PROGRAM
"$@" rcc@Athelon:~>

Of course, this is from a command line, From the 'kicker', I just get the
'bouncing ball" with no error message, after 30 seconds, it just
disappears with no firefox, no message, no nothing.

To restore Firefox, I have to reinstall, 2.5.9 or earlier, then, it works
again. Installing any version later than that results in failure to
start.

This is with 11.3 factory.

uname -a

Linux Athelon 2.6.34-rc5-6-default #1 SMP 2010-04-22 21:18:20 +0200 i686
athlon i386 GNU/Linux


Updated 6 May

Processor is an AMD 64 running 32bit Dual core mode 2 2G memory, LVM AND
RAID 5 (4 drive x 1Tb) + 3 1Tb drives in the / and /home LVM. This all
worked in 11.2 and 11.3 M4 and earlier until Firefox was updated beyond
2.5.9. Reverting Firefox causes the segfault to disappear, reinstalling
the 3.+ (latest) restores the segfault.

Now the squirrel...I have a virtually identical machine int the other
room with similar hardware and also running factory, that works! ...
but NFS won't run on it!!! The MBd is MSI but the CPU is an AMD...the
MBD on this one is an ASUS. I have another one (ASUS) that I haven't
upgraded yet...production machine, but another ASUS running 11.2 with no
problems. So, far, I'm not sure whether it is the kernel interacting
with Firefox or Firefox itself.

Any Ideas?

Richard

Ahh so i'm no the only one.. ;) sounds like:

http://bugzilla.novell.com/show_bug.cgi?id=600222

I haven't submitted a followup because i'm waiting to test M6
(downloadin' now...)

-johnm


Well, this *is* under M6, but in my case, it started after M4+. M4 bare was
OK, but shortly after, *something* zonked it. I don't know if it was an
update to Firefox itself or to the kernel. It first started by some of the
websites (mostly weather underground) where some of the icons they use
wouldn't display, then other things, then finally, entire pages, then firefox
itself wouldn't launch...then I went back to 2.5.9 and all was well again.

I still don't have a handle on just exactly *what* the problem is because on
the other machine, also running M6+, it seems to work. The only real
difference between these machines is this is an ASUS and the other is MSI
motherboard, both use NVIDIA chipsets for video, have 2-3G ram, use at least
1-4Tb raid5 Plus LVM. Both have problems with rsylogd, one has problems with
NFS, the other doesn't, one has problems with Firefox, the other doesn't (not
both the same) both are AMD dual core running 32bit versions of M6 but the
problem started while still running 11.2 in one case and persisted after an
upgrade while the other is a "clean install of M6". There is no consistant
pattern I can see except that M6 is the most cranky version of SuSe that I
have EVER tried to make run. 10.3, 11.1, 11.2 have all been cranky at times
but all have eventually been quite stable overall, but so far, except for M4,
this has been a nightmare. With too many fundemental changes under the hood
all at once, Xorg, Sax2, Firefox, uDev, PackageKit, ext4 , KDE4, Gnome3 or
whatever, and dammed knows whatall else major changes to fundemental "stuff".
This isn't even close to SuSE ELEVEN *anything* anymore, it is SuSE TWELVE dot
ZERO PRE ALPHA, which is fine, but call it what it is, for goodness sake.

Anyway, back to 2.5.9 again...I can't even get to Firefox to check the bug
600222 to see if I do or do not agree the bug is the same or similar <grin>.

Richard
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >