Mailinglist Archive: opensuse-factory (533 mails)

< Previous Next >
Re: [opensuse-factory] M6 and firefox
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Thu, 29 Apr 2010 05:55:14 +0200
  • Message-id: <4BD90322.1090902@xxxxxxxxxxxxx>
Hi,

Am 29.04.2010 00:08, schrieb Donn Washburn:

On 04/28/2010 02:15 PM, s2_johnm wrote:
On 04/28/2010 09:54 AM, Donn Washburn wrote:
Based on a desktop icon after a zypper dup to M6 firefox is no longer
found. It was /use/bin/firefox which is not linked or a script.
Click on the icon and nothing happens

Could it be this?: http://bugzilla.novell.com/show_bug.cgi?id=600222

try running firefox in a terminal and watch for errors.

Well if I had not created the script or link to
/usr/lib/firefox/firefox-bin (no firefox.sh was available). It would
have not worked in a terminal. "which firefox" showed blank. So no
firefox was in any "/bin" or "/sbin" directory or user $PATH

It looks like zypper dup removed /usr/bin/firefox and
/usr/lib/firefox/firefox.sh. Then RPM upgraded mozilla-firefox without
creating a new binary/script or link to /usr/lib/firefox

openSuSE may have changed the name to something else and I am looking in
the wrong spot

No. On Factory you should have mozilla-xulrunner192 and MozillaFirefox
RPM packages installed. And the latter should contain everything to be
able to start "firefox".

rpm -V MozillaFirefox to check what RPM has to say about it?


Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups