Mailinglist Archive: opensuse-factory (533 mails)

< Previous Next >
[opensuse-factory] Factory off-line upgrade
  • From: "Carlos E. R." <carlos.e.r@xxxxxxxxxxxx>
  • Date: Sun, 18 Apr 2010 21:40:10 +0200
  • Message-id: <4BCB601A.70402@xxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi,

For years I have been doing "off-line" factory upgrades. I explain.

Let's assume that factory is in /dev/sda9, and the production system is in
/dev/sda7. Instead of
booting factory, I boot the production system, which I continue using, and
attempt to upgrade the
factory partition from the running stable system. I do it that way because it
can take 10 hours to
run (slow internet), and days if it fails with repeated attempts and half
upgraded system.

The procedure is this:




mount /other/
mount --bind /proc /other/proc
mount --bind /sys /other/sys
mount --bind /dev /other/dev

cat /other/etc/SuSE-release
echo
echo " Copy paste the next line to activate prompt change:"
echo
echo "export PS1=$'\\[\E[1m\E[31m\\]Anor_chrooted_on_\\h:\\w #
\\[\E(B\E[m\\]'"
echo "export PBL_SKIP_BOOT_TEST=1"
# http://en.opensuse.org/Libzypp/Failover
echo "export ZYPP_ARIA2C=1"
echo "cd"
echo


chroot /other/ /bin/bash --login


Once I run that in an xterm, I can run "zypper up", then dup, etc. This I have
done for several
versions... till 11.3, it does not work. This is what I get:

Anor_chrooted_on_minas-tirith:~ # zypper up
Failed to open connection to "system" message bus: Failed to connect to socket
/var/run/dbus/system_bus_socket: Connection refused
Loading repository data...
Reading installed packages...

Nothing to do.
Anor_chrooted_on_minas-tirith:~ #


The file exists, but it doesn't work, not surprisingly.

Anor_chrooted_on_minas-tirith:~ # l /var/run/dbus/
total 12
drwxr-xr-x 3 messagebus messagebus 4096 Apr 18 04:38 ./
drwxr-xr-x 26 root root 4096 Apr 18 21:30 ../
drwxr-xr-x 2 root root 4096 Apr 18 04:38 at_console/
srwxrwxrwx 1 root root 0 Apr 18 03:45 system_bus_socket=


I wonder if I should bind that directory to the "host" equivalent directory?
Would that work? Is it
dangerous?

I tried, and it appears to run:

Anor_chrooted_on_minas-tirith:~ # zypper up
Loading repository data...
Reading installed packages...

Nothing to do.
Anor_chrooted_on_minas-tirith:~ #


Well, the nothing to do is because M5 has the distribution repos, not the
factory repos. I'll change
that and report.


- --
Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 "Emerald" GM (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iF4EAREIAAYFAkvLYBoACgkQja8UbcUWM1zlFQD+K6Q+bheILcACb+O1c2kaHHzm
9Q6wJCzt5swq1pRbpAgA/jx1GFIcIAf5kkTXcTXuLxx8fbjY2vxqa1YLdxPj30Dh
=qK3a
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups