Mailinglist Archive: opensuse-factory (533 mails)

< Previous Next >
Re: [opensuse-factory] Coordinated upgrade to jack2 for FACTORY / 11.3
  • From: Dave Plater <dplater@xxxxxxxxxxxxxxxx>
  • Date: Fri, 09 Apr 2010 21:25:17 +0200
  • Message-id: <4BBF7F1D.3020007@xxxxxxxxxxxxxxxx>
On 04/08/2010 08:15 PM, Sid Boyce wrote:
On 08/04/10 16:28, Takashi Iwai wrote:

At Tue, 06 Apr 2010 10:58:23 +0200,
Dave Plater wrote:

On 04/06/2010 08:21 AM, Takashi Iwai wrote:

At Tue, 06 Apr 2010 07:22:47 +0200,
Dave Plater wrote:


On 04/06/2010 03:49 AM, Sid Boyce wrote:


On 05/04/10 18:09, Takashi Iwai wrote:



Hi,

I got a contact from Debian Multimedia team about the possibility of
coordinated upgrade of JACK package from version 1 to version 2 on
SUSE. That is, major distros, Debian, Ubuntu, and others will upgrade
the package for jack simultaneously in order to avoid confusion among
distros.

From the technical viewpoint, there shouldn't be big obstacles for
us -- JACK2 is ABI compatible with JACK1, and it's being used already
on Packman repo, IIRC. I think Dave already has managed jack2 stuff
in his repo for some time, too. Thus the movement should be
relatively simple.

But, my question here is whether this is allowed now for FACTORY /
11.3 at this moment. I know this kind of thing should have been
handled through FATE. But if we do this, it should be done quickly in
a timely manner. So, I'm asking just here for a quick decision.

Comments appreciated.


thanks,

Takashi



One of my SDR programs (sdr-shell) has needed jack2 for quite a while
now and I have been building and using it locally from svn using waf.
Something in Milestone 4 causes it to fail, probably an option problem
which I am currently trying to track down.
I for one would welcome its inclusion.
# jackd --version

snip
Aborted
Regards
Sid.



I have a fully functional jack2 ready for submission it's a drop in
replacement for the existing jack. I was originally going to submit it
as an update for jack but I've put it in multimedia:libs. There's a
"|shared-lib-calls-exit" rpmlint error I must fix before submission to
factory.


Thanks.

I just took a quick look. One thing to be fixed is the package name.
It should be rather libjack0 instead of libjack2. The shlib package
name is defined simply from the so version number.

For devel, keep libjack-devel. Since JACK1 and JACK2 are exclusive,
there is no big reason to keep both devel packages parallel
installable.

Could you fix these?


Takashi


Jack2 cleanly replaces the jack package with provides and obsoletes
because they cannot exist together. Jack2 provides exactly the same
functions and binaries as jack plus libjackserver this is why it's also
an update candidate for the existing jack, the tarball is even called
plain jack. I'm preparing my home project jack2 to update jack if this
is the way to go.

I submitted the updated jack-1.9.5 to FACTORY now.


Takashi

It's not showed up so far, will check again later.
Regards
Sid.


It;s still waiting sr 37393 created 2010-04-08T17:25:39 but you can get
it in the multimedia:libs repo meanwhile, exactly the same build as
factory standard..
Regards
Dave P
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >