Mailinglist Archive: opensuse-factory (661 mails)

< Previous Next >
Re: [opensuse-factory] Builds not against current perl 5.10.1
  • From: Stephan Kulow <coolo@xxxxxxxxxx>
  • Date: Thu, 17 Dec 2009 10:30:56 +0100
  • Message-id: <200912171030.56863.coolo@xxxxxxxxxx>
Am Donnerstag 17 Dezember 2009 schrieb Gerald Pfeifer:
On Thu, 26 Nov 2009, Ladislav Slezak wrote:
I guess it fails because of yast2-perl-bindings, this package doesn't
have versioned dependency (as yast2-core):

# rpm -q --requires yast2-core | grep perl
perl = 5.10.1
/usr/bin/perl
# rpm -q --requires yast2-perl-bindings | grep perl
perl
perl(Locale::gettext)
libperl.so()(64bit)

Why do we, in general, have so many strict version dependencies, as
opposed to at least >= ? Looking at the troubles with factory updates
in the last half year, this has been constantly hitting us across the
board.

What do you prefer? Zypper telling you that you can't update or happy update
and tons of runtime errors? So far we went for "the truth".

Greetings, Stephan
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References