Mailinglist Archive: opensuse-factory (661 mails)

< Previous Next >
Re: [opensuse-factory] Builds not against current perl 5.10.1
  • From: Gerald Pfeifer <gp@xxxxxxxxxx>
  • Date: Thu, 17 Dec 2009 14:49:27 +0800 (CIT)
  • Message-id: <alpine.LNX.2.00.0912132111460.3804@xxxxxxxxxxxxx>
On Thu, 26 Nov 2009, Ladislav Slezak wrote:
I guess it fails because of yast2-perl-bindings, this package doesn't
have versioned dependency (as yast2-core):

# rpm -q --requires yast2-core | grep perl
perl = 5.10.1
/usr/bin/perl
# rpm -q --requires yast2-perl-bindings | grep perl
perl
perl(Locale::gettext)
libperl.so()(64bit)

Why do we, in general, have so many strict version dependencies, as
opposed to at least >= ? Looking at the troubles with factory updates
in the last half year, this has been constantly hitting us across the
board.

Gerald
--
Dr. Gerald Pfeifer gp@xxxxxxxxxx | SUSE Linux Products GmbH
Director Product Management | HRB 16746 (AG Nuremberg)
SUSE Linux Enterprise, openSUSE, Appliances | GF Markus Rex
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >