Mailinglist Archive: opensuse-factory (661 mails)

< Previous Next >
Re: [opensuse-factory] Kernel Mode Setting (KMS) for openSUSE.
  • From: Stefan Seyfried <stefan.seyfried@xxxxxxxxxxxxxx>
  • Date: Thu, 10 Dec 2009 13:41:57 +0100
  • Message-id: <20091210134157.0237c269@xxxxxxxxxxxxxxxxxxxx>
Hi Egbert,

might be a stupid question, but I'll ask it anyway ;)

Running plain FACTORY (without your fancy kernel package etc.), I can
boot with "vga=0", then when the system is running (in runlevel 3), I
can "modprobe radeon modeset=1" and I will get a beautiful 1400x1050
framebuffer.

Then I can start X ("X :0 -retro") and get a nice X server. However,
switching back to the text console seems to blank the screen shortly,
and I still get the occasional "synchronization loss" on the built-in
panel (Matthias knows what I'm talking about). Switching VT to X and
back still solves this (phew! we anticipated that with kms, once the
pll is screwed there would be no way to recover short of a reboot).

So I guess that KMS is not working well in this setup, since some PLL
is still reprogrammed (and sometimes this fails).

All on an oldish ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Now I wanted to put the module in the initrd, however, loading it from
"init=/bin/bash" (I tried that first, just to make sure) gives me a
kernel backtrace and basically kills the box.

Is this all the fault of me not running your pimped packages or is
there something more fundamentally borken on this old and incredibly
slow radeon card? (the driver is so slow, that I hoped I could use KMS
and then fbdev X server - it can only get faster).
--
Stefan Seyfried

"Theory and practice sometimes clash. And when that happens,
theory loses. Every single time." -- Linus Torvalds
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References