Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] Builds not against current perl 5.10.1
  • From: Ladislav Slezak <lslezak@xxxxxxx>
  • Date: Thu, 26 Nov 2009 09:19:53 +0100
  • Message-id: <4B0E3A29.5020700@xxxxxxx>
On 25.11.2009 21:38, Patrick Shanahan wrote:
* Cristian Rodríguez <crrodriguez@xxxxxxxxxxxx> [11-25-09 15:26]:
On 25/11/09 13:12, Patrick Shanahan wrote:


It doesn't work :^(

Yeah, it may not work, patience is a virtue, several packages fail to
build due to perl upgrade, it will take some time to fix them.

Patience will persevere, but explanation softens the hurt :^)

tks for that.

Still wondering the argument that yast is not broken, itself, with its
failure to execute having the correct requirements present. Namely that
yast2-core requires perl = 5.10.0, which is present and yast fails.

I guess it fails because of yast2-perl-bindings, this package doesn't have
versioned dependency (as yast2-core):

# rpm -q --requires yast2-core | grep perl
perl = 5.10.1
/usr/bin/perl
# rpm -q --requires yast2-perl-bindings | grep perl
perl
perl(Locale::gettext)
libperl.so()(64bit)
# rpm -q yast2-core yast2-perl-bindings
yast2-core-2.18.19-22.3.x86_64
yast2-perl-bindings-2.18.0-4.2.x86_64

I'll fix that...

--

Best Regards

Ladislav Slezák
Yast Developer
------------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: lslezak@xxxxxxx
Lihovarská 1060/12 tel: +420 284 028 960
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >