Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] 11.1 -> 11.2 upgrade breaks keyboard
  • From: Martin Vuk <mrcin.vuk@xxxxxxxxx>
  • Date: Mon, 23 Nov 2009 14:12:51 +0100
  • Message-id: <6c8c06d20911230512y1e88df3cw68f8abce4512de03@xxxxxxxxxxxxxx>
Hi,

I've had the same problem, the keyboard only working in console and
not in X. I've followed the comment in /etc/X11/xorg.conf
# Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"'
# is set in "ServerFlags" section.
and added
Option "AutoAddDevices" "off"

in ServerFlags section and copied InputDevice sections from the old xorg.conf.
But then I guess autodetecting of input devices, such as tablets,
would not work anymore.

Best Martin

On Sat, Nov 14, 2009 at 1:36 PM, Donn Washburn <n5xwb@xxxxxxxxxxx> wrote:
On 11/14/2009 04:51 AM, Herbert Graeber wrote:

Am Donnerstag 12 November 2009 23:11:37 schrieb Robert Schweikert:


I just completed an in place upgrade using "zypper dup" from 11.1 to
11.2 on a Lenovo T400 machine. The machine boots and the keyboard works
in the grub menu. However, there is no response to keyboard input at the
login prompt.

Using GNOME with GDM, touchpad and buttons work.

Now I am locked out of the machine. Any ideas on how to fix this?


I had this problem, too. The answer was on planetsuse:

       http://woelfisch.livejournal.com/103326.html

In short: The commands

       zypper in -f hal
       rchal restart           (not sure if this is neccessary)

fixed it for me.

Herbert


I think this problem is different than mine.

In a console I think the defined keyboard is either wrong or broken.
I get in a console as root at the command line as I type.  On the right side
of the screen as an extension of the typed line a whole bunch of brightly
colored blocks with random characters in the blocks.  They seem to appear
after hitting the back space key or delete key and then the text editing is
not displayed correctly.  Yast2 shows the keyboard to be a "english-us,
pc-104", and vga=0x318
This problem is in openSuSE 11.2 RC2 and has never been seen before.  No
problem with the keyboard is seen in "X"

--
73 de Donn Washburn
307 Savoy Street     Email:" n5xwb@xxxxxxxxxxx "
Sugar Land, TX 77478 LL# 1.281.242.3256
Ham Callsign N5XWB   HAMs : " n5xwb@xxxxxxxx "
VoIP via Gizmo: bmw_87kbike / via Skype: n5xwbg
BMW MOA #: 4146 - Ambassador
     " http://counter.li.org " #279316

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >