Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] unexpected / undocumented question during 11.1 -> 11.2 upgrade
  • From: Jano Kupec <jkupec@xxxxxxx>
  • Date: Tue, 10 Nov 2009 12:51:37 +0100
  • Message-id: <4AF953C9.8070109@xxxxxxx>
On 11/10/2009 10:15 AM, A R wrote:
Hey Greg,

You have to, otherwise upgrading won't work ;)
Don't forget your other repositories (Packman, KDE4 and all the others).
You have to adapt repository Path to 11.2, too

I'm trying to follow the actual instructions which say to disable all
repos. Then I added only the 3 11.2 repos listed.

In this case all other packages from those repos may behave unexpected, but

It is the results of zypper in zypper that I find very unexpected.

I skipped this information

I'm just trying upgrade one package "zypper". I was not expecting 172
MB of download and what looks like hundreds of packages to be upgraded
/ downgraded.

You can take a look on the list of depencies of zypper. Those packages have
other dependencies as well. I am not surprised that hundrets of packages need
to be upgraded and I suppose that's the reason why the new version of zypper
is not available for 11.1.

Exactly. Zypper requires e.g. newer libzypp. And e.g. yast depends on
libzypp - that's why many yast packages must be pulled in, too. And it
goes similarly for the rest.

--
cheers,
jano


Ján Kupec
YaST team
---------------------------------------------------------(PGP)---
Key ID: 637EE901
Fingerprint: 93B9 C79B 2D20 51C3 800B E09B 8048 46A6 637E E901
---------------------------------------------------------(IRC)---
Server: irc.freenode.net
Nick: jniq
Channels: #zypp #yast #suse #susecz
---------------------------------------------------------(EOF)---

< Previous Next >