Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] unexpected / undocumented question during 11.1 -> 11.2 upgrade
  • From: Jano Kupec <jkupec@xxxxxxx>
  • Date: Tue, 10 Nov 2009 12:46:53 +0100
  • Message-id: <4AF952AD.9030108@xxxxxxx>
On 11/09/2009 09:50 PM, Greg Freemyer wrote:
Okay,

I decided to try out the <http://en.opensuse.org/Upgrade/11.2> process
via zypper. (I had been testing wagon, because I assumed others were
testing zyperr.)

Remember upgrade via zypper dup and wagon are both now supported.
This is not at all what I expected.

I first updated my repos as requested in:
<http://en.opensuse.org/Upgrade/11.2#CLI>

I then disabled the old repos and added the 11.2 repos. (See detail 1
below my sig for exactly how my repos were setup.)

I then tried the last of the preparation steps:

zypper refresh # Refresh the local metadata and repo contents
zypper in zypper # Pull in zypper from the 11.2 repository

It is the results of zypper in zypper that I find very unexpected.

At a minimum the Upgrade page needs to warn users to expect this
extreme behavior is what is expected. See below:

gaf@tiger3-64bit:~> sudo zypper in zypper
...
Overall download size: 172.8 M. After the operation, additional 53.4 M
will be used.
Continue? [Y/n/p/?]:

===============
Is that all right?

Maybe it is, but it's a lot of packages. I would at least be suspicious
and tried to enter 'p' here (which is basically the same as 'n' and then
'zypper in --no-force-resolution zypper') to find out what triggered
installation of those many packages.

--
cheers,
jano


Ján Kupec
YaST team
---------------------------------------------------------(PGP)---
Key ID: 637EE901
Fingerprint: 93B9 C79B 2D20 51C3 800B E09B 8048 46A6 637E E901
---------------------------------------------------------(IRC)---
Server: irc.freenode.net
Nick: jniq
Channels: #zypp #yast #suse #susecz
---------------------------------------------------------(EOF)---

< Previous Next >
References