Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] Feature #308284: Ship openSUSE 11.2
  • From: Rob OpenSuSE <rob.opensuse.linux@xxxxxxxxxxxxxx>
  • Date: Fri, 6 Nov 2009 03:34:54 +0000
  • Message-id: <ce9d8ed60911051934kf14de05l9237856bd172b6bb@xxxxxxxxxxxxxx>
2009/11/5 Clayton <smaug42@xxxxxxxxx>:
I have never seen a Fedora or Ubuntu release which could boot an
openSUSE installation either (Things may have changed with this year's
versions, but I have not bothered trying them as yet.)

Really? Interesting.  I've done many mutiboot installs, and they've
always worked... even with 6 or 8 different Linux versions.  Each
successive install was able to "find" the previous and in the end the
last install had a kind of "master" Grub.  In my case that last
install was always openSUSE since I prefer the Grub menu we have to
others.

Anyway, those that are responsible for the Grub fixes have stated that
this situation isn't going to change for the 11.2 release - I
understand the reasoning... I don't agree with the decision, but
hey... that's life :-)

I've often done this, but always worked the other way round, basically
used a Master /boot & GRUB installation and just required the later
installs to create a clean /boot example. So I didn't see the issue
that you have, I just never have seen any sign of that sort of thing
working, well reliably enough for me.

Now actually I considered that bug & others before voting, and decided
on balance, it is not so serious, in scheme of installation bugs
past. When a Linux install stops Windows booting it is worse as they
may require installation media, someone with multiple Linux installs
is perfectly capable of booting with a Live CD (possibly with forum
help) fixing up the GRUB entries, or using GRUB's interactive features
to boot a working kernel.

In a way, the complete failure to boot with just a dark screen, I see
on the laptop I write this appears worse. Anyone trying GM CD/DVD is
just going to see a boot failure, right after Linux loads when
initialisting PCI stuff. Then likely give up on Linux, as all the
2.6.31 kernels I've tried so far fail in same way.

The only way around this type of issue, is to offer an alternative
older kernel, which has drawback of complicating userspace, when
features like ext4 won't be available.

Rob
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >