Mailinglist Archive: opensuse-factory (594 mails)

< Previous Next >
Re: [opensuse-factory] There is no driver for AMD K10 thermal sensors yet
  • From: Juan Erbes <jerbes@xxxxxxxxx>
  • Date: Wed, 9 Sep 2009 08:47:46 -0300
  • Message-id: <61ec494a0909090447u343d6ee1ia90f4c16283b9fab@xxxxxxxxxxxxxx>
2009/9/9 Tejas Guruswamy <masterpatricko@xxxxxxxxx>:
Juan Erbes wrote:
AMD K10 thermal sensors...                                  Success!
    (driver `to-be-written')

If you read carefully the "driver" is called "to-be-written" - fairly
self-explanatory.
And with surprise, I got at the end:
Note: there is no driver for AMD K10 thermal sensors yet.
The detection code is ready, the driver kernel module itself is not yet
ready. The lm_sensors wiki says as of 2008-11-10 it is a WIP
<http://lists.lm-sensors.org/pipermail/lm-sensors/2008-October/024308.html>.
Hopefully it was not abandoned, this is now almost one year later ...

http://lkml.org/lkml/2008/11/15/63 suggests it should have made it into
2.6.29, but looks like it didn't.

If you do some web searching for "k10temp" you can find some code
patches that apparently work, but I have no experience with them. YMMV.
Compilation instructions are here: http://blog.morrigan.ch/?p=9 though I
think it is using an older version of the k10temp source.

Regards,

Tejas
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx




Many Thanks. I will try it.

Regards,
Juan
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >