Mailinglist Archive: opensuse-factory (1233 mails)

< Previous Next >
Re: [opensuse-factory] Compiz openSUSE 11.0 Beta 5 anyone working with Nvidia driver?
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Sat, 22 Nov 2008 02:42:38 -0600
  • Message-id: <4927C5FE.8060700@xxxxxxxxxxxxxxxxxx>
Ben Kevan wrote:
On Thursday 20 November 2008 10:44:04 pm you wrote:
Ben Kevan wrote:
Hey folks,

I just wanted to see if the problem was with compiz, or with my nvidia
driver ( i haven't yet tried the nv driver) have gotten compiz from the
oss repository working on their box.. None of my compiz decorations
start, and none of the compiz features actually work.

I just want to see if it's a bigger problem then I expected.

Ben
Ben,

I am using compiz on 11.1 Beta5 with the nvidia driver on an 8800GT.
Other
than the ksnapshot snafu, everything else works fine until the black screen
of death appears. All cube/cylinder/sphere/scale/app switcher/etc.. with
Emerald decorations. I'm starting compiz with compiz-manager:

20:45 arete~> cat bin/ccpstart
#!/bin/bash
compiz-manager --ignore-desktop-hints --sm-disable --indirect-rendering
--replace & exit 0

Since nobody built fusion-icon for 11.1 I think that's what we are stuck
with. The packages in 11.1 Beta 5 or from X11:/Compiz are the same. (Damn I
miss that handy little icon...)

Really one of my overall problems is that the GLX option will NOT stay.
Everytime I click it, it jus unchecks. This option is not in the Compiz
without nomad.

/usr/lib/compiz/libglx.so exists so why isn't GLX working?

NVRM version: NVIDIA UNIX x86 Kernel Module 177.82 Tue Nov 4 13:35:57 PST
2008
GCC version: gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)

Model: Quadro NVS 110M
IRQ: 16
Video BIOS: 05.72.22.21.fe
Card Type: PCI-E
DMA Size: 39 bits
DMA Mask: 0x7fffffffff
Bus Location: 01.00.0


The 110M is the 7300 also.



That frustrating problem with the check boxes clearing hasn't bitten me
thus
far on 11.1. The last time it did, I think the procedure was to:

cd ~/.config

mv compiz compiz.sav

and start trying again. I know I must have had 3 or 4 different 0.7.8
installs
on 11.0 that did that to me. There isn't any true "this solved it answer" I
would blow away the complete compiz install and re-install from XGL and try -
still no luck. I would mv ~/.config/compiz - same result. They I would do the
same thing and it would work. So I always got it fixed, but it was pure trial
and error. The good thing was that once I got it fixed, it would stay fixed
until the next compiz update.

What does compiz say then you start it in an xterm from the command
line with
compiz-manager --replace or with compiz --replace --sm-disable
--ignore-desktop-hints ccp --indirect-rendering &



--
David C. Rankin, J.D.,P.E. |
Rankin Law Firm, PLLC | Countdown for openSuSE 11.1
www.rankinlawfirm.com | http://counter.opensuse.org/11.1/small

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >